Studio 2011 - Auto-propagating and numbers!
Thread poster: Bodil Little

Bodil Little  Identity Verified
Denmark
Local time: 03:49
Member (2002)
English to Danish
+ ...
May 27, 2013

I have an annoying problem.

I am currently translating a huge file from English to Danish with lots of tables. In these tables, I have to add a space between the number and the percentage sign in my translation. I do this, confirm the segment, and then Studio auto-propagates and removes all the spaces. How do I lock in the correct translations and have the program auto-propagate the correct translation?


 

Heinrich Pesch  Identity Verified
Finland
Local time: 04:49
Member (2003)
Finnish to German
+ ...
What I would do May 27, 2013

I would switch off auto-propagation, if it behaves as you described. Then I would search and replace all "%" with " %" and, if necessary, remove all double spaces.

 

Bernard Lieber  Identity Verified
Local time: 03:49
English to French
+ ...
TermInjector May 27, 2013

Hi Bodil,

Download TermInjector (OpenExchange) and add the following to the Regular Expression Rule File (save as UTF-8)

([0-9]+).([0-9]+)% \1,\2 %

This string replaces the period as decimal separator and adds a non-breaking space between the last figure and the % sign, you may have to customise it to suit your needs. I use this string for English to French.

HTH,

Bernard


 

Géraldine Chantegrel  Identity Verified
France
Local time: 03:49
Member (2007)
German to French
+ ...
In the Projet Settings May 27, 2013

Hi,

Go to Projet Settings -> Language pairs -> [Choose you current language pair] -> Auto-Substitute - > Measures
(Sorry if the Option names are not exactly the right ones, my Studio is in French!)

There you can choose to always insert a non-breakable space between number and unit, to always use the same spacing as in target document, etc.
With a bit of luck, it will also apply to the % sign!


 

Bernard Lieber  Identity Verified
Local time: 03:49
English to French
+ ...
I'd really like to see it working! May 27, 2013

Hi there,

As far as I can see the suggested setting has never worked at all whether in 2009 or 2011. In addition, if the segment contains the slightest bit of text, i.e. Less than and or more than 5.5% - Studio regardless of the version is at complete loss.

This can be fully automated with TermInjector, I haven't typed a single number for months on end with really simple Expression Rules.

Cheers,

Bernard


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio 2011 - Auto-propagating and numbers!

Advanced search







Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search