Trados Studio 2011: "The specified path, file name, or both are too long" error
Thread poster: Jerzy Ozana

Jerzy Ozana  Identity Verified
Poland
Local time: 22:03
Member (2007)
English to Polish
+ ...
Jul 13, 2013

When I try to open a Studio package under Windows XP SP3, I get the following error: "The specified path, file name, or both are too long. The fully qualified file name must be less than 260 characters, and the directory name must be less than 248 characters." I manually renamed the package to zip and checked its contents: it does contain several dozen files and nested folders, so there is a chance that the combined folder path may exceed the directory name length limit described in the error message above.

The key issue is that I do not even get to the main Open Package dialogue window, the error pops up when I try to open a package, so the solution described here http://kb.sdl.com/?portalid=23&articleid=3854#tab:homeTab:crumb:7:artId:3854 does not work, since I am not given a chance to change the project folder. My guess is that perhaps Studio creates some temporary project folders before displaying the main Open Package dialogue window and this is when the Windows path length restriction is violated and this error is displayed.

I realize this error was already discussed in this forum (e.g. in this thread: http://www.proz.com/forum/sdl_trados_support/215200-specified_path_too_long_error.html), but so far I have found no solution that would work in my case.

I cannot manually copy the contents of the package and create a new project from scratch, as the package contains quite a few project settings (such as online project TM etc.).

I use Studio 2011 SP2R 10.2.3046.0.

Does anyone have an idea for a solution/workaround for this problem?


 

Mads Grøftehauge  Identity Verified
Local time: 22:03
English to Danish
+ ...
I have the same problem - the Browse For Folder dialog box is never displayed Nov 6, 2013

Jerzy Ozana wrote:

The key issue is that I do not even get to the main Open Package dialogue window, the error pops up when I try to open a package, so the solution described here http://kb.sdl.com/?portalid=23&articleid=3854#tab:homeTab:crumb:7:artId:3854 does not work, since I am not given a chance to change the project folder.



Did you find a solution for this? My problem is also that Trados creates the same folder with a long name instead of displaying the Browse For Folder dialog box.
I suppose my client could rename the project, but not before tomorrow.


 

Daniel García
English to Spanish
+ ...
Location of temp folder Nov 6, 2013

The problem might be in the location of your TEMP folder.

I had similar case and the problem was that Studio was copying files and creating folders in my temp folder.

The temp folder is located by default in Windows in a deep structure under your user profile. When Studio opens the package, it must probably try to copy first the files and folders to your TEMP folder and this might create too long folder structures.

The procedure to change the location of your TEMP folder will be different depending on your Windows version here are some instructions for Windows 7:

http://www.wikihow.com/Change-Location-of-the-Temp-Folder-in-Windows-7

Good luck!

Daniel


 

Jerzy Ozana  Identity Verified
Poland
Local time: 22:03
Member (2007)
English to Polish
+ ...
TOPIC STARTER
No solution found Nov 6, 2013

No, unfortunately I did not. I emailed a local SDL reseller, but the only advice they could offer (other than sending them the package, which I could not due to confidentiality of this text) was to manually extract the contents of the package and process them separately.

I ended up translating this project on my laptop, as Studio 2011 opened the package without any problems under Vista.

Perhaps the solution offered by Daniel will work?


 

Mads Grøftehauge  Identity Verified
Local time: 22:03
English to Danish
+ ...
Changing Temp location didn't fix it Nov 7, 2013

Thanks guys.

I went to My Computer>Properties>Advanced>Environment Variables and tried changing the user variable path for the Temp folder from %USERPROFILE%\Local Settings\Temp to C:\Temp and rebooted, but unfortunately Trados still won't open the package. (This is Windows XP and Studio 2011).

I'll ask the client not to make 90 character project names some other time, but right now I'm afraid the job will go to someone else if that's easier for them than changing the project name just for me.

I'm guessing SDL's solution would be for me to throw money at the problem in the form of upgrades.

icon_frown.gif Mads

(PS: Note that there is a difference between the (internal) project name and the project package file name. You can change the latter all you want; it won't make any difference.)


 

Mads Grøftehauge  Identity Verified
Local time: 22:03
English to Danish
+ ...
Workaround Nov 7, 2013

I found a workaround!

Using Windows Explorer I just made a tiny change to the name of the folder containing the project, so Trados 'forgot' where to save the project, bringing back the Browse Folder window and allowing me to set a shorter path.

Now I just have to save all my future projects in a location and folder name that isn't optimal for me in terms of back-up, naming conventions, and logic.
Oh, and the €400 job went to someone else.


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados Studio 2011: "The specified path, file name, or both are too long" error

Advanced search







Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search