Help! Target file is bilingual in .txt-format (studio 2014)
Thread poster: Joseph Leist
Joseph Leist
Sweden
Local time: 17:02
Swedish to German
+ ...
Oct 9, 2013

Just upgraded to 2014 and am now having aproblem when saving the target file:

When saving the target file in the .txt-file format, I get a bilingual file, as in both languages are present in the file, though I only want the target language.

This only applies to .txt-files, when I translate a .doc-file, I do not have this problem...

Any solutions?


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 17:02
Member (2010)
Spanish to English
txt or ttx? Oct 9, 2013

If you mean TTX, not TXT, then the solution is to "Save as" (shift F12) and you save the bilingual TTX, and then again, (2nd in the list) to save in native format.

Of course, you need to have the original source file to be able to save the target-only file.

Does that help?
Emma


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 17:02
English
Looks like TXT Delimited and not TXT Oct 9, 2013

Hi,

There are two out of the box TXT files in Studio. One is the TXT Delimited that allows you to keep the source text in the target file and have the target placed in there too.

The other is the regex based TXT filetype that allows you to extract whatever text you like from the file.

You probably need to use the latter, but I guess you are using the former.

Either disable the TXT Delimited when you create the Project or place it lower in the list of filetypes so the regex based TXT filetype is selected first.

Regards

Paul


Direct link Reply with quote
 
Joseph Leist
Sweden
Local time: 17:02
Swedish to German
+ ...
TOPIC STARTER
That worked! Oct 9, 2013

Thanks Paul (might have gotten the solution vie e-mail from you es well, how many Pauls can there be working at SDL?).

Anyhow, you were correct and this solved my problem. Thaks for the quick reply!

And thank you as well for your reply, Emma, even though Pauls solution did work for me.

[Edited at 2013-10-09 10:05 GMT]


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 17:02
English
Pauls at SDL ;-) Oct 9, 2013

josephleist wrote:

Thanks Paul (might have gotten the solution vie e-mail from you es well, how many Pauls can there be working at SDL?).



... 25.

But it was me!

Regards

Paul


Direct link Reply with quote
 

Bob McAvoy
United States
Local time: 10:02
English
Same for me, my solution was ... Oct 22, 2013

Hi Joseph,

My solution was slightly different, nonetheless along same line as Paul's wise advice. I'm very glad his solution worked for you plus on the same day no less.

Simply in event others incur this same thing, I'll elaborate what quick solution I did today. Ultimately I changed my native tab-delimited TXT over to a "Plaintext" (txt) file ... applied my TM ... then export. Resulting in a my desired single language; instead of a bilingual.

(1) Save existing work to a Translation Memory
(2) I opened my source TXT within an standard text editor
** In MS Word / MS WordPad >> open source >> save as "Windows" encoding (not "MS-DOS" text encoding) >> Save as >> TXT
** In NotePad++ >> open source >> Save as >> TXT
(3) I opened my existing SDL Studio 2014 Project, included additional source file as "filename_plaintext.txt"
(4) Batch task >> "Prepare" ... including my saved TM
(5) Prepare Target via: File >> Save Target as ... or ... Batch >> Export.

Cheers,
Bob
SDL Support


Techie notes: The "file type" pattern SDL Studio identified in a existing project is visible by several mean. On a TXT file, it usually is read as a Tab Delimited v 2.0.0.0 or Plaintext v 1.0.0.0. Delimited tab and comma separated files are sometimes used for bilingual import/export purposes.
_1_ In SDL Studio 2009/2011/2014: Click "Files" on far left >> tab at bottom "File Details" >> "File Type Identifier".
_2_ Depending on your column view settings, this info can be visible on your "files" screen within the column "File Type Identifier".
_3_ Alternatively, the plaintext icon happens to be a ever so slightly smaller in comparison to Tab-D-TXT icon.


Direct link Reply with quote
 

Sandrine Guyennet
Ireland
Local time: 16:02
Member (2014)
English to French
How to disable the TTX Delimited Dec 27, 2013

SDL Support wrote:

Hi,

There are two out of the box TXT files in Studio. One is the TXT Delimited that allows you to keep the source text in the target file and have the target placed in there too.

The other is the regex based TXT filetype that allows you to extract whatever text you like from the file.

You probably need to use the latter, but I guess you are using the former.

Either disable the TXT Delimited when you create the Project or place it lower in the list of filetypes so the regex based TXT filetype is selected first.

Regards

Paul


Hi,

How do you disable the TXT Delimited when created a project? I don't see file types in the options. If I go to File/Options/File types I can't see any way to disable a file type.

Thanks


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 17:02
English
You just... Dec 28, 2013

Sandrine Bibolet wrote:

Hi,

How do you disable the TXT Delimited when created a project? I don't see file types in the options. If I go to File/Options/File types I can't see any way to disable a file type.

Thanks


... click on File TYpes on the left and then you will see all the filetypes listed on the right with a checkbox ticked against each one. Untick the ones you don't want to be used.

Regards

Paul


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Help! Target file is bilingual in .txt-format (studio 2014)

Advanced search







memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search