SDLXLIFF validation error: Invalid character in the given encoding
Thread poster: tradestlyon

Local time: 00:41
French to Russian
Oct 10, 2013

Dear colleagues,

I work with Studio 2011 SP2R and I cannot use any of the translated sdlxliff files sent from a colleague.
When I try to open her files, I always get the same message "Unexpected error when detecting the file type... Data at the root level is invalid. Line 1, position 1".

After some investigations, I opened the file with the NotePad and saw a "?" at the very beginning of the first line.

I deleted this question mark and the opening process could go a bit further (the source - French- and target - English- languages are detected), but I finally got an error message stating "Invalid character in the given encoding. Line xxx, position xxx".

When I analyse her files in an XML editor, I can see the French diacritics (é, è, à, etc.) look corrupted.

I even tried to create the sdlxliff files on my computer, then send her the files (individually or through a package), but the results remain the same: I cannot use the files once she worked on them.
Even the translations memories are corrupted since I get another error messages each time I try to import an TMX export. The only solutionis to reuse her own .sdltm file, then pretranslate, which is not convenient at all.

The strange thing is that she is the only person with whom I happen to encounter the problem.
And I am the only person with whom she has the problem too.

Does anyone have an idea on how to solve this probably encoding problem? I would be most grateful for any help ! Thank you


[Modifié le 2013-10-10 16:29 GMT]

Direct link Reply with quote

Local time: 00:41
French to Russian
help needed - Really no-one experiencing the same problem? Oct 25, 2013

Hello to all,

Am I really the only one with that problem?
In the meantime, two other colleagues sent files which I can't open due to the same problem.
I have parsed the files with XML editor which states invalid characters are present in the files.
Is there anything to do here with Windows versions? with installed languages?

Thank you for any tip


Direct link Reply with quote

Alison High  Identity Verified
Local time: 00:41
Member (2003)
French to English
+ ...
So did you find a solution? Feb 27, 2015

Hi, same problem here, only I'm the translator doing the sending with Trados 2014 and the other person has Trados 2011.

You had this problem 2 years ago, surely you've found the solution by now?

If you have, please post it for the rest of us.

Direct link Reply with quote

To report site rules violations or get help, contact a site moderator:

You can also contact site staff by submitting a support request »

SDLXLIFF validation error: Invalid character in the given encoding

Advanced search

Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »

  • All of
  • Term search
  • Jobs
  • Forums
  • Multiple search