Trados 2011 error -- Corrupt file: Missing tag information for tag with id: '24'
Thread poster: Dusan Rabrenovic

Dusan Rabrenovic  Identity Verified
Slovenia
Local time: 18:13
Member (2008)
German to Slovenian
+ ...
Oct 22, 2013

Trados 2011 Freelance plus, Win7 64bit, Office 2007, 8 GB RAM, all programs and work files on SSD, yesterday's cumulative update 11 installed

Error screenshot: http://i.imgur.com/ZGyolM1.png

I have a DE-SL project consisting of 26 RTF files which I merged into one big SDLXLIFF for easier work in the Editor, and everything worked fine until I saved and closed the project earlier, and now came back to continue working. Trados 2011 surprised me with this error when I tried to reopen the project, refusing to open the SDLXLIFF. So I attempted to recreate a new project using the same source RTF files, but the same error pops up immediately.

I distinctly remember that after downloading and running yesterday's cumulative update 11, it appeared as if Trados was fully reinstalling and asked me for my 5 working languages again, could that be the indication of a problem?

Oh and just now Trados pooped out, its icon in the taskbar is still shown as if it was opened, but clicking on it won't maximize it and just produces an error "ding" sound... now it opened a second instance of Trados, while the first one is still borked. Things are heating up!


Direct link Reply with quote
 

Åsa Andersson  Identity Verified
Sweden
Local time: 18:13
Member (2007)
French to Swedish
+ ...
Corrupt file: Missing tag information... Oct 23, 2013

I have the same issue. I worked with the files yesterday evening. Today when I try to open the same files, I receive the above error message, and the files do not open. I have tried to create a new project from scratch, but receive the same error message.

Direct link Reply with quote
 

Åsa Andersson  Identity Verified
Sweden
Local time: 18:13
Member (2007)
French to Swedish
+ ...
Converted files to Microsoft Word solved the problem Oct 23, 2013

After converting the rtf files into Microsoft Word 2010, I could create a new project without problem.

Direct link Reply with quote
 

Valeria Di Virgilio
Italy
Local time: 18:13
Italian to English
+ ...
We're having the same problem Oct 23, 2013

Hi everybody!

I work for a translation agency and this morning we decided to update our Trados versions with the latest update since it seemed that Trados 2011 wouldn't export our documents anymore.

Now we're having trouble in creating projects and the software displays thie same error.

Is there anyone who knows how to go back to the previous version or how to solve this problem? Have you found a solution?
(I have converted all my documents in Word 2010 but it still doesn't work for me)

Thanks in advance.


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 18:13
English
Needs a patch... Oct 23, 2013

Hi Valeria et al,

Unfortunately this update seems to have introduced a problem for users on Studio 2011. It will be resolved tomorrow with a further update.

In the meantime there are three workaround:

1. Uninstall CU11 and go back to CU10 (through the windows control panel)
2. Use Studio 2014
3. email me and I'll send you a patch (pfilkin@sdl.com)

Apologies for the inconvenience.

Regards

Paul

[Edited at 2013-10-23 12:35 GMT]


Direct link Reply with quote
 

OnePlanet
Local time: 12:13
Member (2004)
Arabic to English
+ ...
Manual fix found as a temporary solution Oct 23, 2013

This is Chris R., a PM here at One Planet

I received a file from one of my translators this morning that had the same error with a different number in the tag ID (tag ID: '4.1_4.2' instead of '24'). This is what worked for me, note that we have not yet installed the update mentioned so your experience may be different.

I was able to manually fix the file using Notepad++, it has to do with the fact that it's a merged file. In the editor window of Studio you see the yellow marker that designates the separation between files. In Notepad++ there's ~60 lines of code at these separations, then the first segment starts. This "Header Code" as I'm calling it appears to contain the tag IDs for all the segments in THAT file, but not the others. The sdlxliff should look like this:

(Header code for file #1)
(Segment 1 for file #1)
(Segment 2 for file #1)
(Segment 3 for file #1)(End code for file #1)
(Header code for file #2)
(Segment 1 for file #2)
(Segment 2 for file #2)
(Segment 3 for file #2)(End code for file #2)
(Header code for file #3)
(Segment 1 for file #3)
(Segment 2 for file #3)
(Segment 3 for file #3)(End code for file #3)

Etc.

The error is caused when the segments for all the previous files are re-duplicated in the files following it. It ends up looking like this:

(Header code for file #1)
(Segment 1 for file #1)
(Segment 2 for file #1)
(Segment 3 for file #1)(End code for file #1)
(Header code for file #2)
(Segment 1 for file #1)
(Segment 2 for file #1)
(Segment 3 for file #1)
(Segment 1 for file #2)
(Segment 2 for file #2)
(Segment 3 for file #2)(End code for file #2)
(Header code for file #3)
(Segment 1 for file #1)
(Segment 2 for file #1)
(Segment 3 for file #1)
(Segment 1 for file #2)
(Segment 2 for file #2)
(Segment 3 for file #2)
(Segment 1 for file #3)
(Segment 2 for file #3)
(Segment 3 for file #3)(End code for file #3)

It appears that since the "header code" for file 3 doesn't have the tag ID information for the tags within the segments of files #1 and #2, it throws the error.

To fix the file I first made a backup of the broken file that I could mess with all I like. I then manually went through and deleted the extra segments showing up under the wrong files. After saving the file in Notepad++ I was able to open the sdlxliff in Studio.

I hope this helps you. For those of you who installed the update perhaps re-making the project WITHOUT merging the files will bypass this problem until the new update comes out.

-Chris R.


Direct link Reply with quote
 

Sophie Martineau
France
Local time: 18:13
Spanish to French
+ ...
Same problem here Oct 24, 2013

Hello,

I have exactly the same problem, related to a Studio 2011 package of 4,000 files...

Paul, could you please send me the patch at your earliest convenience? I have just sent you an email.

Thank you.


Direct link Reply with quote
 
davidioso
Local time: 17:13
Same but... tag with id '0' Oct 24, 2013

Appreciate the patch. I'm in big trouble!

This seems to have occurred after updating.

David

[Edited at 2013-10-24 09:38 GMT]

[Edited at 2013-10-24 15:34 GMT]


Direct link Reply with quote
 

Gisele Latour  Identity Verified
France
Local time: 18:13
Member (2010)
English to French
Same here, Corrupted file, data missing for tag ID '0' Oct 24, 2013

I'm in a real mess, I have to deliver the package today.
Could you help me with this issue?
Thank you!


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 18:13
English
CU12 for Studio 2011 Oct 24, 2013

Dear all,

The fix for the problem created by CU11 yesterday has now been released as CU12. So if you restart Studio 2011 today you should see the automatic update available as long as you have this switched on (Tools -> Options -> Automatic Updates)

If you received a patch from SDL already then don't worry, this will not be affected by the update.

You can find more information on this in KB article #4536. But if you can't access the article, or the KB generally at the moment, it's because we seem to be also suffering from some temporary network issues that the IT teams are working on.

Also note that if you are experiencing problems as a result of the CU11 update then you will have to recreate the merged files you were working on after applying the CU12 patch (or the dll fix provided to some users so far).

Regards

Paul


Direct link Reply with quote
 

Gisele Latour  Identity Verified
France
Local time: 18:13
Member (2010)
English to French
Thank you! Oct 24, 2013

Working fine now after the last update, thank you for reacting so fast.

Direct link Reply with quote
 
davidioso
Local time: 17:13
Problem returns... Oct 25, 2013

Although the update worked initially. The problem has returned this morning for me in Studio 2011.
Appreciate any help.

David


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados 2011 error -- Corrupt file: Missing tag information for tag with id: '24'

Advanced search







LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »
WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search