Tag error when trying to save target text in Trados Studio 2014
Thread poster: Tina Gross
Tina Gross
English to German
Oct 24, 2013

Hi,

I'm having the same problem with a couple of word files (docx) in Trados Studio 2014: When I try to save the translated target text, I get the following error message: "Zieltext konnte nicht gespeichert werden (Target text could not be saved - I use the program in German): The 'w:p' start tag on line 24 position 2 does not match the end tag of 'w:sdtContent'. Line 27, position 3."

I meticulously checked the tags in the document - there are not many of them. I tried to pretranslate the docx again against the translation memory, which didn't help. Then I tried saving the docx as an rtf file, which brought about one pair of tags per letter in some places and obviously also doesn't really help. And I tried to disable tag checking in the file formats, but it didn't help either.

Any suggestions?

Any help would be greatly appreciated - otherwise I will have to translate a large number of word files with loads of repetitions manually ...

Thank you!!!!
Tina


Direct link Reply with quote
 

Shai Navé  Identity Verified
Israel
Local time: 18:58
Member
English to Hebrew
+ ...
Run a Verify (F8) Check Oct 24, 2013

The first thing to do is to run a Verify (by pressing F8 or from the Ribbon) check and correct any errors found, specifically those related to tags.
If the problem persists please report back.

[Edited at 2013-10-24 15:24 GMT]


Direct link Reply with quote
 
Tina Gross
English to German
TOPIC STARTER
Verify check doesn't help! Oct 25, 2013

Thank you for your advice, but that's what I've already done. The editor shows the same message that I get when I try to save the file and jumps to a segment in the document that does not contain any tags. Neither the segment before or after does. There are only 10 tags in this document and I've checked them over and over again ...

Direct link Reply with quote
 

Shai Navé  Identity Verified
Israel
Local time: 18:58
Member
English to Hebrew
+ ...
Two more possible solutions Oct 25, 2013

The original file might be corrupt. There are two methods to try and fix it.
First, create a TM of your translation if you don't already have one.
Method 1: Convert to RTF (or Doc)
1. Save the original file as RTF (and later as Doc if it doesn't work).
2. Re-translate it using the TM.
3. Create Target document.
4. Open it in Word and save it as Docx.

If this above doesn't work, the document might have a broken bookmark field in it.
Method 2: Remove all bookmarks from the original document
1. Open the original document in Word.
2. Goto to the Insert tab.
3. Under the Links group select the Bookmark command.
4. Select the Hidden Bookmarks checkbox at the bottom of the window to display all bookmarks in the document.
5. Remove all of them.
6. Save the file, open it in Studio (with or without re-translating it) and try to save it as target.


Direct link Reply with quote
 

mhairibain

Local time: 17:58
Catalan to English
+ ...
Thank you! Nov 28, 2014

Thank you so much Shai! Your Method 1. worked! I really appreciate the advice.

All the very best,

Mhairi.


Direct link Reply with quote
 

Lutz Plueckhahn  Identity Verified
Local time: 17:58
Member (2003)
English to German
Unbelievable Solution! May 27, 2015

Guys, you won't believe how I solved this problem:

I opened the sdkxliff file in question with the standard Windows editor and searched for the string "bookmarkend" and found this:

ph name="bookmarkend" word-end="false" bookmarkend id="0" ...

After fiddling around with that and causing lots of errors and frustration, I simply erased one character - turning the second "bookmarkend" into "bookmarknd".

Guess what - it worked! I got my target document and it looks OK!

Hope that helps,

Lutz

[Edited at 2015-05-27 16:29 GMT]


Direct link Reply with quote
 
xxx2nl  Identity Verified
Netherlands
Local time: 17:58
Nice work-around May 27, 2015

Hi Lutz,

Your suggested solution is indeed a nice one, but I cannot stop wondering whether this is a Studio issue or an MS Word issue. Perhaps Paul can tell us? Is it Studio handling bookmarks not correctly?

Cheers,

Hans


Direct link Reply with quote
 

Lutz Plueckhahn  Identity Verified
Local time: 17:58
Member (2003)
English to German
No bookmark to find in Word May 27, 2015

Hi Hans,

I couldn't find any bookmarks in the document. However, it was converted from Framemaker, so there may be some hidden ones.

Lutz


2nl wrote:

Hi Lutz,

Your suggested solution is indeed a nice one, but I cannot stop wondering whether this is a Studio issue or an MS Word issue. Perhaps Paul can tell us? Is it Studio handling bookmarks not correctly?

Cheers,

Hans


Direct link Reply with quote
 

Daniela Alunni  Identity Verified
Italy
Local time: 17:58
Member (2008)
English to Italian
+ ...
Many thanks Shai! 'Method 1' is great;) Dec 20, 2015

Shai Navé wrote:

The original file might be corrupt. There are two methods to try and fix it.
First, create a TM of your translation if you don't already have one.
Method 1: Convert to RTF (or Doc)
1. Save the original file as RTF (and later as Doc if it doesn't work).
2. Re-translate it using the TM.
3. Create Target document.
4. Open it in Word and save it as Docx.

If this above doesn't work, the document might have a broken bookmark field in it.
Method 2: Remove all bookmarks from the original document
1. Open the original document in Word.
2. Goto to the Insert tab.
3. Under the Links group select the Bookmark command.
4. Select the Hidden Bookmarks checkbox at the bottom of the window to display all bookmarks in the document.
5. Remove all of them.
6. Save the file, open it in Studio (with or without re-translating it) and try to save it as target.


Direct link Reply with quote
 
xxxPaluF
Tonga
Would this method 1 work with xml files too? Dec 28, 2015

Daniela Alunni wrote:

Shai Navé wrote:

The original file might be corrupt. There are two methods to try and fix it.
First, create a TM of your translation if you don't already have one.
Method 1: Convert to RTF (or Doc)
1. Save the original file as RTF (and later as Doc if it doesn't work).
2. Re-translate it using the TM.
3. Create Target document.
4. Open it in Word and save it as Docx.

If this above doesn't work, the document might have a broken bookmark field in it.
Method 2: Remove all bookmarks from the original document
1. Open the original document in Word.
2. Goto to the Insert tab.
3. Under the Links group select the Bookmark command.
4. Select the Hidden Bookmarks checkbox at the bottom of the window to display all bookmarks in the document.
5. Remove all of them.
6. Save the file, open it in Studio (with or without re-translating it) and try to save it as target.


Direct link Reply with quote
 

Shai Navé  Identity Verified
Israel
Local time: 18:58
Member
English to Hebrew
+ ...
No, unless the XML content is stored in a Word file Dec 28, 2015

Unfortunately, it works only for Word documents. With the new Word file filter in Studio 2015 these errors should be, save for extreme cases perhaps, a thing of the past.
If you are dealing with a true XML (as in plain text) file, the problem is elsewhere.


Direct link Reply with quote
 

Jose&SteveLilly
Netherlands
Local time: 17:58
Member (2011)
Dutch to English
+ ...
I'm getting the following error on a 54,000 word project that saved ok previously. Any advice? Dec 9, 2016

Shai Navé wrote:

Unfortunately, it works only for Word documents. With the new Word file filter in Studio 2015 these errors should be, save for extreme cases perhaps, a thing of the past.
If you are dealing with a true XML (as in plain text) file, the problem is elsewhere.


[Edited at 2016-12-09 10:09 GMT]

[Edited at 2016-12-09 10:10 GMT]


Direct link Reply with quote
 

Jose&SteveLilly
Netherlands
Local time: 17:58
Member (2011)
Dutch to English
+ ...
I'm getting the following error on a 54,000 word project that saved ok previously. Any advice? Dec 9, 2016

Shai Navé wrote:

Unfortunately, it works only for Word documents. With the new Word file filter in Studio 2015 these errors should be, save for extreme cases perhaps, a thing of the past.
If you are dealing with a true XML (as in plain text) file, the problem is elsewhere.


[Edited at 2016-12-09 10:10 GMT]


Direct link Reply with quote
 

Shai Navé  Identity Verified
Israel
Local time: 18:58
Member
English to Hebrew
+ ...
Run the tag verifier Dec 9, 2016

Run the Tag verifier (the Verify command) and correct any issues it detects.
If this didn't help (it should if the file previously saved correctly) and you are using Studio 2015 and above, make sure the Word 2007-2016 file type is enabled and before (i.e. above on the file types list) all the other Word file types. Then recreate the project and use the TM to translate everything.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Tag error when trying to save target text in Trados Studio 2014

Advanced search







Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »
SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search