Problem importing .ttx into Studio 2014
Thread poster: pgschreier

pgschreier  Identity Verified
Switzerland
Local time: 15:19
German to English
Oct 26, 2013

Hello,

In attempting to import a .ttx file into Trados Studio 2014, at the very first step (convert to translatable format) I get the following error message:

Index out of range (-1). It must be a number from 0 up to the number of items in the collection (0). Parameter name: index


First, it appears we can forget any claims that Studio is fully compatible with Workbench .ttx files (and any hopes this will be the case).

Second, does anyone have any suggestions on how I can successfully import this .ttx so I can work on it in Studio 2014?

Thanks
Paul


Direct link Reply with quote
 

Andrzej Lejman  Identity Verified
Local time: 15:19
German to Polish
+ ...
Why import? Oct 27, 2013

Just open the file.

Go to File > Translate Single Document and select the file.

It works without any problems.

Regards

A.


Direct link Reply with quote
 

pgschreier  Identity Verified
Switzerland
Local time: 15:19
German to English
TOPIC STARTER
Still same error message Oct 27, 2013

Hi Andrzej,

Thanks for the tip, but I still get the identical error message when Trados tries to open up the file.

-- Paul


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 15:19
English
Can I see the file? Oct 27, 2013

Hi Paul,

If you can share the file I'd be happy to take a look at it?

Regards

Paul
pfilkin@sdl.com


Direct link Reply with quote
 

Alison High  Identity Verified
Switzerland
Local time: 15:19
Member (2003)
French to English
+ ...
Another .ttx Trados 2014 problem Nov 29, 2013

Hi I am looking to import multiple .ttx into one Trados 2014 project.

So that answers the "why not just open it" comment someone else asked above

I want all the files in ONE project.... so I can use them virtually merged....

But Trados imports them as reference and won't let me change them to translatable.

Does anyone have any ideas, please?


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 15:19
English
Perhaps... Nov 29, 2013

... the languages in the TTX don't match? Can you open them individually using Translate Single Document? Give that a try and as you open them the languages in the TTX will be displayed.

Regards

Paul


Direct link Reply with quote
 

Alison High  Identity Verified
Switzerland
Local time: 15:19
Member (2003)
French to English
+ ...
Languages OK Nov 29, 2013

The languages are OK

The TTX files open OK as single-project files

When I select the TTX files for addition to a new project

I get

type unknown
usage reference
file type identifier unknown.

and I can't change the useage


Direct link Reply with quote
 

Alison High  Identity Verified
Switzerland
Local time: 15:19
Member (2003)
French to English
+ ...
Found it Nov 29, 2013

I'd been trying to ensure that ttx as a format existed by clicking on the file types section of the PROJECT SETTINGS, which didn't help.

There's a file types button in the PROJECT FILES window.... with a confusing filter funnel image, to make you think it is just going to sort the input files by file types.... you have to click there and then there's some red text allowing you to click again and add the .ttx format if you don't have it already.

hope this helps someone else out.


Direct link Reply with quote
 

Fong-chyi Wen  Identity Verified
Taiwan
Local time: 21:19
Member (2008)
English to Chinese
When will this glitch be fixed? Jan 20, 2014

It's really amazing to see this compatibility issue appear time and again for each new version of SDL Trados. Now I have this issue, too, and this problem hasn't been fixed for 3 months. I also found that files exported from WorldSever can't be handled correctly on Trados Studio 2014. I can translate the files (xliff, ttx, xlf), but when I tried to save target files, the files will be garbled and many segments aren't saved. I am really disappointed by the quality of this tool which is so important to my work.

Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 15:19
English
Glitch or settings? Jan 20, 2014

Fong-chyi Wen wrote:

It's really amazing to see this compatibility issue appear time and again for each new version of SDL Trados. Now I have this issue, too, and this problem hasn't been fixed for 3 months. I also found that files exported from WorldSever can't be handled correctly on Trados Studio 2014. I can translate the files (xliff, ttx, xlf), but when I tried to save target files, the files will be garbled and many segments aren't saved. I am really disappointed by the quality of this tool which is so important to my work.


Hi,

I’d be happy to review any files you wish to share to demonstrate your point? Perhaps it’s just a question of the settings you are using.

Regards

Paul
pfilkin@sdl.com


Direct link Reply with quote
 

Merete Hvas  Identity Verified
Denmark
Local time: 15:19
English to Danish
+ ...
Incorrect source language setting Jan 23, 2014

Hi,

I just had the same problem as described above.

The problem turned out to be the source file language setting. I knew I was translating from Dutch, but I had no way of knowing (since I am unable to open the TTX files without TagEditor) that the source files were in Belgian Dutch! Once I changed the source language setting everything worked just fine.

Merete

[Edited at 2014-01-23 09:53 GMT]


Direct link Reply with quote
 
error: hexadecimal value 0x02 is an invalid character. Jun 30, 2014

Hello everyone,

I have Trados Studio 2014 Freelance and when I try to open a specific ttx. file I get the following error:

hexadecimal value 0x02 is an invalid character.

So the file cannot be opened.

Because the ttx. file had been sent by an agency, I tried to create my own ttx file using the original doc file and the SDL TTX it option in Trados Studio 2014, but the problem is still there.

Is there a way to overcome this?

Thank you for your suggestions.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Problem importing .ttx into Studio 2014

Advanced search







memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search