"Language not supported" for Hunspell w Studio 2011/Win 8
Thread poster: Michael Bauer

Michael Bauer
United Kingdom
Local time: 01:43
English to Scottish Gaelic
+ ...
Nov 12, 2013

I had Studio 2011 set up on Win 7 previously with a custom Hunspell dictionary for Scottish Gaelic working perfectly alright. I then had to upgrade to Win 8 and found that after re-installing (I lost all apps during upgrade) I could not get the custom Hunspell to work again. I put the dic and aff into the appdata/roaming/sdl/spellchecker folder and selected the dic via the options menu. I made sure that I've selected the right locales for the project but it will just not run the spellcheck, it tells me "Check spelling... (Language not supported)" under tools. Also tried making it the default dic, no difference.

As I had done an install from the SP1 file and the run the upgrades, I decided to get the SP2 file for installing it on my (also Win 8) laptop. Ran all the updgrades, copied the dic and aff, selected them... same problem. Hunspell in general works fine (e.g. in LibreOffice) on both my systems so I don't think it's a Hunspell issue.

Has anyone had this problem?


 

SDL Community  Identity Verified
United Kingdom
Local time: 02:43
English
Hunspell Nov 12, 2013

Hi Michael

Did you update the spellcheckmanager_config.xml ?

If not you can download an update version with several additional languages for download here:
http://goo.gl/qF56ls

I added there also ga-CT, so the only thing you need to do is to replace then the existing spellcheckmanager_config.xml that is located in C:\Program Files (x86)\SDL\SDL Trados Studio\Studio3\HunspellDictionaries with the on downloaded.

Then add the dictionaries in the folder HunspellDictionaries too (*.dic and *.aff).

Restart Studio and see if it works then.

Cheers
Richard


 

Michael Bauer
United Kingdom
Local time: 01:43
English to Scottish Gaelic
+ ...
TOPIC STARTER
Eventually got there Nov 12, 2013

Hi Richard,

First off, thanks for your help!

Second though, I wish SDL would fix those bad locale codes. ga-CT doesn't exist, ga is Irish, CT is Catalonia and Irish is not spoken in Catalonia. That code did kick around for a while but it goes back to Trados 3.6 (I think) where Scottish Gaelic was not supported but the translator HAD to choose from existing locale codes, so someone picked ga-CT. The correct ISO code for Scottish Gaelic is gd-GB.

So I didn't use your xml but it was a good pointer. The problem seems to be as follows:

1. The guidance on the SDL website is out of date. It points the user at the ...\document and settings\\Application data\SDL\SpellChecker\ App Data directory, which is where I put the dic and aff.
2. There IS a customdictionary_config.xml in that dir which automatically added
dict fileNameRoot="gd_GB" isDefault="true"
when I pointed Studio at it.
3. Following your suggestion, I added gd-GB / gd_GB to the xml in the OTHER dir (under Programs (86)). At this point, I got the following error:
Could not load spell checker ... Could not locate \Program Files (86)\SDL\SDL Trados Studio\Studio2\HunspellDictionaries\gd_GB.aff
4. Based on that, I tried putting the dic and aff into this directory and thankfully, that worked.

It would be good if someone at SDL could fix the locale error (it is causing endless problems with clients sending packages with the wrong ISO which of course now that SDL HAS added Gaelic (as gd-GB) no longer works and it throws the unsupported culture error). It would also be good if the Help page could be updated if the App Data dir path is no longer correct or at least not on Windows 8?

Thanks very much again!


 

SDL Community  Identity Verified
United Kingdom
Local time: 02:43
English
Not SDL but my fault :) Nov 12, 2013

Hi Michael

I´m sorry, the local was provided by my and it was not correct.

I took the local from somewhere else and it seems it was not reliable the table I looked aticon_smile.gif

I corrected the XML and it should be now correct.

Regards
Richard


 

Juan Nuño  Identity Verified
Mexico
Local time: 19:43
Member (2007)
English to Spanish
My "Options" settings have gone Nov 17, 2013

SDL Support wrote:

Hi Michael

Did you update the spellcheckmanager_config.xml ?

If not you can download an update version with several additional languages for download here:
http://goo.gl/qF56ls

I added there also ga-CT, so the only thing you need to do is to replace then the existing spellcheckmanager_config.xml that is located in C:\Program Files (x86)\SDL\SDL Trados Studio\Studio3\HunspellDictionaries with the on downloaded.

Then add the dictionaries in the folder HunspellDictionaries too (*.dic and *.aff).

Restart Studio and see if it works then.

Cheers
Richard


Hello all,

I have followed the instructions to replace the XML configuration file for the dictionaries, but after replacing the XML, I got this error:

"An item with the same key has been already added"

Does anyone know how to fix this issue?

I lost control over my "Options" Settings.

Thanks in advance.


 

Silvia GOMEZ  Identity Verified
Local time: 21:43
English to Spanish
Still not working Feb 28, 2014

Thank you for the updated spellcheckmanager_config.xml. I've replaced the olde one with this one and it now has the es-AR variant, but it still doesn't work for me.
I've copied the es-AR dic and aff files in the Hunspell dictionaries folder, but the Spellchecker is still grayicon_frown.gif

Have I forgotten to do something?

Thanks, guys!

Sil


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

"Language not supported" for Hunspell w Studio 2011/Win 8

Advanced search







Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search