Pages in topic:   [1 2] >
Translation memory and second thoughts
Thread poster: Natalia Kobzareva

Natalia Kobzareva  Identity Verified
Russian Federation
Local time: 01:04
Member (2009)
English to Russian
+ ...
Nov 12, 2013

It happens that I often start having seconds thoughts of the translations already confirmed and stored in the memory.
It may happen very often when you have first translated, say, 50 terms that usually take the first 3-5 pages of an agreement, and on page 20 you realise, that the existing translation would not fit in the context, and that another synonym, or the same word but in its plural/singular form should be used. Or you decided to translate a certain phrase in a different way and that may mean changing grammar cases, endings, etc. (This is because I translate into Russian).

I go to segments with this particular term or phrase and change them and reconfirm. However, there is no guarantee that these "better" or "second" variants will be offered by TM or Concordance later when I come upon still untranslated segments that do not exactly reproduce the confirmed and reconfirmed ones (of which Auto-propagation takes care of), but repeat them by 80%-99% only. Quite often Trados offers you the original version. And if the document is long, I may have to spend several days on its translation, and as every human being tend to forget what improvements were introduced by me the day before.

What should I do in order to be each time offered the better (second) variant instead of the first one, apart from leaving the segment as "draft"?

1. Run Update Main Translation Memory after each amendment?
2. Use Project TM method? But that does not guarantee the better variant during the process, however it will leave my main memories clean and neat.
3. Anything else you may advise?

The option "think twice before confirm" would be the best, but alas, it is not always possible.


Thank you for your insights.


Direct link Reply with quote
 

Katalin Horváth McClure  Identity Verified
United States
Local time: 18:04
Member (2002)
English to Hungarian
+ ...
Do not allow multiple translations? Nov 12, 2013

There is a TM setting in Trados, at least in my version, where you can specify whether you allow multiple translations of the same segment.
If you don't allow multiple translations, the latest will overwrite the old one.
Have you tried this?
Katalin


Direct link Reply with quote
 

Natalia Kobzareva  Identity Verified
Russian Federation
Local time: 01:04
Member (2009)
English to Russian
+ ...
TOPIC STARTER
Multiple translations Nov 12, 2013

Katalin,
Studio 2011 allows multiple translations by default. It is not possible to unallow it.


Direct link Reply with quote
 

Nora Diaz  Identity Verified
Mexico
Local time: 16:04
Member (2002)
English to Spanish
+ ...
Multiple translations in Studio 2011 Nov 12, 2013

If you store your alternate translations via the right shortcut (as multiple translations), then they will always be offered as alternatives.

Maybe this will help:

http://noradiaz.blogspot.mx/2012/07/same-segment-multiple-translations-in.html


Direct link Reply with quote
 

Natalia Kobzareva  Identity Verified
Russian Federation
Local time: 01:04
Member (2009)
English to Russian
+ ...
TOPIC STARTER
Thank you, Nora Nov 12, 2013

But I do not want multiple translations for one and the same segment. I want my TMs to store the very last (and possibly, the best) variant not after the project has been finalised, but during the process, so that I can use these better variants for further untranslated segments.

I guess that I would need to uncheck Always add as new translation and use Project TMs feature.


Direct link Reply with quote
 

Nora Diaz  Identity Verified
Mexico
Local time: 16:04
Member (2002)
English to Spanish
+ ...
A regular Confirm segment should do that Nov 12, 2013

Maybe I'm not understanding exactly what is going on, but if you have a confirmed segment, and then change the translation and confirm the new translation, that replaces your original translation unit in the TM, so you wouldn't really need to do anything special. No need for Project TMs or any special settings.

For example, if I have the following:

Source: A big red house
First Translation: Una casa roja grande

When I confirm this segment, it is saved to my TM. If the next time I come upon the same segment I decide that I want to change it. I simply do so:

Source: A big red house
Edited translation: Una casa grande y roja

Then confirm the segment, and the first translation is replaced with the new one in my TM.

Is your TM set to update as you work? Here's how to make sure:

http://noradiaz.blogspot.mx/2012/07/studio-2011-tm-not-updating-check-this.html


Direct link Reply with quote
 

Natalia Kobzareva  Identity Verified
Russian Federation
Local time: 01:04
Member (2009)
English to Russian
+ ...
TOPIC STARTER
Confirm does not do what I want Nov 12, 2013

I have longer sentences where, for example, I want to change just part of it.
I do it, and store it in my memory with Confirm.
When I come upon a similar sentence (not a 100% repetition), Trados offers me my original variant, and would not offer the amended one.
I want Trados to offer me the amended one, not the original. In other words, overwriting.
Yes, I check the Update field each time.

So, your advice (according to the link) would be to run the Update Main Memory every time I amend something.


Direct link Reply with quote
 

Miguel Carmona  Identity Verified
United States
Local time: 15:04
English to Spanish
You need to do the change in the original segment Nov 12, 2013

Natalia,

You need to go back to your original segment, make any changes there and confirm, by using either Ctrl+Enter or Ctrl+Alt+Enter.

It is something you do on the fly, no need to change any settings.

For instance if you had as a translation:
"I want to go to church"
when in fact the correct translation was:
"I want to go to a striptease club"

You would need to go back to the original segment, and there, you would change "church" for "a striptease club" and confirm that new translation. This will overwrite the old translation for that particular segment.

Next time you come across a segment similar to your original segment, you will see, "I want to go to a striptease club" as a suggested translation.

Good luck


Direct link Reply with quote
 

Natalia Kobzareva  Identity Verified
Russian Federation
Local time: 01:04
Member (2009)
English to Russian
+ ...
TOPIC STARTER
Thank you, guys Nov 14, 2013

But I do know how to Confirm and to Update.
I would not be writing here without first checking and rechecking everything possible.


Direct link Reply with quote
 

Miguel Carmona  Identity Verified
United States
Local time: 15:04
English to Spanish
Studio suggests the original translation after you changed it? Nov 14, 2013

Natalia Kobzareva wrote:

... Quite often Trados offers you the original version.


Do you mean, Studio suggests your original translation even after you changed it, as if you had not confirmed the change?

For any untranslated segments, the version suggested by Studio should be the original segment's edited version.

There must be something you are not doing right, or maybe I am not understanding your problem, or what you expect from the program.

Good luck


Direct link Reply with quote
 

Natalia Kobzareva  Identity Verified
Russian Federation
Local time: 01:04
Member (2009)
English to Russian
+ ...
TOPIC STARTER
Yes, Miguel Nov 14, 2013

I know I am doing something wrong.
And that is why I am asking for help.
This may be connected with checking/unchecking "Always add translation as new translation to the memory", at least I am thinking in this direction, because all other obvious methods did not help.



[Edited at 2013-11-14 20:38 GMT]


Direct link Reply with quote
 

Miguel Carmona  Identity Verified
United States
Local time: 15:04
English to Spanish
Always add new translation to the translation memory Nov 14, 2013

Hi Natalia,

I think you are on the right track.

Have you tried unchecking that checkbox? When you edit a translation your translation unit will be updated, not added as a new translation unit.

Here is the help link from SDL regarding this setting:
http://producthelp.sdl.com/SDL%20Trados%20Studio/client_en/Ref/A-G/Batch_Processing/Batch_Processing___Translation_Memory_Updates.htm

It says (although I am sure you have read it already):
Always add new translation to the translation memory
When this option is selected, translations that have the statuses below are added as a new translation unit to the translation memory instead of updating existing translation units in the translation memory.

Good luck

For those who may be wondering where that setting is located:

Project Settings >
-- Language Pairs >
---- All Language Pairs >
------ Batch Processing >
-------- Translation Memory Updates:
---------- Always add new translation to the translation memory

[Edited at 2013-11-14 22:05 GMT]


Direct link Reply with quote
 

Tom in London
United Kingdom
Local time: 23:04
Member (2008)
Italian to English
In Word Nov 15, 2013

In Word, you just find/replace all the instances of the phrase you want to change. Who needs a CAT tool?

Direct link Reply with quote
 

Miguel Carmona  Identity Verified
United States
Local time: 15:04
English to Spanish
Find & replace Nov 15, 2013

Tom in London wrote:

In Word, you just find/replace all the instances of the phrase you want to change. Who needs a CAT tool?


You are right. The use of a CAT tool is not absolutely necessary, nevertheless, obviously the OP wants to take advantage of the benefits of her CAT tool that a word processor does not offer, for instance suggested translations, plus many others.

Also, I am sure you know, you can as easily perform search and replace operations with CAT tools too.


Direct link Reply with quote
 

Nora Diaz  Identity Verified
Mexico
Local time: 16:04
Member (2002)
English to Spanish
+ ...
Can you give us an example? Nov 15, 2013

Hi Natalia,

Regarding "Always add new translation to the translation memory", I'm not sure unchecking that box would solve the problem. The box is checked by default for Translated, Translation Approved and Signed Off, I haven't touched it and I don't have the same problem.

Are your fuzzy matches pre-populated? That could be causing the issue, but it's actually the expected behavior from the program.

I was trying to think of what could be happening because you mention that in fuzzy matches you don't get offered the newest TU. This would happen when the fuzzy match has been populated first and then edits are made and confirmed on the original segment that you want to change. In that case, the already populated fuzzy match would not get updated, of course. You would need to clear the target segment, then place the cursor again in the empty segment where you expect a fuzzy match, and now you would get the updated TU.

Here's a short video that demonstrates this:

http://noradiaz.blogspot.mx/2013/11/editing-tus-in-sdl-trados-studio.html


Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Translation memory and second thoughts

Advanced search







TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search