WSXZ file: Trados says file name is too long to open the file
Thread poster: Samuel Murray

Samuel Murray  Identity Verified
Netherlands
Local time: 04:44
Member (2006)
English to Afrikaans
+ ...
Dec 16, 2013

Hello everyone

I'm using Trados 2011 and a client sent me a WSXZ file. This client has sent similar files before, and I have always been able to open them. I haven't changed any of my Trados settings since I got the previous file. But this time, I get this error message when I try to open the WSXZ file:



The file name is 116 characters long. The path name (excluding the file name) is 53 characters long. Renaming the file to a short name (e.g. foo.wsxz) and trying to open it from a shorter path (e.g. D:\bar) yields the same error message.

What can I do? If this was an SDLPPX file, I would have simply unzipped it and translated the SDLXLIFF file inside it, but WSXZ files are more complex than that and one can't simply unzip it and work on a file.

Thanks
Samuel


Direct link Reply with quote
 

2G Trad  Identity Verified
Italy
Local time: 04:44
Member (2000)
English to Italian
+ ...
Move the file to shorten the path Dec 16, 2013

You should shorten the path, moving the file upwards in the subfolders hierarchy.

Update: I see you already tried that.
Maybe the mistake is on client-side: ask your client to save the original package in a shortened path.

Bye!
Gianni

[Edited at 2013-12-16 12:45 GMT]


Direct link Reply with quote
 
Daniel García
English to Spanish
+ ...
Try changing the location of your "temp" folder Dec 16, 2013

This message might be appearing while Studio copies files to your "temp" folder before copying them to your real folder.

In Windows, the "temp" folder might be located in a deep structure under your profile, resulting in very long file and path combinations.

Try changing the location of your "temp" folder to something like "C:\temp". Perhaps the error will not appear.

The way to do it is different for each version of Windows.

Daniel


Direct link Reply with quote
 

Samuel Murray  Identity Verified
Netherlands
Local time: 04:44
Member (2006)
English to Afrikaans
+ ...
TOPIC STARTER
Thanks, but... Dec 16, 2013

Daniel García wrote:
In Windows, the "temp" folder might be located in a deep structure under your profile, resulting in very long file and path combinations.


My TEMP folder is located at:
D:\TEMP\AppData\Local\Temp
which is not terribly long.


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 04:44
English
Possible workarounds.... Dec 16, 2013

Workaround 1

Note: this is relevant for WorldServer Users who creates projects in WorldServer, such as Project Manager, Project Creators or Administrators. As a translator, you will not be involved in the creation of a project in WorldServer and you can ignore this step.


When creating a project in WorldServer, make sure to enter a Project name that is as short as possible. Please check that the length of the AIS folder path in WorldServer along with the project name do not exceed 260 characters, included spaces.

In WorldServer, the directory path can be checked under:

  • Management>Asset Interface System>AIS Mounts>Mount: FileSystem


Workaround 2

On the Computer where SDL Trados Studio is installed and where you perform your translation, make sure to change the TEMP variables directory to make it shorter than the default value. Here are the steps to follow (Windows 7 OS):

  1. From the Desktop, right-click My Computer and click Properties.
  2. Click Advanced System Settings link in the left column.
  3. In the System Properties window click the Environment Variables button.
  4. You need to change the value of the USER variables TEMP and TMP. To do so, select each of these 2 user variables, click Edit
    and change the value to


    • C:\TEMP

      and
    • C:\TMP

  5. Click OK and again OK on the main window.
  6. Reopen SDL Trados Studio and try again to open the package.


Workaround 3

If WorldServer has applied Studio File Types to segment the assets/filesinside your WorldServer Studio package, the WorldServer Studio package (*.wsxz) will contain one or more *.sdlxliff files. Here are the steps to be applied to each SDLXLIFF file:

  1. Change the Studio package file extension from *.wsxz
    to *.zip.
  2. Extract the file.
  3. Open the *.sdlxliff file in any text/XML editor
  4. Find the element SDLWS:ProjectName.
  5. Change the value of the element's attribute to any short name. This value corresponds to the project’s name. Just change it to a much shorter name.
  6. Save and close the file.
  7. Compress all of the extracted files to a zip file.
  8. Change the zip file name extension to *.wsxz.
  9. Open it in Studio.
If WorldServer has applied Legacy Filters to segment the assets/files inside your WorldServer Studio package, the WorldServer Studio package (*.wsxz) will contain a *.xlf file (and not one or more
SDLXLIFF file(s)). Here are the steps to be applied to the XLF file:

  1. Change the Studio package file extension from *.wsxz to *.zip.
  2. Extract the file.
  3. Open *.xlf file on any text editor – for instance in NotePad.
  4. Search for the element iws:dwb-project-info.
  5. Change a value of the element's attribute project_name to any short name. This value corresponds to the project’s name. Just change it to a much shorter name.
  6. Save and close the XLF file.
  7. Compress all of the extracted files to a zip file.
  8. Change the zip file name extension to *.wsxz.
  9. Open it in Studio using the Open Package button.


Note: Changing the project name inside the *sdlxliff or the *.xlf files will not impact the creation of a correct Studio Return project. Your Studio Return package will still be imported to the correct Worldserver project even if in WorldServer the project name has not changed.


Regards
Richard

[Edited at 2013-12-16 14:14 GMT]


Direct link Reply with quote
 

Samuel Murray  Identity Verified
Netherlands
Local time: 04:44
Member (2006)
English to Afrikaans
+ ...
TOPIC STARTER
@Richard Dec 16, 2013

SDL Support wrote:
Workaround 3
If WorldServer has applied Studio File Types to segment the assets/filesinside your WorldServer Studio package, the WorldServer Studio package (*.wsxz) will contain one or more *.sdlxliff files.

  • Find the element SDLWS:ProjectName.
  • Change the value of the element's attribute to any short name. This value corresponds to the project’s name. Just change it to a much shorter name.


  • That would apply here (my WSXZ file contains four SDLXLIFF files). However, the value of that element is 109 characters, which is not very long. The path of the folder in which Trados by default creates folders for extracted projects is 45 characters long.

    Fortunately, the client was able to send me an SDLPPX file instead, which fortunately worked.


    [Edited at 2013-12-16 14:29 GMT]


    Direct link Reply with quote
     


    To report site rules violations or get help, contact a site moderator:


    You can also contact site staff by submitting a support request »

    WSXZ file: Trados says file name is too long to open the file

    Advanced search







    Déjà Vu X3
    Try it, Love it

    Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

    More info »
    SDL MultiTerm 2017
    Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

    SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

    More info »



    Forums
    • All of ProZ.com
    • Term search
    • Jobs
    • Forums
    • Multiple search