Trados 2014: not all segments imported into TM from source and target folders after alignment
Thread poster: abmarwan

abmarwan
Local time: 22:44
English to Arabic
Dec 18, 2013

When I tried to create a TM from a source and target folders (each contains 3 files), after the alignment is complete I got a comment saying that 74 translation units were imported. But when I opened the TM I found that some TUs are missing. I compared the TM with the source and target files and found that many paragraphs and sentences were missing from different parts of the file.

I tried to do files alignment (instead of folders alignment), the problem is still the same. I always get missing segments. Sometimes I get one missing sentence from the middle of a paragraph.

I know about the 50 units in each page and I followed the document in other pages until the end .

Please advise


[تم التعديل في 2013-12-18 08:36 GMT]


 

abmarwan
Local time: 22:44
English to Arabic
TOPIC STARTER
alignment of docx files Dec 18, 2013

Please note that the files I am trying to align are docx files for both source and target.

 

abmarwan
Local time: 22:44
English to Arabic
TOPIC STARTER
SDL SUPPORT TEAM PLEASE HELP Dec 19, 2013

I wish someone from sdl trados support team helps me solve this issue.

 

owhisonant (X)  Identity Verified
Germany
Local time: 19:44
German to English
+ ...
Tried manual alignment? Dec 19, 2013

Haven't done folder alignment, but I have had to align quite a few files to create base TMs. I have found that some segments will line up nicely, others will not. Some segments will run across two or three lines in the source, and only one in the target. They have to be manually aligned, by splitting, joining, editing or sometimes inserting new segments.

Unfortunately, some degree of "manual" labor has been required for every alignment I've ever done ;-/


 

MikeTrans
Germany
Local time: 19:45
Italian to German
+ ...
Not yet a complete feature... Dec 19, 2013

Hi abmarwan,

The Alignment feature in Studio 2014 is not yet a complete feature. It is meant to do a fast alignment on files, and generally it yields a high percentage of successful alignments. According to SDL, in future releases this feature will be improved, notably it will be possible to correct the alignment and set a serie of options to control the process.

Until then, if you want to correct miss-alignments, it's best to create a pseudo-TM with your alignment and do manual corrections (but personally I find this a loss of time). For the moment, one must accept that the feature will just skip (and therefore not treat) unsucessful alignments.

Greets,
Mike

P.S.
More details here in a dedicated video:
https://sdl.dist.sdlmedia.com/vms/distribution/?o=2A74E0DA-A753-4DE2-A42C-9638F347A131

[Edited at 2013-12-19 13:12 GMT]


 

abmarwan
Local time: 22:45
English to Arabic
TOPIC STARTER
I am not even getting some source segments imported Dec 20, 2013

Many thanks Owesonant and Mike for replying.
Unfortunately in my case I didn't even get considerable source segments imported into my TM . It's very time consuming to go into each and every part of the source files to check if they have imported into my TM or not. I don't mind doing manual alignment if both source and target segments are imported but required manual alignment.


 

MikeTrans
Germany
Local time: 19:45
Italian to German
+ ...
LF Aligner Dec 20, 2013

Hi abmarwan,
if your alignment must be done with lots of settings and you want to have total control, then I would use LF Aligner.

https://sourceforge.net/projects/aligner/

Here some details that may be of interest to you:

If LF Aligner fails to align some segments, it will not enforce the alignment, but leave the target cells (or the source cells) empty, allowing you to treat them on the fly in the UTF8 bilingual text file, or better: you can still import these "single" segments and manage them later in a TM manager, joining them if approriate, or exporting them to be further treated. To locate such 'singles' during alignment, press F12 and go through them, correcting or just ignoring them.
A long serie of 'singles' means that topics or chapters are inverted in both the source and target document. In this case, save the alignment, re-arrange the bilingual text file (you can use a simple table in a Word file), then re-open the file with LF Editor.

For other details, e.g. the settings in the "LF Aligner_setup.txt" or the handling of special characters, read the docs included.

Mike

[Edited at 2013-12-20 20:59 GMT]


 

abmarwan
Local time: 22:45
English to Arabic
TOPIC STARTER
LF Aligner Dec 23, 2013

Many thanks Mike . I think I should give LF Aligner a try and see if it works.
I am really disappointed about the quality of the alignment in Studio 2014.


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados 2014: not all segments imported into TM from source and target folders after alignment

Advanced search







BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »
Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search