Studio does not pretranslate/confirm numbers
Thread poster: Tomi Dobaj

Tomi Dobaj
Slovenia
Local time: 12:17
Member (2007)
English to Slovenian
+ ...
Jan 26, 2014

Studio never translate numbers for me, even when I have all the possible forms in the TM already.
It does not even translate or confirm simple 1, 2, 3 during pretranslation (file preparation).

Is there a setting for this (or a workaround:)?

Happy Sunday!


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 12:17
English
Numbers in Studio Jan 26, 2014

Hello Tomi,

The first thing to note is that if the numbers are recognised in the TM then you only need one number in the TM and the rest are automatically recognised. For example, in this example below I created a word document, added the numbers you see in the source side and then opened in Studio with a brand new TM. The first number is recognised and given the AT status; when I confirm it the rest are autopropagated to suit the format of the target language... I went EN to DE:


If I now confirm all of these segments I will still only have one entry in my TM, and this will be the first one I confirmed:


This is because Studio knows these are numbers are only needs one of them in the TM to be able to autopropagate the rest.

You can tell if the number is recognised because it will have a blue line under the number as you can see in segment #3 in the first screenshot and segment #9 in the second screenshot.

Now, if you don't have numbers being recognised then is probably because of one of these things:

  1. The number format is not recognised with the language combination you are using
  2. You have turned off number recognition
  3. You are not using a TM

Two and three are the easiest to deal with... the first is more problematic. Here you may find these articles helpful... or at least they may give you some ideas on how to best handle this situation in Studio:

Working with placeables that are not automatically recognised
http://wp.me/p2xDjK-ep

Search and replace with Regex in Studio – Regular Expressions Part 3
http://wp.me/p2xDjK-7z

The SDLXLIFF Toolkit
http://wp.me/p2xDjK-tu

Pretranslation will work on the same basis... or it should do.

Regards

Paul


[Edited at 2014-01-26 11:17 GMT]

[Edited at 2014-01-26 11:18 GMT]


Direct link Reply with quote
 

Tomi Dobaj
Slovenia
Local time: 12:17
Member (2007)
English to Slovenian
+ ...
TOPIC STARTER
Hello Paul! Jan 27, 2014

Thank you much for the detailed answer. I have no time today to go into Regex, but I want to let you know how my problem looks in practice:

Simple number 1 ("1") is not recognized as AT, but translated as 99% match into "#1", which is obviously wrong. Autopropagation works, but it is much too slow to be used, so I am stuck correcting all such numeric or char forms manually, unpaid. Since these are very large and mostly pretranslated files it would be much help, if at least numbers were pretranslated and corrected properly.

Is there no simple setting I may have missed somewhere?


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio does not pretranslate/confirm numbers

Advanced search







PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search