STUDIO 2014 - Out of memory on big project
Thread poster: Enrico C - ECLC

Enrico C - ECLC  Identity Verified
Taiwan
Local time: 14:30
Member (2011)
English to Italian
+ ...
Feb 18, 2014

Now i am handling a 60k job in 11 files.

Not only it took ages to create the project (i mean ages like in 15 minutes) but now apparently i can't open those files in merged view as i get a variety of messages and then Studio crashes. Same if i try to add a new term (I have 16GB Ram on and i7 cpu, so no slouch).

Has anyone seen this? Is there a workaround?

Thanks in advance.

Forgot: It's eating up around 20% of all memory and it's steady on 1302 MB

Stuck again. Can't translate over 2 sentences

Enrico

[Edited at 2014-02-18 11:38 GMT]


Direct link Reply with quote
 

Antje Matthaeus  Identity Verified
Germany
Local time: 08:30
Member
English to German
+ ...
Translate files separately Feb 18, 2014

You could treat each file as a single file project and work on them one after the other. This takes les memory and it als helps to shut down the computer and turn it back on after completing each file.

Usually it's not the number of words but big images etc that produce this kind of error message. So you could also save all your files as plain text without any format or images, do them all as one 11-file translation project. Then turn the coputer off and then on again and run the individual files with all the images and formating included one by one through the programme again, which will automatically translate then and you can save each file separately to send to the client but still have a project TM, if that's what the client requires.
Several people have asked the same question before here at proz, so you could try searching for the answers to those on this site.


Direct link Reply with quote
 

Enrico C - ECLC  Identity Verified
Taiwan
Local time: 14:30
Member (2011)
English to Italian
+ ...
TOPIC STARTER
Won't work Feb 18, 2014

Antje Matthaeus wrote:

You could treat each file as a single file project and work on them one after the other. This takes les memory and it als helps to shut down the computer and turn it back on after completing each file.

Usually it's not the number of words but big images etc that produce this kind of error message. So you could also save all your files as plain text without any format or images, do them all as one 11-file translation project. Then turn the coputer off and then on again and run the individual files with all the images and formating included one by one through the programme again, which will automatically translate then and you can save each file separately to send to the client but still have a project TM, if that's what the client requires.
Several people have asked the same question before here at proz, so you could try searching for the answers to those on this site.


The client needs the TTXs translated without manipulation (of files, code, or even language combination changing, for example, EN-GB into EN-US). This is a key requirement and each time i do tricks they find out and rant!

Working on single files is more viable. However, it will make the whole thing lenghtier, much lenghtier. I have noticed crashes when it's doing the AutoSave.
Another issue (i have reported in another thread, too) is that for some reason it marked all segments as TRANSLATED. Now i not only have it crashing, but i also have to remark them as untranslated for all the non 100% match segments.

I wonder why, in 2014 this tool still has issues with big files. It's a chronic disease.

Will go for single files. Thanks a lot Antje


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 08:30
Member (2010)
Spanish to English
TTX compatibility Feb 18, 2014

Enrico C - ECLC wrote:

The client needs the TTXs translated without manipulation


Make sure that before you process the files, you uncheck the box "generate document structure information" under the ttx file type (filetypes>TradosTag>Compatibility.

Re. confirmed translated segments. Have you got the box under the one mentioned above ticked by any chance (confirm all translated segments...)


Direct link Reply with quote
 

Zoltán Kulcsár  Identity Verified
Local time: 08:30
English to Hungarian
try to Feb 18, 2014

check your Studio installation, this size is not that large to produce these symptoms.

Increase the size limit of embedded files in the xliff filetype of your project settings.

If that does not work, try to merge the files on the fly in the Files view.

On another note, make sure your ttx files are presegmented with the correct settings before loading them into Studio

[Módosítva: 2014-02-18 18:10 GMT]


Direct link Reply with quote
 

Enrico C - ECLC  Identity Verified
Taiwan
Local time: 14:30
Member (2011)
English to Italian
+ ...
TOPIC STARTER
Answers for all Feb 28, 2014

Zoltán Kulcsár wrote:

check your Studio installation, this size is not that large to produce these symptoms.

Increase the size limit of embedded files in the xliff filetype of your project settings.

If that does not work, try to merge the files on the fly in the Files view.

On another note, make sure your ttx files are presegmented with the correct settings before loading them into Studio

[Módosítva: 2014-02-18 18:10 GMT]


Thanks all and sorry for belated reply.

Going short.

- There is nothing improving this. I was working in merged view. Once files finish to load (5 minutes to load 55/60k words) i can make one or max two sentences before Studio throws an out of memory exception and crashing.
This DOES NOT HAPPEN ifi i open them in 3 or 4 batches (around 10k/15k words and up to 26k to date they work ok although segment insertion becomes very slow, like in 2 minutes per segment while waiting to open close and occasional crashes).
- Do i have installation issues? I don't think so unless the latest update did something wrong. The software works as expected in smaller jobs. Slows generally down with bigger ones (in general and this one in particular).

Additional issues i am having which will cause further wastes of time are:

- TM editing throws an error message each time i edit a segment from main window
- The search window in Review tab is good for for nothing. I insert things like "With 3+3" and it finds nothing when i know for sure there are like 200 occurrences". I use CTRL+F and they pop up one by one. This will have me hunting things one by one during proofreading (extra time, not paid)
- I keep having concordance issues and TM issues. What i have is not showed. I have to hunt for it.

Overall in this case i say the CAT is more a nuisance than a real help. This job was due today...i still have 15k words to go mostly due to these issues.



[Edited at 2014-02-28 04:49 GMT]


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

STUDIO 2014 - Out of memory on big project

Advanced search







memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search