Trados Studio 2014 error: "Object reference not set to an instance of an object"
Thread poster: Théo Amon
Théo Amon  Identity Verified
Brazil
Local time: 22:46
Member
English to Portuguese
+ ...
Mar 31, 2014

Hello:

After working on an apparently innocent PDF project, now I get this error message everytime I try to edit a segment in any project. Even after clicking OK and proceeding to the translation of the segment, I get another error as I confirm the translation: "TM update failed". I had to revert to Trados 2011 to continue working. Has anyone had this issue so far in Trados 2014? Any solution?

Thanks

Théo


Direct link Reply with quote
 
Zhoudan  Identity Verified
Local time: 08:46
Member (2007)
English to Chinese
+ ...
Read this article Apr 1, 2014

http://kb.sdl.com/?portalid=23&articleid=4984

I had this issue before and was able to solve it using Solution 2.


Direct link Reply with quote
 
Théo Amon  Identity Verified
Brazil
Local time: 22:46
Member
English to Portuguese
+ ...
TOPIC STARTER
Solution 1 worked Apr 1, 2014

Oh, thanks, solution 1 from the link worked fine, although I had to repeat it already.

Thanls


Direct link Reply with quote
 
JH LEE
South Korea
Same error Aug 8, 2014

Hello!

I have the same problem.

Whenever I open preview, this massages pop up.
"Object reference not set to an instance of an object"
after remove this massage, whenever I move cursur to any place, this massage pop up...

I already tried every solution in these link
http://kb.sdl.com/?portalid=23&articleid=4984

but, they were not worked...

Is there any other solutions in this error?

I tried re-install trados 2014, but it was also not working...

There is no problem except "preview"


Direct link Reply with quote
 

Tuan Dzung  Identity Verified
Vietnam
Local time: 07:46
Member (2014)
English to Vietnamese
+ ...
I have same issue when the source file is too large Aug 9, 2014

I translated an instruction manual with many pictures and the size of source file (*.docx) was about 10.1 MB, I got the same message after preparing file.
My solution was:
- Separate into 2 parts or
- Save the source file as *.doc and then save back to *.docx, the size reduced to 6.5 MB and it's fine.

NTD


Direct link Reply with quote
 

Madeleine Chevassus  Identity Verified
France
Local time: 02:46
Member (2010)
English to French
I can't understand why this is not fixed for good in Studio 2014. Aug 10, 2014

hello

I had this problem a long time ago with Studio 2011; it is a blocking problem and I lost 1 contract / client.

When switching to Studio 2014, I hoped it was fixed, but it happened again with a PDF file. It was blocking too and I lost again a contract/client. I finally discovered KB # 4984 and sol 2 worked.

What a waste of time and money for everybody!

CAT tools providers should know that new versions are here firstly to correct previous versions bugs, as every software house does!



Direct link Reply with quote
 

Michael Grant
Japan
Local time: 09:46
Japanese to English
Another possible solution for "Object reference not set to an instance of an object" Error Aug 13, 2014

Hi folks,


I just found this thread while searching for a solution to this problem while reviewing a file I received from a translator. I tried everything in the linked solution documents short of reinstalling SDL, nothing worked. Then, I noticed that the document had a lot of comments in it! Comments in Word documents have been the source of errors in the past, so I deleted all of the translator's comments and...voila! The "Object reference not set to an instance of an object" error was resolved!!

The next time you have this problem, check and see how many Word comments there are in the document (assuming it's a .doc/.docx). Like me, you may find that deleting those comments resolves your issue!

Hopes this helps someone in the future...
MLG4035

[Edited at 2014-08-13 02:13 GMT]

[Edited at 2014-08-13 02:13 GMT]


Direct link Reply with quote
 

Madeleine Chevassus  Identity Verified
France
Local time: 02:46
Member (2010)
English to French
is there a Trados studio version which resolves the problem? Aug 15, 2014

hi again,

I have the problem (symptom 1 according to KB # 4984 with corresponding error messages) and I try to apply solution 1.

However, if I switch from Version 3.0.3709.0 to version 3.0. 3720.0 (Studio 2014), would that solve the problem for good?

Thank you - Madeleine

Context: Windows7.


Direct link Reply with quote
 

Dr. Lausberg de Morales  Identity Verified
Guatemala
Local time: 18:46
Member (2004)
German to Spanish
+ ...
Resolved in Windows settings Sep 10, 2014

Dear colleagues, I had the same issue with SDL Trados Studio 2014 on Windows 8.1.

I found out that in my case, the security settings for my user account in Windows were nor properly configured. In Windows 8.1, I did the following:

In Windows Explorer, I accessed the C:\Users\Uta\AppData\Local\Temp path. I found two SDL folders there:

1. SDLTempFileManager
2. SDLTempFileRegen

For each folder, I right-clicked on the folder name and selected "Properties" from the popup menu.

In the dialog box that opened I selected the Security tab.

I clicked on the Edit button.

In the top pane I clicked on "Users (name of my Windows user account)".

In the bottom pane there is a list with permissions. I selected "Total control" (first item). I guess it is important to activate the write permissions in this pane but I activated them all just to be sure.

I confirmed with "OK" (Aceptar in Spanish), and again "OK".

With that procedure, SDL is working properly again.

I hope it may help you, too, good luck!
Uta


Direct link Reply with quote
 
Jorgen1977
Local time: 03:46
English to Norwegian (Bokmal)
+ ...
Converted to .doc May 11, 2015

I had this happening with a .docx document during preparing, but I solved it simply by saving it as a .doc.

Direct link Reply with quote
 

Alex Lilo
Ukraine
Local time: 03:46
English to Russian
+ ...
Object reference not set to an instance of an object Sep 5, 2015

Madeleine Chevassus wrote:

hello

I had this problem a long time ago with Studio 2011; *** What a waste of time and money for everybody!




I encounter this problem almost every time I translate a powerpoint presentation or some other files, also quite often when I work on a large file. every time I can't open a sdlxliff file after the error, I go to C:\Users\[My User Name]\AppData\Roaming\SDL\SDL Trados Studio\11.0.0.0 and either delete or rename the three xml settings files (BaseSettings, plugincache and UserSettings).

If I have a very large file, I may have to delete the settings every time I try to open the sdlxliff file in Studio to continue with the translation. This is not a major situation but it certainly takes a bit more time to finish a project. To save time, I created a shortcut to the settings folder so I don't have to find it again and again. I actually created lots of shortcuts to all kinds of SDL folders to be able to quickly fix a problem or to do a full reset if nothing helps. So, sharing my recipe: create a shortcut to C:\Users\[My User Name]\AppData\Roaming\SDL\SDL Trados Studio\11.0.0.0 to save time when you have a project like this and can't open your file after "Object reference not set ..."


Direct link Reply with quote
 

Alex Lilo
Ukraine
Local time: 03:46
English to Russian
+ ...
http://kb.sdl.com/#tab:homeTab:crumb:7:artId:5375 Sep 6, 2015

didn't help me, but it is a good idea to keep your Studio updated

http://kb.sdl.com/#tab:homeTab:crumb:7:artId:5375

Cumulative Update 10 (released on 13 May 2015)

This cumulative update (CU) includes all previous cumulative updates for SDL Trados Studio 2014 and the following enhancements and hotfixes:

Fixed the Object reference not set to an instance of an object error when the Edit Source mode is still active in a document.


Direct link Reply with quote
 
Nick Hoyle
Local time: 01:46
German to English
Object reference error when trying to open a document Sep 17, 2015

This is a slightly different scenario - but still related - so I thought I'd share my solution with you:
I had a frustrating time yesterday trying to open a PowerPoint presentation and kept getting the notorious "Object reference not set to an instance of an object" error message while Studio was trying to preprocess the file.
Then I remembered a workaround I've used before for this problem with Word documents:

Open the problem file in its native format (PowerPoint, Word)
Open a new blank document in that format as well
Copy and paste the entire content of the problem file into the new blank document (to do this in PPTX I went into the Slide Sorter view in both documents)
Save the new document as a new name

I've usually found that Studio will now let you open and translate it.
You may lose some formatting; I didn't lose much in my PowerPoint, mainly the background of my title page, so I suspect that's what was causing the problem.

Hope this helps!


Direct link Reply with quote
 

Karin Kutscher  Identity Verified
Local time: 21:46
Member (2005)
English to Spanish
+ ...
Thank you so much Jan 16, 2016

Alex Lilo wrote:

either delete or rename the three xml settings files (BaseSettings, plugincache and UserSettings).



Alex, you've saved me a ton of work! SDL's KB is not working right now... Your solution did it for me instead. There are still people who care about others and you're one of them. [-:

Love,
Karin


Direct link Reply with quote
 
kchansen
Local time: 02:46
English to Danish
Object reference not set to an instance of an object Jan 24

I had a similar problem. When I tried to open a file in the editor, I got the "Object reference not set to an instance of an object" error message, and the editor would just shut down immediately. I could do anything else with the project - batch tasks, export a return package - just not open the editor! Which was a pain in the extreme lower back because I had finished the translation and only needed to insert my own changes.

I tried all the solutions I could find on the internet, re-imported the original package from the client, added my own return package, to no avail.

Then in the "Files" view I tried this:

- Right-click the .SDLXLIFF file and choose "Open With".
- Choose to open it in SDL Trados Studio (duh!).
- Make a change (and change the document back).
- Save the .SDLXLIFF and close the editor.
- Try to open the file for translation again. It opened like a charm.

The drawback is, I had to re-add all TMs and termbases.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados Studio 2014 error: "Object reference not set to an instance of an object"

Advanced search







PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search