I need a function which makes 'expections'...
Thread poster: xxxsjmdcl

xxxsjmdcl
Local time: 06:27
English to Spanish
+ ...
May 10, 2014

I don't know if Trados Studio already has something similar to this:

1) Let's say the source has the phrase "black dog".
2) The software shows me two segments: black and dog.
3) The target language rules change the order so I have to translate "black" as "perro" and "dog" as "negro".

Is there any option in order to make an "exception" so in future translations "black" won't be translated as "perro"?

Thanks


 

Emma Goldsmith  Identity Verified
Spain
Local time: 12:27
Member (2010)
Spanish to English
Segmenting issues from hard returns May 11, 2014

The reason you have "black" and "dog" in two separate segments is probably a hard return (paragraph mark) after "black" in your source text. This often happens in tables and ppt files.

If you don't have a hard return, the solution is simple. Merge the two segments together (right click the segment number column and click merge). If there's a hard return, this option will be greyed out.

Presuming this isn't the case here, and you can't merge the segments, the aim is to stop Studio from storing a segment in your TM that translates "black" as "perro". I use two workarounds to avoid this.

The quickest:
- Translate the segment. Change the segment status to confirmed if you like, but don't use "confirm and move to next segment" because you don't want it saved to your TM. In fact, I lock these segments to make sure I don't confirm and save it later by mistake.

Another solution:
- Use "edit source" (if the filetype lets you) and perform a pseudomerge by typing the two words in the first segment. Enter a space (or similar) in the second segment.
Now you can translate "black dog" in a single segment and save the correct translation to your TM.


 

xxxsjmdcl
Local time: 06:27
English to Spanish
+ ...
TOPIC STARTER
I'll try your suggestions thanks! May 11, 2014

Emma Goldsmith wrote:

The reason you have "black" and "dog" in two separate segments is probably a hard return (paragraph mark) after "black" in your source text. This often happens in tables and ppt files.

If you don't have a hard return, the solution is simple. Merge the two segments together (right click the segment number column and click merge). If there's a hard return, this option will be greyed out.

Presuming this isn't the case here, and you can't merge the segments, the aim is to stop Studio from storing a segment in your TM that translates "black" as "perro". I use two workarounds to avoid this.

The quickest:
- Translate the segment. Change the segment status to confirmed if you like, but don't use "confirm and move to next segment" because you don't want it saved to your TM. In fact, I lock these segments to make sure I don't confirm and save it later by mistake.

Another solution:
- Use "edit source" (if the filetype lets you) and perform a pseudomerge by typing the two words in the first segment. Enter a space (or similar) in the second segment.
Now you can translate "black dog" in a single segment and save the correct translation to your TM.


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

I need a function which makes 'expections'...

Advanced search







Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »
WordFinder Unlimited
For clarity and excellence

WordFinder is the leading dictionary service that gives you the words you want anywhere, anytime. Access 260+ dictionaries from the world's leading dictionary publishers in virtually any device. Find the right word anywhere, anytime - online or offline.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search