Pages in topic:   [1 2 3] >
Multiterm 2014, Termbase (default): Added terms disappear when application closes.
Thread poster: Yoko Busk

Yoko Busk  Identity Verified
United Kingdom
Member (2010)
Japanese to English
+ ...
May 19, 2014

Conditions: Studio 2014, Multiterm 2014.

I'm currently experiencing the same situation for the 2nd time.

I added hundreds of new entries in a project (default) termbase while working on 39k project on Studio 2014. I left the application open for several days. The termbases were returning the results and recognising the terms including what I newly entered.
But, when I closed the application after I completed the project and created return package.
I opened my PC the next day when PM asked me to check some points in the file, I found out all the terms I entered were gone. The originally empty default termbase was empty again.

Then I started new project with the same condition, added new terms in a default termbase. I closed the application in the middle as I had a connection problem.
Then, I resumed Studio and the project, and found out all the newly entered terms were gone.

I'm suspecting this 'newly entered terms disappear' situation is happening whenever I close the Studio 2014.
I've checked all the user settings and options, but I don't see any customisable Termbase saving option.

Is this a known issue or does anybody can offer me advice?
Multiterm is a life saver when it works, but when it doesn't really kills me, especially when I was asked by a client to build glossary.

Thank you for your help in advance.


Direct link Reply with quote
 

Alex Lilo
Ukraine
Local time: 03:28
English to Russian
+ ...
same here Sep 14, 2014

I have lost as many as 80,000 technical terms using SDL Multiterm.

Had to use it again yesterday and today. Well, the almost seven hundred terms I added yesterday into a new termbase (I added many manually) were gone today!!! there are a few terms left in the termbase, but just a few.

I closed all applications properly and turned off my computer and turned it back on today, started the Studio and... a very bad surprise again.

Trados Studio download and installed some latest update yesterday. Maybe something in that update...


Direct link Reply with quote
 

Alex Lilo
Ukraine
Local time: 03:28
English to Russian
+ ...
holy... Sep 14, 2014

I just checked and I have losts so many more terms from other projects....
Also, just now added a term through SDL Trados Studio, saved, exited, started again and ... the term is no longer in the termbase!!! You are right. Terms are only there as long the Studio is open and then they are gone. I think it is the latest update.


Direct link Reply with quote
 

Yoko Busk  Identity Verified
United Kingdom
Member (2010)
Japanese to English
+ ...
TOPIC STARTER
Regardless of update... Sep 14, 2014

Hi Alex. It is indeed a bad surprise, especially after you built up big termbase for large projects.
My case happened before recent update. I inquired the tech support of my agency but she couldn't find why it happened.
The only thing I was certain was, it happens if I close the application. So until the project finished I never closed the application (for nearly 2 weeks). And as another precaution, I copied and saved termbase in different location.

Somehow, this accident stopped happening recently. But I still copy and save termbase in another location in case it happens again and make me cry. It happened twice in a row for big projects. I will attend SDL roadshow in October so will raise this question directly to SDL people.


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 02:28
English
Can you confirm... Sep 14, 2014

... the actual build numbers of Studio and Multiterm that you are using? You can find this in the Help -> About in Studio.

We do have some reports of this in our Beta communities as well, but not from everyone. So we have been using logging software to try and determine what the cause is. So far we have not nailed this down, and we can't find a way to reliably reproduce it either. So if any of you can cause this to happen at will we'd be very interested to take a look at your setup?

A few questions for you.

  • while translating a particular document are the terms returned from multiple termbases? So is the first recognized term returned from the default, and the rest from other termbases for example?
  • do your termbases share the same entry/input model structure
  • do they have same language combinations?
  • can you repro the issue in all languages or only specific ones?
  • are you using an external drive for your databases?
  • what kind of antivirus, defragmentation, or backup software are you using and how often is it running?

Thank you

Paul


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 02:28
English
80,000? Sep 14, 2014

Alex Lilo wrote:

I have lost as many as 80,000 technical terms using SDL Multiterm.



Hi Alex,

This doesn't sound like the same problem as this is a significant number... probably more than most termbases in their entirety. Can you elaborate with any details on what you were doing when you found you had lost 80,000 terms?

Thank you

Paul


Direct link Reply with quote
 

Alex Lilo
Ukraine
Local time: 03:28
English to Russian
+ ...
80,000 Sep 17, 2014

Hi Paul,

this is a separate incident that happened several months ago. an ordinary day, no new updates, everything as usual. I added several terms into a large database. there was an error and Studio crashed. When I started Studio again, it could not use the termbase, Studio did not respond for a long time so I had to shut it down. it was not responsive again and again and so I disconnected the termbase and the translation memory before opening the translation file. looked at the memory and the tb to see what could be the problem. the tm was fine, but I could not open the tb in multiterm and could never recover the terms.

what Yoko described is a different problem that occurred last weekend and lasted for two days. I used a new clean TB to add terms from within Studio and all terms later disappeared. I deleted that TB and continued using an old one, which is large and I kept getting an Unknown exception error after adding two or three terms, but at least all added terms are still there.

i am not using SDL Trados right now. The current project involves Memsource. Let me send you the details you asked for as soon as I have finished my work.


Direct link Reply with quote
 

Alex Lilo
Ukraine
Local time: 03:28
English to Russian
+ ...
answers to Qs Sep 18, 2014

SDL Support wrote:

... the actual build numbers of Studio and Multiterm that you are using? You can find this in the Help -> About in Studio.

We do have some reports of this in our Beta communities as well, but not from everyone. So we have been using logging software to try and determine what the cause is. So far we have not nailed this down, and we can't find a way to reliably reproduce it either. So if any of you can cause this to happen at will we'd be very interested to take a look at your setup?

A few questions for you.

  • while translating a particular document are the terms returned from multiple termbases? So is the first recognized term returned from the default, and the rest from other termbases for example?
  • do your termbases share the same entry/input model structure
  • do they have same language combinations?
  • can you repro the issue in all languages or only specific ones?
  • are you using an external drive for your databases?
  • what kind of antivirus, defragmentation, or backup software are you using and how often is it running?

Thank you

Paul



Paul, Hi again!

“… a significant number... probably more than most termbases in their entirety…”

Just to confirm that the ‘80,000’ number is not out of thin air. It was one of my first TBs that I built over many years and a merge of several TBs on similar domains. Since I maintained and reorganized the TB, I knew approximately how many terms there were before it became corrupted and unusable.
But again, that is a separate issue that happened once and months ago.

About your questions regarind the latest issue.

Version numbers:

SDL Trados Studio 2014 SP1 - 11.1.4095.0

SDL Multiterm 2014 SP1 -11.1.1266.0

Java 7 Update 65.
Origianlly Java 8, but with this version I would get too many errors and at one point continuing to add terms became impossible, so I used the SDL Java Cleanup tool for resolving Java-related error to install Java 7 Update 67. With this version, I was able to add terms, but continued getting an unknown exception. I installed Java 7 Update 65 (It did not fix the error), then Update 25 (could not add terms at all) and went back to Update 65.

PC: Windows 7 x64 Professional (latest version, administrator account, have all rights, UAC disabled), Intel Core i7, 16 GB RAM

“…. So if any of you can cause this to happen at will we'd be very interested to take a look at your setup ….”

I will try on another project when I have to use SDL Studio. I try not to use it if I don’t have to or if my client does not require a terminology list from the project.

-Multiple (three)

-First recognized from the default and the rest from other

-Yes, all share the same input model

-Same language combinations (English and Russian)

-No, a physical internal SATA-3 harddrive only.

-Antivirus: Esset NOD32 and Windows Firewall enabled

-Defrag: Windows native defrag tool, once a year

-Not using backup (I probably should).

Hope this helps.


Direct link Reply with quote
 

Bruno Depascale  Identity Verified
Italy
Local time: 02:28
Member (2009)
English to Italian
+ ...
This is an old problem (2 years for me) Dec 11, 2014

Hi everybody,
I have the same problem since 2 years now.
I already talked 2 years ago with trados support. They visited my computer and said the problem was due to the fact I was running trados on a virtual machine.
However, I haven't still managed to solve the issue.
The strange thing is that it doesn't happen always or with all terms: it only happens when there is some error in Trados studio in adding a new term or when I close trados.
And I think it only concerns the last 20-30 added terms..


Direct link Reply with quote
 

Alex Lilo
Ukraine
Local time: 03:28
English to Russian
+ ...
happened again Jan 14, 2015

Yesterday, I was working on a client's computer in their office. They have SDL Trados Studio 2014. I did not copy the build information. I don't think it was SP2, so maybe SP1. They asked me to add terms to a new TB. When I finished last night, I saved and closed everything. This morning I returned to finish a few sentences and to proofread the translation and.... the TB was empty! (it is not the same computer as in my first post.) The client was not happy. I had to show him this thread. Anyway, don't want to spend too much time on this. I extracted the terms using a free service online, translated them and added to the TB. Closed it, rebooted the computer. the terms did not disappear. the client was happy. He may check out this thread and provide more details. I am just telling the problem is still there. and this was not a virtual machine.

This thing does not happen often. I don't really know what could have caused it on that computer. Studio (F8) did not show any errors. it was plain text so not even any formatting issues. everything looked ok, but eventually I had to do the same job twice.


Direct link Reply with quote
 

Orrin Cummins  Identity Verified
Japan
Local time: 10:28
Japanese to English
+ ...
Here is something interesting Mar 5, 2015

After having the same problem and searching out this thread, I noticed something just now.

If I try to add a term pair that does not appear in the termbase, I get the unknown exception.

But if I try to add a term pair in which one of the terms is already in the termbase, the normal pop-up comes up asking me if I want to edit the existing term. If I choose yes, and then try to save that addition, it works. However, trying again to add a pair that is not in the termbase still fails after that.

This information is probably useless to anyone without access to Studio's code, but it is interesting. Why would I be able to save in one situation and not the other?

Edit: I forgot to mention that this is in Studio 2014, and I just realized that this thread is probably talking about the standalone Multiterm, but maybe they are related somehow...

[Edited at 2015-03-05 15:19 GMT]


Direct link Reply with quote
 

Alex Lilo
Ukraine
Local time: 03:28
English to Russian
+ ...
... about the standalone Multiterm, but maybe they are related somehow. Jun 23, 2015

Orrin Cummins wrote:

: I forgot to mention that this is in Studio 2014, and I just realized that this thread is probably talking about the standalone Multiterm, but maybe they are related somehow...

[Edited at 2015-03-05 15:19 GMT]



The thread is about Studio and it is related to Multiterm.

What you describe is a common error for versions dependent on Java. But you can update to Service Pack 2 (free update for your 2014 Studio) and this problem is very likely to disappear. Some continue experiencing the same problem or worse after installing SP2. If this happens to you, contact support. They will help you identify the files and registry entries causing the problem on your computer.

I also noticed that even though you can open your old projects after updating, it may be a good idea to create new projects from scratch in the updated Studio.

If you continue getting unknown exception, you can try renaming the settings files in C:\Users\[INSERT]\AppData\Roaming\SDL\SDL Trados Studio\11.0.0.0 This may help.


Direct link Reply with quote
 

Alex Lilo
Ukraine
Local time: 03:28
English to Russian
+ ...
terms disappearing from a multiterm tb Aug 29, 2015

Hi again! I was in Kiev yesterday and used an agency's sdl trados studio 2014. I got a phone call today about the 120 terms I added to a fairly large TB yesterday. the problem is they are all gone today. or so the owner said. the owner also explained that they had opened the sdlxliff file and noticed that very few terms were highlighted. so they searched for the terms individually and found none. I am not sure if all the terms are gone, since I don't think they tried to find every one of the 120 on the list, but they could not find any of the terms they tried from the list.
part of the job was to export the terms into a spreadsheet. so they still have the terms in the spreadsheet. they also shared the tb yesterday with other translators for a large project.

this particular situation is resolved. they used a glossary converter to create a new tb from the excel file.

but the question remains, why do terms disappear from a TB?


Direct link Reply with quote
 

Alex Lilo
Ukraine
Local time: 03:28
English to Russian
+ ...
same old problems - entries completely disappeared without warning in Multiterm IX Aug 29, 2015

Just a few minutes after my previous post, I am browsing Terminology, Computing and Translation by Pius ten Hacken and this is what I see:

"... There are however a number of disadvantages which were encountered while using Multiterm IX. One of these is a particularly low level of stability. It appears to be quite easy to lose data. Entire entries seem to completely disappear without warning, or the programme refuses to save changes made to entries. In fact editing imported entries can sometimes be a very frustrating process. ..."

I wonder if SDL MultiTerm 2015 has the same bug inherited from Multiterm IX, since apparently it hasn't been eliminated in SDL MultiTerm 2014.


Direct link Reply with quote
 

Alex Lilo
Ukraine
Local time: 03:28
English to Russian
+ ...
at least 5 different computers with at least one thing in common Aug 29, 2015

one thing to consider if somebody wants to capture and investigate the issue...

at least 5 different PCs where this problems persists also have some old versions of Trados installed parallel to SDL Trados Studio 2014 and some of these users still experience the unknown exception error when adding terminology in SDL Trados Studio 2014 SP2.

Hope this helps.


Direct link Reply with quote
 
Pages in topic:   [1 2 3] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Multiterm 2014, Termbase (default): Added terms disappear when application closes.

Advanced search







BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »
Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search