Incorrect handling of single quotes upon TMW -> TXT export
Thread poster: rdurff
rdurff
English to German
Dec 1, 2004

Hi All,

Environment: Trados 6.5.5.438 on Windows XPSP2 Machine

Problem: I need to export an English -> French translation memory to a text format. When I do, instead of getting proper looking single quotation marks (n'utilisez), I get ugly tagging instead (n\rquote utilisez).

Such segments look good (proper quotation marks) in the basic TM maintenance window, but if I drill down I can see that the \rquote tag is there in the code of the TM itself. So, the export process is doing its job too faithfully -- exporting exactly what's in the TM as opposed to recognizing that \rquote represents a single quotation mark.

This looks like the remnants of MS Word Smart Quotes to me -- where tagging is used instead of the actual character.

Has anyone seen this behavior before? I'm looking for possible root causes and potential workarounds. Is there a setting I've missed in Trados that controls this?

Thanks very much,
-Robert


Direct link Reply with quote
 

Ben Hickman  Identity Verified
Sweden
Local time: 17:34
Dutch to English
RTF coding Dec 1, 2004

Hello Robert,

The Trados TMs are stored in RTF format, which accounts for the coding you are seeing. This can be rather inconvenient when you want to edit segments in the Workbench or in an exported TXT file.

In the past I have edited a lot of exported TMs in a text editor by exporting them to TXT and then reimporting them into an empty TM. You have to be very careful though... search and replace can lead to undesirable results. Take the job I'm working on today for instance. Someone must have translated to American English and tried a quick-and-dirty fix to make it British English. The result was a TM full of garbage entries like "entyrely" ("tire" => "tyre").

If you decide to go this route, I suggest you use the "REPLACE and FIND NEXT" option in your text editor and not "REPLACE ALL". A very good text editor for this sort of work is UltraEdit-32, which is available for download from www.tucows.com.

Changing "\rquote " to "'" should do the trick. Be sure you include the space after \rquote. That's part of the tag!


Direct link Reply with quote
 
rdurff
English to German
TOPIC STARTER
Thanks & Follow Up Question Dec 1, 2004

Thanks very much for the post, Ben! I use UltraEdit on a daily basis and am very impressed with it.

It's too bad that Trados doesn't convert the RTF coding into the equivalent characters upon export. There's no way to force it to do so, is there?

Thanks again folks,
-Robert


Direct link Reply with quote
 
rdurff
English to German
TOPIC STARTER
Follow Up --> Root Cause is Word Smart Quotes Dec 1, 2004

Hi All,

I've done some further tests and determined that the problem was due to localizing in Word with Smart Quotes enabled. Details:

- Created a test document with 3 simple English sentences.

- Created a new EN-US -> FR-CA TM

- Opened Word (Smart Quotes enabled) and translated the document into (very poor) French; each sentence contained at least one use of a single quotation mark, as in m'appelle

- In Translator's Workbench, I looked at the individual segments of the resulting TM (File -> Maintenance -> Begin Search -> Right-Click on TU -> Edit Translation Unit...) and observed the offending \rquote tags.

- Created a second TM

- Opened Word and disabled Smart Quotes, then translated the same document into French

- In Translator's Workbench, I looked at the translation units the same way and noticed no RTF tagging. In other words, localizing with smart quotes disabled leads to proper single quotes ( ' ) as opposed to tagging ( \rquote ) in the TM.

So -- be warned of smart quotes in Word! They can lead to problems if you need to export the resulting TM to TXT.

-Robert


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Incorrect handling of single quotes upon TMW -> TXT export

Advanced search







LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »
CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search