Term recognition not displays term at the end of long segment, trados 2014
Thread poster: Long Hoang

Long Hoang  Identity Verified
Vietnam
Local time: 15:02
English to Vietnamese
Jul 27, 2014

For example:

WebRTC uses a server called Web Conferencing Server that in conjunction with a STUN Server it is required to provide the initial page and synchronise the connections between two WebRTC endpoints. WebRTC is rapidly gaining ground and set to revolutionise the communication standards.

This segment is in a cell of excell. TB has: server, standard.

Case 1: Source and target segment is displayed on a row. In Term recognition window, just display only "server" term, not "standard", but can search in termbase search

Then split segment into two rows:
a.WebRTC uses a server called Web Conferencing Server that in conjunction with a STUN Server it is required to provide the initial page and synchronise the connections between two WebRTC endpoints.
b.WebRTC is rapidly gaining ground and set to revolutionise the communication standards.

Click mouse on a row, Term recognition window displays "Server" term
Click mouse on b row, Term recognition window displays "standard" term

And can not merge 2 splited segments become the original one.

Case 2: Trados automatically splits this segment into two rows as above. And displays "server" and "standard" term in tem recognition when clicking mouse to appropriate segment.


Please help me to explain how Trados works with this.


Direct link Reply with quote
 

Long Hoang  Identity Verified
Vietnam
Local time: 15:02
English to Vietnamese
TOPIC STARTER
Problem solved Aug 16, 2014

I have found the problem for this by myself not only with 2014 but also 2011. The reason is Trados just searchs terms within 256 chars of segment. If means if segment includes more than 256 chars, the term begins from char 257 will not be recognized.

Is it right with yours ?

If yes, hope it can help someone faced the same problem with me.


Direct link Reply with quote
 

Henning Holthusen  Identity Verified
Philippines
Local time: 16:02
English to German
+ ...
Unfortunately, it appears not to be the case... Aug 26, 2014

I just checked - it's not true. I looked at a couple of sentences longer than 600 characters and at least some terms are recognized even if they appear for the first time after more than 500 characters.

[Edited at 2014-08-26 11:30 GMT]


Direct link Reply with quote
 

Lorenzo Bermejo
Local time: 10:02
English to Spanish
+ ...
That's good news Aug 26, 2014

Nice to know that, Henning, thanks for telling.
Nevertheless, Multiterm DOES have a very mysterious behaviour and decides randomly to show terms or not.
Let's hope they fix it one day.


Direct link Reply with quote
 

Long Hoang  Identity Verified
Vietnam
Local time: 15:02
English to Vietnamese
TOPIC STARTER
Giving up investigation this problem Aug 27, 2014

Hi Henning and Lorenzo,
I am glad to see you in my topic. I am waiting for everyone's response nearly hopelessly.

After I posted the second, I also realized I was wrong but do not know the correct answer. Because I inserted one more "standard" before "." of first sentence. Term recognition appears "server" and "standard" but highlights the second "standard". It means it recognized char after 256.

Besides, I asked my friend to do the same examination, his trados is normally with that paraghaph?
He did:
-Copy and paste that paragraph in WORD
- Trados automatically splits into a and b row
- Term recognized terms at a or b row when choosing
-Merge two rows becomes 1
- Term recognized two terms normally

I also did the same thing but the last step, my term not recognized "stardard", just only one "server".

Did I do something wrong? Or my Trados's setting?

I almost give up to solve this problem. But always keep in mind about this for further.

@Henning: you said that: "I looked at a couple of sentences longer than 600 characters and at least some terms are recognized even if they appear for the first time after more than 500 characters." it means not-all terms you want appear ? The other terms is not recognized ?

@Lorezo: Everyone sometimes has the same problem with term ?


Direct link Reply with quote
 

Henning Holthusen  Identity Verified
Philippines
Local time: 16:02
English to German
+ ...
Some terms appear, others don't Aug 30, 2014

It is usually the case that in long sentences, some terms are recognized, and others are not. I have not been able to find the pattern behind that so far.
This is just one of those ways where Trados is badly programmed. The same applies unfortunately to concordance searches, which are very unreliable, not to mention inexplicably slow.
In some projects, I've taken to opening an export of the TM in an editor and using the editor search function.


Direct link Reply with quote
 

Lorenzo Bermejo
Local time: 10:02
English to Spanish
+ ...
Yes Aug 30, 2014

Long Hoang wrote:

@Lorezo: Everyone sometimes has the same problem with term ?


Hi Long,
Yes, there are quite a few posts about this problem. No one has come to a solution. I guess the only solution is to have a good memory and remember the translation of the term when it doesn't appear in the Viewer, although we've seen it in other segments.
Kind regards.


Direct link Reply with quote
 

Long Hoang  Identity Verified
Vietnam
Local time: 15:02
English to Vietnamese
TOPIC STARTER
Thank you for your info Sep 2, 2014

Hi Henning, Lorenzo,

Thank you for your info.

However, I still wonder why my friend's result is different to mine with the same example and trados 2014.


Direct link Reply with quote
 
Saulius_S
Lithuania
Local time: 11:02
English to Lithuanian
+ ...
The same problem Nov 1, 2014

Yes, SDL Trados Studio 2014 SP1 - 11.1.4095.0 still has this problem. Terms, that are beyond 256 characters of the segment are not recognized, if they are not repetitions of previous terms in this segment.
Concordance (Ctrl+F3) can help a bit in this case, but search of a single word in large memories slows down the process. Unfortunately there are no single keyboard shortcut access to Termbase Search for highlighted word, like it was in Trados 2007.


Direct link Reply with quote
 
Saulius_S
Lithuania
Local time: 11:02
English to Lithuanian
+ ...
The same problem Nov 20, 2014

In Trados Studio 2014 SP2 this remains not corrected.

Direct link Reply with quote
 

David Terhart  Identity Verified
Germany
Local time: 10:02
English to German
+ ...
Will not be resolved in Studio 2014 Oct 28, 2016

This issue annoys me for years now. Finally, after searching it, I found out that it is a bug and will not be resolved in Studio 2014. Paul Filkin of SDL writes:

This is a known bug... resolved in Studio 2015.
and
The only way to avoid this in 2014 is to have shorter segments.
Source: https://community.sdl.com/solutions/language/translationproductivity/f/91/p/4110/15240#15240


Direct link Reply with quote
 

Artem Vakhitov  Identity Verified
Estonia
Member (2012)
English to Russian
+ ...
Unacceptable Oct 28, 2016

To me, this situation is unacceptable. This is one of the reasons I'm skeptical of SDL's term recognition technology (another being the slow-down it causes on my system) and prefer to avoid it altogether except where mandated by the client.

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Term recognition not displays term at the end of long segment, trados 2014

Advanced search







memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search