all text in sdlxliff is red
Thread poster: Lianne van de Ven

Lianne van de Ven  Identity Verified
United States
Local time: 10:43
Member (2008)
English to Dutch
+ ...
Aug 31, 2014

Does anyone know why my regular looking word document (black font) shows up in red in my sdlxliff? The target font is also red. These are normally black, and, actually, one of my 2 documents in this project is regular black.

I have saved a version with CodeZapper to no avail. It's going to be fairly annoying to look at the "alarming red" for the next 5000 words, so I hope someone has seen this before and knows a solution.

Thank you for any suggestions.

(Windows 7 Home Premium, Studio 2014 SP 1 - 11.1.3952.0)

[Edited at 2014-09-01 04:25 GMT]

[Edited at 2014-09-01 04:26 GMT]


Direct link Reply with quote
 

Lianne van de Ven  Identity Verified
United States
Local time: 10:43
Member (2008)
English to Dutch
+ ...
TOPIC STARTER
SDL support Sep 1, 2014

Anyone?

Thank you.


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 16:43
Member (2010)
Spanish to English
Show formatting/tags settings Sep 1, 2014

I once saw a doc that Studio processed with strikethrough font all the way through!

I'm not sure, but you might solve the red font issue by going to File>Options>Editor>Formatting display style: "Show all tags but do not show formatting."

You might also want to check that the target file saves in the right colour and the red font is just a display problem.


Direct link Reply with quote
 

Lianne van de Ven  Identity Verified
United States
Local time: 10:43
Member (2008)
English to Dutch
+ ...
TOPIC STARTER
Good workaround Sep 1, 2014

Emma, your solution works, thank you. I would call it a workaround, though, because it also removes other formatting which needs to be applied to the target (underlines and bolds). I will probably revert back and use the "solution" I had, which is changing the background of the highlighted segment to ** PEACH ** for a color combination that is least painful to my eyes.

Do you know what determines how Studio processes doc files, and "inherits" formatting versus creates tags for it? Is there any codezapping built into Studio?

Your reference to the underlined document suggests (confirms?) that the underlying issue is coding in Word. I would have hoped CodeZapper would take care of that, but maybe it is something like a missing closing tag? Without a proper closing tag in HTML, formatting applies to an entire document - sometimes even when it displays fine in word.

I did check my output file and that looks fine.

Thanks for your help!


Direct link Reply with quote
 

Lianne van de Ven  Identity Verified
United States
Local time: 10:43
Member (2008)
English to Dutch
+ ...
TOPIC STARTER
formatting display style Sep 1, 2014

Lianne van de Ven wrote:

Do you know what determines how Studio processes doc files, and "inherits" formatting versus creates tags for it? Is there any codezapping built into Studio?



I see this is actually rather a setting of "formatting display style" too: "show all formatting and tags" displays tags as well as underline/bold. I had it "show formatting but hide recognized formatting tags."


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 16:43
Member (2010)
Spanish to English
More thoughts Sep 1, 2014

Lianne van de Ven wrote:

Emma, your solution works, thank you. I would call it a workaround, though, because it also removes other formatting which needs to be applied to the target (underlines and bolds).

The workaround doesn't remove the formatting, it just doesn't display it. Actually, I work with this setting most of the time (display tags, not formatting).


Do you know what determines how Studio processes doc files, and "inherits" formatting versus creates tags for it? Is there any codezapping built into Studio?

Formatting and tags are the same thing. Formatting is just a user-friendly way of displaying tag content (WYSIWYG).
The closest you get to codezapping in Studio is to "skip advanced font formatting" in docx files (this setting is in the docx filetype under File>Options>Filetypes>MS Word 2007>Common). But I don't think it will help in your red font case.


Your reference to the underlined document suggests (confirms?) that the underlying issue is coding in Word.

Possibly. Actually my document was crossed out, not underlined (much worse, as you can imagine!)


I did check my output file and that looks fine.

Glad to hear it!


Direct link Reply with quote
 

Lianne van de Ven  Identity Verified
United States
Local time: 10:43
Member (2008)
English to Dutch
+ ...
TOPIC STARTER
Solved it! Sep 1, 2014

Thanks for your additional thoughts, Emma.

I would like to find out a bit more about the coding and zapping so I know what I am doing.
I gave CZ (the CodeZapper add-in) another try but now used CZall instead of the standard CZL (which is CZLight). This zapped the red text out of it

The output looks fine for all that I can tell, so I am going to use this for now and if my client complains about something missing, I will run the red version through the TM.

Codezapping it is!


Direct link Reply with quote
 

Lianne van de Ven  Identity Verified
United States
Local time: 10:43
Member (2008)
English to Dutch
+ ...
TOPIC STARTER
Did not work after all Sep 3, 2014

The solution I mentioned above (CZall) did not really work. I lost other relevant formatting as well, plus, for whatever reason, the target text would be partially red.

I ended up working with a peach background for the highlighted segment, a color that best toned down the red.

ps: I would not know what to do with strike-through text. How did you solve that, Emma?

[Edited at 2014-09-03 02:23 GMT]


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 16:43
Member (2010)
Spanish to English
Formatting display settings Sep 3, 2014

Sorry to hear that CZ got rid of other formatting too. It needs to be used with caution, as you've discovered!

As mentioned earlier, the solution is to hide formatting and just display the tags in Studio. "Show all tags but do not show formatting" is the way to go.


Direct link Reply with quote
 

Lianne van de Ven  Identity Verified
United States
Local time: 10:43
Member (2008)
English to Dutch
+ ...
TOPIC STARTER
Show all tags but do not show formatting Sep 3, 2014

Emma Goldsmith wrote:

As mentioned earlier, the solution is to hide formatting and just display the tags in Studio. "Show all tags but do not show formatting" is the way to go.



When you do this i.e. during translating, do you turn the tags/formatting on once completed to add these in? Or how?

Thanks!


Direct link Reply with quote
 

Miguel Carmona  Identity Verified
United States
Local time: 07:43
English to Spanish
RE: Show all tags but do not show formatting Sep 4, 2014

Lianne van de Ven wrote:

Emma Goldsmith wrote:

As mentioned earlier, the solution is to hide formatting and just display the tags in Studio. "Show all tags but do not show formatting" is the way to go.



When you do this i.e. during translating, do you turn the tags/formatting on once completed to add these in? Or how?


Lianne,

Any time, even during translation:

1) Go to Tools > Options
2) Click on Editor
3) Go to Formatting display style
4) Click on the down arrow to choose an option
5) Choose Show all tags but do not show formatting

As Emma explained, with the above options you are only controlling how the text is going to look in the Editor window, not how the text is going to look in the saved target file. Those are two different issues.

In contrast, if you apply formatting on the text using the formatting commands / tags under the Editor's Format menu (or the corresponding buttons on the toolbar), that is the formatting the text will have in your target file once you save it.

If you are getting an unwanted font color in your saved target Word file, try selecting all the text (Ctrl+A) and apply the black font color, or apply color (or any other formatting) selectively selecting only the text you want in a certain color (or format) and applying the corresponding color (or format).

Good luck.

[Edited at 2014-09-04 23:14 GMT]


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

all text in sdlxliff is red

Advanced search







WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »
CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search