Newly added files to project won't open in editor
Thread poster: Lianne van de Ven

Lianne van de Ven  Identity Verified
United States
Local time: 20:25
Member (2008)
English to Dutch
+ ...
Sep 3, 2014

Working in Studio 2014, I figured out how to add more files to translate, and perform a batch task on the added file(s), but the new sdlxliff will not open in the editor. I first have to quit and re-open Studio to open the file.
Has anyone else seen this too?

More info: I can r-click the file and choose "open with" and select Trados to open the file, but then it opens as an independent file and I need to create new project settings, so the file has not really been added to the project unless I quit and reopen Trados. I am also able not able to access the analysis of the file.


[Edited at 2014-09-03 02:40 GMT]


 

Emma Goldsmith  Identity Verified
Spain
Local time: 02:25
Member (2010)
Spanish to English
Open from target language list in Files view Sep 3, 2014

Are you trying to open it from the source language list by mistake? Make sure you've switched to your target language (in the left-hand column).

Opening a file for translation from outside Studio opens it as a single document, not within an existing project, as you've noticed. That's why I never use this method.


 

Lorenzo Bermejo
Local time: 02:25
English to Spanish
+ ...
Same behaviour Sep 3, 2014

Lianne van de Ven wrote:

Working in Studio 2014, I figured out how to add more files to translate, and perform a batch task on the added file(s), but the new sdlxliff will not open in the editor. I first have to quit and re-open Studio to open the file.
Has anyone else seen this too?



[Edited at 2014-09-03 02:40 GMT]


Yes Lianne, I've also added files to an existing project, prepared them (convert to translatable format, pretranslate, etc.), and after that I wasn't able to open them from the Files view of the Project. Had to quit and restart Studio 2014 to be able to open the files.


 

Lianne van de Ven  Identity Verified
United States
Local time: 20:25
Member (2008)
English to Dutch
+ ...
TOPIC STARTER
File management Sep 7, 2014

Emma Goldsmith wrote:

Are you trying to open it from the source language list by mistake? Make sure you've switched to your target language (in the left-hand column).


I am not sure what you refer to above - with source language list and the column.
I have a folder (2trans) with translatable files (in my "client>job>work" folder). Receiving an additional file from client, I add it to the "2trans" folder in my regular file browser, then go to Studio>files>r-click to select "add files" and add the specific file to the project.

I have not yet decided on the best approach to file management. I use TO3000 and Trados, each with their own folder structures.

Emma Goldsmith wrote:
Opening a file for translation from outside Studio opens it as a single document, not within an existing project, as you've noticed. That's why I never use this method.


I am actually r-clicking the file from within the file browser in Studio when this happens. The only solution seems to be to quit and restart Studio. The file can then just be double clicked and opens normally.


 

SDL Community  Identity Verified
United Kingdom
Local time: 02:25
English
It does sound as Emma describes... Sep 7, 2014

Lianne van de Ven wrote:

Emma Goldsmith wrote:

Are you trying to open it from the source language list by mistake? Make sure you've switched to your target language (in the left-hand column).


I am not sure what you refer to above - with source language list and the column.
I have a folder (2trans) with translatable files (in my "client>job>work" folder). Receiving an additional file from client, I add it to the "2trans" folder in my regular file browser, then go to Studio>files>r-click to select "add files" and add the specific file to the project.



Hi Lianne,

When you add the files the languages are switched so that you are in the source language folder. If you don't switch the language back to the target language first, after running your batch tasks, then you won't be able to open the file for translation. If you restart Studio then the language will be switched and all will be well.

So it does sound as though you just need to switch the language. You can find the languages in the file navigation list on the left you are using. At the top above the files is a drop down. You'll see that if you were translating NL->EN for example that when you add the file the language switches to NL. To open the file it needs to be EN.

The reason for this behaviour is because Studio Projects can be multilingual and the view is taken that Studio doesn't know which language you want to go to next... even if you are working with a single language pair.

Regards

Paul


 

Lianne van de Ven  Identity Verified
United States
Local time: 20:25
Member (2008)
English to Dutch
+ ...
TOPIC STARTER
Changing the language it is Sep 9, 2014

SDL Support wrote:

(....) At the top above the files is a drop down. You'll see that if you were translating NL->EN for example that when you add the file the language switches to NL. To open the file it needs to be EN.

The reason for this behaviour is because Studio Projects can be multilingual and the view is taken that Studio doesn't know which language you want to go to next... even if you are working with a single language pair.


Paul, I now noticed this drop down for the languages at the top, and changing the list to the target language did the trick indeed.

Thanks everyone!


 

Milana Penavski  Identity Verified
Brazil
Local time: 21:25
Member (2010)
English to Portuguese
+ ...
Thanks! May 26, 2015

Emma Goldsmith wrote:

Are you trying to open it from the source language list by mistake? Make sure you've switched to your target language (in the left-hand column).



Thanks, Emma! I had this problem many times and never figured it outicon_smile.gif


 

AsterBlistok
Portugal
Can not find drop down at the top above the files Feb 28

Hello,

Lianne van de Ven, Paul, or anyone else, can you please help, I have the same problem, newly added file can not be opened for translation, I am using Trados 2017, when I restart the programme, everything is ok and I have the option "open for translation" again, but I would like to solve it so that I do not need to restart Trados every time I add a new file. I´ve read your solutions but I am not sure where to find drop down at the top above the files. Can you send a printscreen?

Thanks!

PS 10 minutes later - found iticon_smile.gif

[Edited at 2018-02-28 11:48 GMT]


 

Lianne van de Ven  Identity Verified
United States
Local time: 20:25
Member (2008)
English to Dutch
+ ...
TOPIC STARTER
Screenshot Feb 28

Glad you found it. For completeness:

When you add a file to an existing project, you need to open the menu "Files" in the bottom left and then expand the column at the top left ( >> symbolizing 'expand') to open the submenu for files. There is a little triangle pointing down that you need to click and navigate to "source" language instead of "target" language. You need to add new files to the source language. After you navigate to the source files, you r-click in the field to the right of this column which opens a menu option to add files.
After adding files, you need to prepare them for translation like you normally do. Then you need to navigate back to the "target" language with that same down arrow to access the files for target/translation. This is not very logical or user-friendly but this is how it works.

WceM4TJ.png

[Edited at 2018-02-28 17:01 GMT]


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Newly added files to project won't open in editor

Advanced search







CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »
WordFinder Unlimited
For clarity and excellence

WordFinder is the leading dictionary service that gives you the words you want anywhere, anytime. Access 260+ dictionaries from the world's leading dictionary publishers in virtually any device. Find the right word anywhere, anytime - online or offline.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search