An Item with the same key has already been added error Studio 2014
Thread poster: MKramer
MKramer
United States
Local time: 09:59
Sep 24, 2014

I have a large Word file (.docx - Word 2013) that I am able to translate in Studio 2014. I am not able to 'Save Target As' or 'Generate Target Translation'. I continue to get the error 'An item with the same key has already been added'. Here are the things that I have tried to do so far:

* Retranslate the file in both Studio 2011 and 2014
* Open the Word 2013 file and have determined there are no comments in the file or track changes
* Removed the 3 XML files from other posts with the error
* Saved the Word 2013 file to Word 2010 compatibility mode
* Open the Word 2013 file and turned off 'Comment' feature

I'm running out of ideas. Please note that I can NOT save this down to .doc as the file is too large to go back and fix everything for the layout.

System info:
* Windows 7
* Studio 2014 SP1 - 11.1.4095.0

Does anyone have any other ideas?
Thank you!
Mindy


Direct link Reply with quote
 

Muhammad Essam  Identity Verified
Egypt
Local time: 16:59
English to Arabic
+ ...
Try the following Sep 24, 2014

Hi...

Try to recreate it - either copy the text in a new file or save as rtf and then re-save as doc, use OpenOffice to open the file and save as doc, then save it as docx...


Direct link Reply with quote
 
MKramer
United States
Local time: 09:59
TOPIC STARTER
Apparent defect in Studio, SDL working on it Sep 26, 2014

Thanks, Muhammad for your feedback, unfortunately, by following your suggestion, I would have a lot more work on fixing the layout.

I had talked to SDL about this and they are currently working on it. The file I was working on had field codes that were causing the trouble. Their suggestion was to remove the specific text with the certain field codes in the source file, retranslate the file and then put the text back in. We are testing this right now.

Interestingly enough, we had a different file with the exact same error. I was able to locate the segment that was showing the error and found that in the file, there was a hard return placed before a field (the text was referring to Table 8, a cross reference in the file). I removed the hard return before the text, retranslated and the file worked!

It seems that this error could be many possibilities, but SDL is aware and is trying to fix it. They are unsure when it will be fixed.

I hope this helps someone else!
Best, Mindy


Direct link Reply with quote
 

María Croxcatto  Identity Verified
Argentina
Local time: 11:59
English to Spanish
Conversion to RTF solved it Jun 10, 2015

I had the same problem. After trying other options that did not work, I tried converting the original docx to rtf, and processing the file again.
It worked and I was able to clean the file

[Edited at 2015-06-10 17:13 GMT]


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

An Item with the same key has already been added error Studio 2014

Advanced search







PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
Across v6.3
Translation Toolkit and Sales Potential under One Roof

Apart from features that enable you to translate more efficiently, the new Across Translator Edition v6.3 comprises your crossMarket membership. The new online network for Across users assists you in exploring new sales potential and generating revenue.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search