Trados 2011/Trados 2014 trial - broken Czech characters in exported translated HTM in Notepad
Thread poster: Vojtěch Schubert

Vojtěch Schubert
Czech Republic
Local time: 18:40
Member (2014)
English to Czech
+ ...
Nov 9, 2014

Dear all.

I translated a set of .htm files in Trados 2011. I used a standard method and finalized the project without any problem. The Czech characters in the finalized target .htm files are without any problem. All is fine and the translation can be used as final translated files, but not when client wants to edit them.

However, the client wishes to have the possibility to do some editing directly in the .htm file in Notepad. There is the problem. Trados 2011 (tried this even in Trados 2014 trial, the results is the same) just uses some codes in order to render Czech special characters, instead of using the actual Czech characters.

Translated files, processed in Trados (just an example):
.htm file opened in a browser (characters OK): Detail designu: Účtování řádku finančního deníku
.htm file opened in Notepad (characters broken): Detail designu: Detail designu: &Uacte;ètov&aacte;n&iacte; øádku finanèn&iacte;ho den&iacte;ku
How it should be (same as the first one, characters OK): Detail designu: Účtování řádku finančního deníku

The client needs to have the text correctly in order to edit it in Notepad. I am unable to make Trados render it correctly, even if I force target character set encoding to compatbile UTF-8 or Windows-1250 or 1252. It stays broken.

What I had to do was to install memoQ, load TM (TMX export from Trados) and manually process all segments and then finalize/export the .htm files in memoQ. Because memoQ renders the Czech characters correctly not only in the .htm file opened in a browser, but also in the Notepad when you want to edit the file.

Translated files, processed in memoQ (just an example:
.htm file opened in a browser (characters OK): Detail designu: Účtování řádku finančního deníku
.htm file opened in Notepad (characters broken): Detail designu: Účtování řádku finančního deníku
How it should be (same as the first one, characters OK): Detail designu: Účtování řádku finančního deníku

memoQ does it all fine: characters are displayed correctly even when the file is opened in Notepad - no codes used, just actual Czech special characters and that is how I need it.

So, my question is how to make Trados to render/encode the Czech characters as actual Czech characters (not as codes), so that it is correctly displayed even when opened in Notepad? I do not feel like buyinq memoQ just because of this.

Thank you very much for advising, any help is much appreciated.


Direct link Reply with quote
 

Vojtěch Schubert
Czech Republic
Local time: 18:40
Member (2014)
English to Czech
+ ...
TOPIC STARTER
Solved Nov 9, 2014

Solved through this: http://producthelp.sdl.com/sdl%20trados%20studio/client_en/SDL_Trados_Studio_Help.htm#Ref/U-Z/Options/File_Types/HTML_Entity_conversion.htm If anyone needs this, just disable entity conversion.

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados 2011/Trados 2014 trial - broken Czech characters in exported translated HTM in Notepad

Advanced search







PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search