SDL Trados Studio 2014 - won't split texts by | (pipe character)
Thread poster: Maria Novikova

Maria Novikova  Identity Verified
Norway
Local time: 16:27
English to Norwegian
+ ...
Jan 15, 2015

I tried these instructions:
http://kb.sdl.com/#tab:homeTab:crumb:7:artId:4657
http://signsandsymptomsoftranslation.com/2013/02/27/update-tm/

I have also tried Advanced view, and wrote \| in the former break part and nothing in the latter break part.

My text looks like this:

"xxx | xxxxx | xx xxxx x | "

The file is huge and contains lots of pipe characters.


Do you have any suggestion to fix it?


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 16:27
Member (2010)
Spanish to English
Re-segment Jan 15, 2015

Adding the pipe character to your segmentation rules as you've done with the backslash escape should work.

After you've added a new segmentation rule, make sure you re-segment your source document. That means you'll have to recreate the project.


Direct link Reply with quote
 

Maria Novikova  Identity Verified
Norway
Local time: 16:27
English to Norwegian
+ ...
TOPIC STARTER
Did it too Jan 15, 2015

Hi, thanks for your help. I did that too with \| in the first form and nothing in the second form in the "Advanced view" window.

Do you mean that I should re-import the project?
If yes, doesn't it delete my previous translations?


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 16:27
Member (2010)
Spanish to English
Use the same TM Jan 15, 2015

Maria Novikova wrote:

Do you mean that I should re-import the project?
If yes, doesn't it delete my previous translations?


Yes, start a new project. Your translation won't be deleted if you confirmed the segments and they're safely stored in your TM. Check this first.
The 100% matches will be transferred in the pretranslate stage of the batch task.

Of course, any segments containing the | symbol will not be 100% matches because they'll be split up in the new xliff file.


Direct link Reply with quote
 

Maria Novikova  Identity Verified
Norway
Local time: 16:27
English to Norwegian
+ ...
TOPIC STARTER
Segmentation rule was not saved, why? Jan 15, 2015

By the way, I noticed that new segmentation rule in the project translation memory was not saved, why is that so?
How do I save properly?


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 16:27
Member (2010)
Spanish to English
Project TM? Jan 15, 2015

If you're working on a main TM in a project that was created using "prepare without project TM" (this is the default option), then the segmentation rule will be saved (simply by clicking OK after creating the rule).

If, however, you created a project TM, then a segmentation rule will be specific to that TM and won't be applied elsewhere.
Maybe that's the problem?


Direct link Reply with quote
 

Maria Novikova  Identity Verified
Norway
Local time: 16:27
English to Norwegian
+ ...
TOPIC STARTER
I still don't get it.. Jan 15, 2015

The project contains already its own TM, but somehow I am not able to change it, because when I quit and open Trados, all new segmentation rules are gone.

However, I created new language resources template and chose it as the default template in the main TM. Now it seems to work partly, why not wholly?

[Edited at 2015-01-15 20:52 GMT]


Direct link Reply with quote
 

Maria Novikova  Identity Verified
Norway
Local time: 16:27
English to Norwegian
+ ...
TOPIC STARTER
Few 100% Jan 15, 2015

By the way, very few of my translated segments have 100% match. As mentioned, the (huge!) files are strangely formatted, so I don't have heart to re-open the project.
How do I find out if pre-translations are stored in TM or not?

Should wish it could split by ALL pipe symbols, but it is just about half that got splitted. Any idea why it is so?


Direct link Reply with quote
 

Walter Blaser  Identity Verified
Switzerland
Local time: 16:27
French to German
+ ...
You need to modify the segmentation rule in the main TM Jan 15, 2015

Maria

You have to modify the segmentation rule in the main TM, not the project TM, and after having done this you need to reconvert (open) the document so that the segmentation is done according to the modified rule. Unless you need a project TM for an explicit reason, I would create a project without a "project TM" to make things easier.

Walter


Direct link Reply with quote
 

Maria Novikova  Identity Verified
Norway
Local time: 16:27
English to Norwegian
+ ...
TOPIC STARTER
Afraid of re-opening... Jan 15, 2015

Walter.

Thanks for your explanation. I did what you suggested, but I don't want to mess it up with re-opening the package. How can I be sure that my translation won't go lost if I re-open the project?
I don't have possibility to create a new project package, as I have the Freelance version. Besides, I got the package from an translation agency.


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 16:27
Member (2010)
Spanish to English
Package Jan 16, 2015

Maria Novikova wrote:

Besides, I got the package from an translation agency.


Pity you didn't mention that you're dealing with a package in your first post.
A package contains a segmented xliff file and you can't re-segment it inside that package.

Your options are:
1. Ask the agency to add the segmentation rule and send a new package.
2. Ask the agency if you can process the source file outside the package and just return the sdlxliff file and target file on delivery. That way you can take all the steps discussed earlier in this thread.



[Edited at 2015-01-16 08:14 GMT]


Direct link Reply with quote
 

Maria Novikova  Identity Verified
Norway
Local time: 16:27
English to Norwegian
+ ...
TOPIC STARTER
Thanks for all answers Feb 25, 2015

Emma and Walter, thank you very much.

Emma, you are right in your last reply. The next time I receive such formats, I'll solve it with the agency/client BEFORE I start translatingicon_smile.gif


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

SDL Trados Studio 2014 - won't split texts by | (pipe character)

Advanced search







BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »
SDL Trados Studio 2017 only €495 / $595
Get the cheapest prices for SDL Trados Studio 2017 on ProZ.com

Join this translator’s group buy brought to you by ProZ.com and buy SDL Trados Studio 2017 Freelance for only €495 / $595 / £425 / ¥70,000 You will also receive FREE access to Studio 2019 when released.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search