Trados Studio 2014: languages that are not configured for this installation. How to solve it?
Thread poster: Vincenzo Di Maso

Vincenzo Di Maso  Identity Verified
Portugal
Local time: 12:10
Member (2009)
English to Italian
+ ...
Feb 3, 2015

Dear all,
I am with a problem with a package.
I tried to open it in Trados Studio 2014, but the following error message appears:
"The package ... cannot be opened as it contains languages that are not configured for this installation".
I don't have the foggiest idea how to solve this issue. The problem occurs both with the package and the single SDXLIFF file. The source language is Spanish (Mexico).
From other forums I have read that I would need to uninstall Trados and re-activate it to set default languages. It seems absolutely unbelievable as this would be time-consuming and weird.
Thank you very much in advance!
Best regards,
Vincenzo

[Modificato alle 2015-02-03 23:48 GMT]


Direct link Reply with quote
 

Roy Oestensen  Identity Verified
Norway
Local time: 13:10
Member (2010)
English to Norwegian (Bokmal)
+ ...
Languages have to be added at installation time - I think Feb 4, 2015

When you installed Studio, you were asked to add 5 languages, and apparently you did not add this language at the time. Not sure how to solve this later on, but with Trados, I have had to reinstall the software to be able to change the languages.

Check if it's possible to remove a language from the installation and then add the language you need. That would be the easiest, but I am not sure if SDL is allowing for this easy way out so you don't have to buy a more expensive version.

One way out would be to translate with a different CAT tool that doesn't have the limitations of Trados and Studio, for instance Dejavu. I would also think MemoQ does not have this limitation. I definitely know that Dejavu opens sdlxliff files nicely without problems. The risky part is that if sdlxliff is not pretranslated in Studio before importing in Dejavu, then the language combination may be wrong when you export from Dejavu, since you have to define the language combination when you import it into DVX3.




[Edited at 2015-02-04 06:18 GMT]


Direct link Reply with quote
 

Astrid_H  Identity Verified
Germany
Local time: 13:10
German to English
+ ...
Check the project settings and file view Feb 4, 2015

Hi,
I have repeatedly had the same problem with files assigned via GroupShare, which were to be translated into a range of languages I did not choose at the time of installation, but for some reason I could only download the files from the server including all languages.

I'll try to reconstruct from memory the workaround I used, I hope I'm not forgetting anything:

In the project view, click on the file. You should see all target languages. If there are languages you cannot work with, double click on the file to open the file view.
In the top left hand corner of the "file" window on the left you will see a dropdown menu. Choose the language you want to translate into.
Now you should be able to double click on the file and open it.
If this doesn't work, there may be an entry in a context menu (right-click) which allows you to only download a certain language version, but I'm not sure on that and can't check now.
Oh, if you work with a server TM, please check in the TM view that all other languages but yours are unchecked. I think (but I'm not sure) you update these too if they are activated.

I'm not sure why this happens. In my case, with GroupShare, the files are assigned to me on the top level, not in the language sub-folder. This may be due to the fact that the person in charge of assigning files is not yet familiar with GroupShare, as it was only recently acquired by the client (no agency).

Hope this helps!


Direct link Reply with quote
 

Roy Oestensen  Identity Verified
Norway
Local time: 13:10
Member (2010)
English to Norwegian (Bokmal)
+ ...
Excellent solution ... Feb 4, 2015

... and I think that should work. I have not experienced this same problem, but will try to remember if it does arise, as the agency does use GroupShare on a regular basis and might inadvertently make a mistake.

Direct link Reply with quote
 
Will Require Re-Installation Feb 4, 2015

Hi Vincenzo,

following on from what Roy has already advised you, in the Freelance edition, you are prompted to select the 5 languages you work with when you first start using the software and enter the set up process.

If you need to change this select you will need to remove the software from your machine, so you can run the installation and set-up process, you will then be asked to select the languages you need to work with again.

If you remove the software from your machine, PLEASE make sure you return the activation code from within the installation first. If you remove the the software without returning this, it will become trapped and you will not be able to use it again without having to contact our support team to perform a manual return for you.

To return an activation code in Studio, you select the "Help" menu, then select the "Product Activation" option. You will then see a large "Deactivate" key displayed, please make sure your machine is connected to the internet, then select the "Deactivate" key to return the activation code back to your account.

You can then retrieve the activation code and the installer download from within your account.

If you require any further assistance with this process, please feel free to contact us via our live chat service -
www.sdl.com/CXDesk

Kind Regards,

Steven Barlow

SDL Customer Experience Executive.


Direct link Reply with quote
 

Vincenzo Di Maso  Identity Verified
Portugal
Local time: 12:10
Member (2009)
English to Italian
+ ...
TOPIC STARTER
great Feb 4, 2015

SDL SteveBarlow wrote:

Hi Vincenzo,

following on from what Roy has already advised you, in the Freelance edition, you are prompted to select the 5 languages you work with when you first start using the software and enter the set up process.

If you need to change this select you will need to remove the software from your machine, so you can run the installation and set-up process, you will then be asked to select the languages you need to work with again.

If you remove the software from your machine, PLEASE make sure you return the activation code from within the installation first. If you remove the the software without returning this, it will become trapped and you will not be able to use it again without having to contact our support team to perform a manual return for you.

To return an activation code in Studio, you select the "Help" menu, then select the "Product Activation" option. You will then see a large "Deactivate" key displayed, please make sure your machine is connected to the internet, then select the "Deactivate" key to return the activation code back to your account.

You can then retrieve the activation code and the installer download from within your account.

If you require any further assistance with this process, please feel free to contact us via our live chat service -
www.sdl.com/CXDesk

Kind Regards,

Steven Barlow

SDL Customer Experience Executive.

Hi Steven,
I have followed your steps and it has worked.
Thank you so much! Thank you also to the other colleagues that helped with their suggestions.
Vincenzo


Direct link Reply with quote
 

Sandra Peters-Schöbel
Germany
Local time: 13:10
Member (2007)
English to German
+ ...
Another workaround Feb 12, 2015

Hi,
I came about the same problem yesterday. I should proofread a file translated from Danish to German. I do not understand Danish and haven't installed it in Studio, but should only proofread the German part.

I actually wasn't willing to reinstall my software for this task and came upon the SDL Xliff converter from SDL. It is just a simple workaround, but it worked for me.
It converts the XLIFF file into a word doc, with different colours for fuzzys and no matches and with source and target segments.

I could revise the file, save and convert it back to the final XLIFF file.
You haven't of course the functionality of a CAT tool and cannot create the final cleaned files...

you can download the converter on the SDL website


Direct link Reply with quote
 

Astrid_H  Identity Verified
Germany
Local time: 13:10
German to English
+ ...
Confirmation Feb 18, 2015

I just wanted to confirm that the solution I posted above works and is actually easier than I had remembered.

I currently have some Groupshare projects which contain, among German, Italian, Spanish, Canadian French and more languages I do not have installed for my license.

Activating the file to be translated in the file view and choosing the correct target language on the left hand side (German in my case), then clicking on the file to translate works fine.
You'll just need to remember to set the language again in this view when you have closed the software.

Since this solution doesn't require any re-installation or risk, it might be worth trying out before doing a re-install.


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 13:10
Member (2010)
Spanish to English
Don't return the activation code for a simple uninstall / re-install Feb 18, 2015

SDL SteveBarlow wrote:

If you remove the software from your machine, PLEASE make sure you return the activation code from within the installation first. If you remove the the software without returning this, it will become trapped and you will not be able to use it again without having to contact our support team to perform a manual return for you.



Steve, you don't need to return the activation code before uninstalling Studio from your machine and reinstalling it.
You only need to return the activation code when you re-format your hard disk / re-install the OS or other drastic measure. And, of course, if you move to a new computer.


Direct link Reply with quote
 
marlowe61  Identity Verified
Italy
Local time: 13:10
English to Italian
Yet another work-around for the missing language(s) Oct 26, 2015

Hello All,
I realise that this is a quite old post, but I came across the same issue just today and I found a much simpler work-around I'd like to share with you, if it didn't happen someone already mentioned it.

Go to the Control Panel, click on Programs and Features (Windows 8.1) and in your list of programs select SDL Trados Studio 2015 (in my case).
Right-click and select Repair from the menu.
Windows will start performing a "fix" routine. When finished, start your Trados and will see the SDL Trados Setup window again. At that point, you'll be able to add the actual languages you need during your work.

No need to activate/deactivate.

Hope it helps.
Cheers,
A.D.


Direct link Reply with quote
 
marlowe61  Identity Verified
Italy
Local time: 13:10
English to Italian
An addendum to my suggestion Mar 8, 2016

I have been asked via a private message whether my suggestion works even after having updated to Windows 10. I don't know for sure, because Windows 10 was already on board on my PC when I fixed the language issue in Trados. In my opinion it should be valid in any case.

However, if you are going to install the newly released Service Release 2 (SR2) for SDL Trados Studio 2015, after the update you will be asked to insert again the standard 5 languages in the Trados setup window. Just add English, your target language, and three others, that's it.

Hope it helps.


Direct link Reply with quote
 

Trevor Chichester  Identity Verified
United States
Local time: 07:10
Member (2012)
German to English
+ ...
Marlowe, you are a genius! Jun 23, 2016

marlowe61 wrote:

I have been asked via a private message whether my suggestion works even after having updated to Windows 10. I don't know for sure, because Windows 10 was already on board on my PC when I fixed the language issue in Trados. In my opinion it should be valid in any case.

However, if you are going to install the newly released Service Release 2 (SR2) for SDL Trados Studio 2015, after the update you will be asked to insert again the standard 5 languages in the Trados setup window. Just add English, your target language, and three others, that's it.

Hope it helps.



Marlowe!!!

YOU ARE A GENIUS!!!!


Thank you!!! This work-around absolutely works.


Bravo, sir. Bravo!


Direct link Reply with quote
 

Valentin Cirdei  Identity Verified
Romania
Local time: 14:10
Member (2006)
English to Romanian
+ ...
Text editor Jan 19

You can simply open the sdlxliff file in any text editor (such as Notepad) and change the language to the one of your choice in the first few lines of code. For instance, change [target-language="ro-RO"] to [target-language="en-US"]. This works for Studio 2017, I haven't tried it in older versions.

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados Studio 2014: languages that are not configured for this installation. How to solve it?

Advanced search







LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »
CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search