Pages in topic:   [1 2] >
Bad Error with last SP2 release of STUDIO 2014 !!!
Thread poster: Ivan Bertrand

Ivan Bertrand  Identity Verified
France
Local time: 10:47
English to French
Feb 13, 2015

I just updated STUDIO 2014 with the new SP2 uodate that was released a few days ago.
I probably did something wrong with the update processus although I was following the SDL procedure:
now i have this VERY UNPLEASANT ERROR,
after modifying a segment , i have an error popup

Method 'get_Settings' in type 'Sdl.TranslationStudio.Editor.TranslationMemory.TranslationUpdate' from assembly 'Sdl.TranslationStudio.Editor, Version=11.0.0.0, Culture=neutral, PublicKeyToken=c28cdb26c445c888' does not have an implementation
I can translate, but this error comes all the time and I can see that my TM is not uptated:

HELP-HELP
Ivan


 

Shai Navé  Identity Verified
Israel
Local time: 11:47
Member
English to Hebrew
+ ...
Try the following Feb 13, 2015

Unless you updated Studio mid-project, you didn't do anything wrong. It is NEVER recommended to update/upgrade Studio, or any other software, while in the middle of a project (with the exception of a patch that specifically addresses an issue that one is having).

First, I would test to make sure I get this error with all projects/file and not just a single project.
If not, try to recreate the project and use the existing SDLXLIFF file to update the TM from the Translation Memories view in Studio, not from the batch tasks menu.

If the problem seems to be global, or it persists even with the newly created project:

Try to rename the three XML files as explained in SDL KB4457.

You can also try the other suggestions there, but before you do a repair installation, try to fully reset Studio as explained in SDL KB4393.

If the problem persists, I would do a repair install, and if that didn't help, I would contact SDL under the Licensing and Installation support option, because I think this could be classified as an installation problem.


 

Ivan Bertrand  Identity Verified
France
Local time: 10:47
English to French
TOPIC STARTER
Thank you for the help Feb 13, 2015

Hi Shavi:
I couldn't agree more with you: upgrading Studio in the middle of a project is not a very smart idea.
This goes for any critical program. The only excuse I have was that it was 3:00 am and
I answered yes without thinking.
I will try all the things that you kindly suggested and I will let you know
Shalom
Ivan


 

Simon Bruni  Identity Verified
United Kingdom
Local time: 09:47
Member (2009)
Spanish to English
Exactly the same issue, no solution Feb 13, 2015

Hello Ivan and Shavi

I'm having exactly the same problem. I've tried all of the suggested fixes and none of them work. I'm struggling not go on another rant about SDL and their tactic of creating problems then making you pay them to resolve them.

Any other ideas? I just want to revert back to previous service pack if possible.

With thanks

Simon


 

SDL Community  Identity Verified
United Kingdom
Local time: 10:47
English
Glad you restrained yourself... Feb 13, 2015

... nobody has to pay to have their problems resolved when they can't install the product successfully!

We have investigated this today to see where the problem might be coming from and in the opinion of our developers it looks as though something didn't install/update correctly on your machine.

Given the update is automatic perhaps you can try the following:

  1. Uninstall Studio altogether
  2. Download the CU8Update from the links in KB #5375
  3. Reinstall Studio, making sure you right-click and run as admin
  4. Install the update manually, also running as admin
  5. If you have an AV running it might also be a good idea to turn this off while you do the installation process. This might not a problem but it won't hurt to remove this as a possible cause of the issue

This may resolve the problem. If this doesn't help then please log a case through the solution finder and a support engineer will be able to help you with this. Go to the Knowledgebase;

http://kb.sdl.com

Then go to the tab called Solution Finder ( http://kb.sdl.com/?cid=23&tab=sf ) and now go here;

Download & Installation Problems
- I use SDL Trados Studio and/or SDL MultiTerm 2009, 2011 or 2014
-- The installation went fine but now I get an error message etc
--- The problem occurs in (pick the appropriate tool/s)
---- None of the articles resolved my problem (if they didn’t!)

Follow the route for your problem and if there is no answer that helps by the time you get to the end you'll be presented with a form to contact support. Complete all the fields in the form making sure your email address is entered correctly or nobody will be able to get back in touch with you.

Also use the Chrome browser to log the case if you have it; you'll get more success in completing the form.

Regards

Paul


 

Shai Navé  Identity Verified
Israel
Local time: 11:47
Member
English to Hebrew
+ ...
Removal of CU8 Feb 13, 2015

Paul,

I'm just thinking out loud here, but is it really necessary to uninstall Studio completely instead of just CU8 (through Control Panel > Programs and Features > View Installed Updates [from the left pane])?

I don't have access to a system with problems after CU8 (as far as I know the few colleagues I've helped don't experience any issue), so I can't test it myself.

[Edited at 2015-02-13 10:32 GMT]


 

Ivan Bertrand  Identity Verified
France
Local time: 10:47
English to French
TOPIC STARTER
ok I am trying Paul suggestion, Shavi I tried all suggested, did not work Feb 13, 2015

i have de-installed Studio completely.
I have downloaded CU8
I am downloading again Studip from SDL and I wil let you know.
FYI I do not thing I did anything wrong, Studio asked me if I wanted to update and stupid me, I said yes.
now i am in trouble, again.
Kind regards
Ivan


 

Shai Navé  Identity Verified
Israel
Local time: 11:47
Member
English to Hebrew
+ ...
You didn't do anything wrong Feb 13, 2015

You really didn't do anything wrong, Ivan. Sometimes updates fail for a multitude of possible technical reasons, none of which are the user's fault.

I'm curious to know if the removal of CU8 without uninstalling Studio would have changed anything, but because your already uninstalled Studio, nevermind that now. I truly hope reinstalling everything will solve your issue, but just in case it doesn't, please try to remove just CU8 and see if it changes anything.


 

SDL Community  Identity Verified
United Kingdom
Local time: 10:47
English
And please... Feb 13, 2015

... contact support as requested - if the suggest from Shai doesn't work. They will be able to help resolve this.

Regards

Paul


 

Ivan Bertrand  Identity Verified
France
Local time: 10:47
English to French
TOPIC STARTER
Shai so sorry I spelled you name wrong Paul thanks Feb 13, 2015

Hi Shai: thanks for the update. I will let you know what it gives.
Paul: yes I have logged in a ticket with tech support since I am a good customer and actually pay for tech support.
I will let both of you what happens.
Regards
Ivan


 

Ivan Bertrand  Identity Verified
France
Local time: 10:47
English to French
TOPIC STARTER
recommendation from Jesse Good (from community) Feb 13, 2015

Paul:
Jess just told me that he has had the problem.
I remember seeing this error on one machine where I work. We installed SP2 on 10 or so machines, and only 1 had this problem.
The solution is simply to reinstall Trados from scratch and then reinstall SP1 and SP2 in that order.
Also, make sure your Multiterm is also up to date. Incompatibles between versions may cause this problem.
Anytime you see "Method not found: " that immediately implies that you have an installation problem,
as a missing Method means that the update didn't work correctly.

ok guys it is a bit complex for me, from my sdl account:
should i download STUDIO SP1 and install it then SP2 then CU8?
Which sldterm should I install?
regards
Ivan


 

Shai Navé  Identity Verified
Israel
Local time: 11:47
Member
English to Hebrew
+ ...
Install the SP2 versions Feb 13, 2015

Just download the installers for both Studio 2014 SP2 and MultiTerm 2014 SP2. Both should be the only options available to you by default in My SDL Account, I think.

Then download the standalone installer of CU8.

Install both Studio 2014 SP2 and MultiTerm SP2 (as administrator; right click the installer file > Run as administrator). If you don't have the time to experiment, and assuming everything works, continue without installing CU8 until your are done with all current projects.
Then install the standalone CU8 (again as administrator), and hopefully everything will work as expected.

If not, wait for SDL to get back to you and have them solve it for you (especially if you have a support contract).


 

Ivan Bertrand  Identity Verified
France
Local time: 10:47
English to French
TOPIC STARTER
What I did and it worked!! Feb 13, 2015

I de-installed TRADOS STUDIO
I installed STUDIO SP1 (with the right click as administrator), i know this may not have been necessary
I installed STUDIO SP2 idem with the right click
I applied Studio-KB5375-8.msp (CU8 you call it)
I tried, but could not dl Multiterm SP2( i have a strange loop error) this is not critical for me.
I started STUDIO and everything works fine.
THANK YOU GUYS.
i will investigate further the multiterm issue but i need to catch up on some work.
Shai, i appreciate very much your advices.
Kind Regards
Ivan


 

Simon Bruni  Identity Verified
United Kingdom
Local time: 09:47
Member (2009)
Spanish to English
Thanks Feb 14, 2015

Many thanks Ivan and Shai- the fix worked for me, too.

And thanks SDL for making me miss a deadline and ruining my day with your buggy and over-complicated software that the market forces me to use.


 

Shai Navé  Identity Verified
Israel
Local time: 11:47
Member
English to Hebrew
+ ...
Glad it worked out Feb 14, 2015

Simon, there is a policy you can follow to minimize the re-occurrence of such experience. It applies to all hardware/software in a production environment (unless one prefers to be an early adopter and doesn't mind dealing with the occasional problem):

1) Short of a hardware failure (for which one should have proper hardware and data backup in place), never update/upgrade the hardware or software while in the middle of a project. Most softwares, Studio included, don't install updates automatically, they just check and notify about available updates. Alternatively, if the notification is too distracting, one can disable the automatic check for updates (I don't recommend it personally), but it is highly recommended to subscribe to a relevant mailing list, RSS feed, Twitter account, etc. so to not miss the updates completely.

2) For those who don't care to be early adopters it is recommended to wait 3-4 weeks before installing a maintenance update (such as Studio's Cumulative Updates [CU]), and 2-3 months before upgrading to a new Service Pack (SP) or a major new version (e.g. Studio 2014, 2017, etc).

This should minimize any unexpected serious issues in the middle of a project.


 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Bad Error with last SP2 release of STUDIO 2014 !!!

Advanced search







SDL MultiTerm 2019
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2019 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2019 you can automatically create term lists from your existing documentation to save time.

More info »
SDL Trados Studio 2019 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2019 has evolved to bring translators a brand new experience. Designed with user experience at its core, Studio 2019 transforms how new users get up and running and helps experienced users make the most of the powerful features.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search