Compile error in hidden module: MTInsertFunctions
Thread poster: Sian Cooper

Sian Cooper  Identity Verified
France
Local time: 03:32
French to English
+ ...
Apr 21, 2015

Hi, I'm hoping I can get some help to sort this out!

I have Trados 2014, with Multiterm 2014. I previously had 2011 Trados and Multiterm. In Word, there was still the SDL Multiterm 2011 add-on showing (although not 2014, maybe it doesn't do that any more?), and Word was starting really slowly, so I decided to do a clean up of add-ons. I used add-remove programs to remove Multiterm 2011. There were multiple individual uninstalls, and 1 - maybe 2 - 'group' uninstalls. I chose the 'uninstall everything' option, but - for some reason of mistaken over-caution - I only selected the uninstall Word module option from it. However, in the add-remove programs program, the individual options all disappeared, so I could not manually remove them afterwards. That is not my problem, though.

The SDL Multiterm add-on tab still shows in Word, but it is not functioning and is causing errors. When I open a document, I get the multiple messages 'The macro cannot be found or has been disabled because of your security settings'. If I accept it enough, it goes and I can function normally. If I actually try selecting the SDL Multiterm tab, I get that error and have to kill Word, no number of OKs will kill it.

I had in Word created a new template that I was using as my standard - not the Normal template. I cannot give you the exact details because I don't remember (sorry) but trying to fix this error, I reset Normal as my standard and deleted my personalised template. When I exit Word, it tells me changes have been made to the global template, do I want to save, and whether I select to save or not, it then gives me the compile error in the subject of this message.

It is just possible that if I could remember my Administrator user password I could sort this - although I am the only user and have Administrator rights.

It is obviously more annoying than anything, but... any help gratefully received!

Thanks


Direct link Reply with quote
 

Sian Cooper  Identity Verified
France
Local time: 03:32
French to English
+ ...
TOPIC STARTER
Delete multiterm9.dotm Apr 28, 2015

I have finally worked out my own answer.

Solution: after uninstalling Multiterm 2011, you have to physically delete the file C:/Users/[username]/App Data/Roaming/Microsoft/Word/STARTUP/multiterm9.dotm

The uninstall evidently should do this.

SDL support people, I do feel that you could and should have answered this, since you know how the program works (theoretically) and could have realised it was due to the macro template being loaded at Word startup. It would have saved me several weeks of annoyance and several hours of working out how to fix it.

Details of how I worked this through:
1) I realised that I could not remember my Administrator password because there is no Administrator user - it's Win 8, there is just me, with Administrator rights
2) I searched for all files that contained 'multiterm'
3) I found that the problem was with multiterm9.dotm, which sat in the
C:/Users/[username]/App Data/Roaming/Microsoft/Word/STARTUP folder and continued to be loaded when Word was opened
4) I renamed multiterm9.dotm to multiterm9.old.dotm
5) I right-clicked on winword.exe and ran as Administrator, just to make sure
6) I turned off all add-ins (of which Multiterm was not one, since I had uninstalled it)
7) I rebooted and restarted Word as normal
8) It still loaded multiterm9.old.dotm, so I moved the file to a temporary folder, re-rebooted and now Word opens fine.


Direct link Reply with quote
 

RobAlink
Local time: 03:32
English to Dutch
+ ...
MTInsert problem resolved! Dec 10, 2015

Hi Sian,
Thanks very much for solving this problem. Although I'm still using Studio 2011 and never use Multiterm 2011 inside Word, this "mtinsert" thing kept popping up. I simply changed the "dotm" extension to "old" and the nuisance is gone!
In my case nothing indicated which program was causing this problem, so I'm really glad you found out!
Thanks,
Rob


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Compile error in hidden module: MTInsertFunctions

Advanced search







SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »
SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search