Multiterm doesn’t recognize different language variants from termbase
Thread poster: Eric Schwartz

Eric Schwartz  Identity Verified
Colombia
Member (2011)
Spanish to English
Apr 23, 2015

Hello,
I have a question about Multiterm.
I’ve used memoQ for about year now, and Trados Studio on and off for about the same time. Both at a pretty basic level. But now I’m taking a CAT tool course to learn more, and when we learned how to create and use termbases in Multiterm I ran into a problem. My teacher is stumped, too, so I’d like to see if anyone here can help.

I made a sample termbase from an excel with Convert, and was able to import it with Multiterm. But there’s a problem with the languages. My language entries in my excel are (in order) “es-CO”, “es-CO2”, “es-ES”, “es-ES2”, “en-US”, “en-US2”, “en-GB”, “en-GB2”. I used those when I converted the excel. Then in multiterm, I configured the same language categories (though only one for each language).
But when I look at the entries in Multiterm, all of the English ones, regardless of language variant, are listed as en-GB, and all the Spanish ones are listed as “en-CO”. Like it will say “en-GB: authorise” and below that “en-GB: authorize.” Any idea of why this would be? The same excel imported fine into a termbase in memoQ.

And another problem with using my termbase in Trados Studio; I’ll post it here also, because my teacher thinks it might be related.

I made a practice file in word with some of my terms that are in the termbase. I imported it as "translate a single document". And in project settings, I set it up as the termbase for the project.

Now I can see it if I click on termbase viewer. But the relevant termbase entries don't show up automatically in each segment, even though I have auto-propagate set up, or even when I do a search from the editor; they don’t show up in the termbase pane on the side, either. I have the termbase search and termbase recognition panes open. I'm not editing the TB in Multiterm at the same time.

Any idea why this would be?


Direct link Reply with quote
 

Walter Blaser  Identity Verified
Switzerland
Local time: 18:04
French to German
+ ...
Many mixed problems here Apr 24, 2015

Eric Schwartz wrote:
I made a sample termbase from an excel with Convert, and was able to import it with Multiterm. But there’s a problem with the languages. My language entries in my excel are (in order) “es-CO”, “es-CO2”, “es-ES”, “es-ES2”, “en-US”, “en-US2”, “en-GB”, “en-GB2”. I used those when I converted the excel. Then in multiterm, I configured the same language categories (though only one for each language).
But when I look at the entries in Multiterm, all of the English ones, regardless of language variant, are listed as en-GB, and all the Spanish ones are listed as “en-CO”. Like it will say “en-GB: authorise” and below that “en-GB: authorize.” Any idea of why this would be? The same excel imported fine into a termbase in memoQ.


I am not sure, I understand what you really did. On one hand, you mention that you have several language variants in your Excel (en-US, en-US2, etc.), but later on you say "though only one for each language". What languages did you really define in the Multiterm entry? Do you need to have separate language variants in your Multiterm entries?

I made a practice file in word with some of my terms that are in the termbase. I imported it as "translate a single document". And in project settings, I set it up as the termbase for the project.

When you say "I set it up as termbase", what do you refer to by "it"? Cant be the word file as you cannot use a Word file as a termbase, I guess you refer to the termbase mentioned before that you created.

Now I can see it if I click on termbase viewer. But the relevant termbase entries don't show up automatically in each segment, even though I have auto-propagate set up, or even when I do a search from the editor; they don’t show up in the termbase pane on the side, either. I have the termbase search and termbase recognition panes open.


Just to clarify things: you will see terms recognized in the source segment only in the "Term recognition" window (on the top right). If you have clicked the tab "Termbase Search", this hides the Term recognition window and you will not see the recognized terms, apart from the red line above the terms in the source segment.
You can do a search for a term in the "Termbase search" window to check whether your termbase is correctly attached (but please revert to the Term Recognition window afterwards).
And BTW, term recognition has nothing to do with the "AutoPropagate" function that you mention, these are two completely separate features. I guess you meant to say "AutoSuggest". Check in your options that termbases are enabled as AutoSuggest provider (should be by default).

Walter


Direct link Reply with quote
 

Eric Schwartz  Identity Verified
Colombia
Member (2011)
Spanish to English
TOPIC STARTER
I simplified my termbase and now it works Apr 25, 2015

Hello, thanks very much for your response. I'll explain what I did and also answer your questions.
I had multiple language variations because I had the idea that the termbase languages had to match the project language exactly, like is the case (I think) with translation memories. And I was very ambitiously going to make separate entries by language variant, too: realise and realize, etc. I think that now I'll just leave the languages as English and Spanish.

When I said "one for each language", I meant that when I created the termbase in multiterm, it only asked me for the language variants; it didn't ask me how many terms I would have of each variant (es-ES1, es-ES2).

When I said I set it up as a termbase, I meant that I set up the termbase I had created as the termbase for that project. I see I switched my pronouns around a bit too much and it wasn't clear, you're right.

And I see I was confused about the auto-propogate feature.

What I meant in that case was that nothing showed up in the termbase recognition pane, and the terms in the termbase weren't marked with the red line above them in the editor.

My solution was just to simplify. I redid the termbase to just have Spanish and English, though with two terms for each. And now I obviously don't have the first problem. And for some reason, the termbase results are also showing up in the termbase recognition pane now.

Thanks!


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Multiterm doesn’t recognize different language variants from termbase

Advanced search







memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search