Studio 2014 misinterprets numbers as times of day
Thread poster: Kate Deimling

Kate Deimling
United States
Local time: 07:10
French to English
+ ...
Apr 29, 2015

I'm not sure there's any solution to this problem, but here goes!

I'm translating a big Word file of subtitles. Above each line there are numbers that correspond to the time code of the video. I'm supposed not to touch these numbers. When I translate the doc in Studio 2014, it keeps on interpreting the numbers as times of day. For instance,

01:00:40.01 01:00:41.19 Duration 00:00:01.18 26

becomes

01:00:40 AM.01 1:00:41 AM.19 Duration 12:00:01 AM.18 26

So, I've been selecting "copy source to target" for each such segment. There is then a long delay of up to 2 full minutes when I confirm the segment while Trados processes and supposedly auto-propagates my change. Yet most of the remaining segments are still changed into times of day and treated like perfect matches. The process is so slow that I'm on the verge of giving up...but could you recommend a solution that I haven't thought of?

Thanks for any help!

Kate


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 13:10
English
This works correctly for me... Apr 29, 2015

... so it's probably down to your autosubstitution settings. Times are automatically localized based on the format you have in your settings.

Try going to Project Settings -> Language Pairs -> Specific language pair -> Auto-Substitution -> Dates and Times. Then set the way the times should be handled from the drop down.

If that doesn't work for you then it's most likely because your windows settings are using this format for the times. So changing the default windows settings for date/time may well resolve it. Studio uses whatever is available in your windows settings.

But try the Studio settings first, may well be a simple solution.

Regards

Paul
SDL Community Support


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 13:10
English
Meant to add... Apr 29, 2015

... that if this doesn't work, or possibly even if it does then there is a better way to do this. Especially on a large project with many files or hundreds/thousands of these segments.

Use the SDLXLIFF Toolkit to correctly handle every segment, confirm as translated and lock them. Only takes a few clicks and then you won't have to worry about them at all. Drop me an email if you need help with that (on a train and connection is very flaky... so email is better!)

Regards

Paul
pfilkin@sdl.com


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 13:10
English
Video Explanation Apr 29, 2015

Hi Kate,

I created a video to explain how to do this. It's about 15 mins long as I also covered a few other things including how to create the regular expression.

https://youtu.be/DX-IWQU3LbI

I hope this is clear.

Regards

Paul
SDL Community Support


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio 2014 misinterprets numbers as times of day

Advanced search







memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search