Studio 2015 - AS conflicts with actual keystrokes
Thread poster: _stephan

_stephan  Identity Verified
Germany
Local time: 20:25
English to German
Jun 30, 2015

Hi,

so I installed Studio 2015 last night side by side with 2014, and I've been working with it the whole morning only to discover that it's introduced what could become my next pet peeve.

When Studio loads AS matches while I'm typing, it tends to skip the odd keystroke.

For example:

Termbase entry: DE "Ansprechpartner" = EN "contact"

Source segment: "Wir haben die wesentlichen Termine [...] und Ansprechpartner in einem Dokument zusammengefasst."

So I begin to type "We have compiled..." and the moment I press "c" it begins to load the AS list and I end up with "We have cpiled".

This happens all the time, even when it suggests the exact term I want to type. I'm just usually a lot faster typing than interrupting the flow by accepting an AS match. Still I don't want to lose the AS altogether because I do use it, especially for longer terms.


I may be the only person to actually use 2015 for real projects the morning after it was released, but has anyone else experienced this? Is this something that can or needs to be fixed with an extra memory bar? To be honest, I haven't looked at the potentially higher system requirements of 2015.


Thanks
Stephan








[Edited at 2015-06-30 11:14 GMT]

[Edited at 2015-06-30 11:16 GMT]


 

Emma Goldsmith  Identity Verified
Spain
Local time: 20:25
Member (2010)
Spanish to English
Autocorrect? Jun 30, 2015

_stephan wrote:

I may be the only person to actually use 2015 for real projects the morning after it was released, but has anyone else experienced this?


I've been using Studio 2015 for several weeks as a beta tester, with real projects.

I haven't noticed AS conflicts with keystrokes or any skipped keystrokes.
It sounds to me that the behaviour you've noticed is related to AutoCorrect, not autosuggest.

Try disabling "Replace text as you type" in Options>Editor>AutoCorrect
If that solves it, at least you know the cause of this behaviour.


 

_stephan  Identity Verified
Germany
Local time: 20:25
English to German
TOPIC STARTER
Not AutoCorrect Jun 30, 2015

Emma Goldsmith wrote:

Try disabling "Replace text as you type" in Options>Editor>AutoCorrect
If that solves it, at least you know the cause of this behaviour.



Thanks Emma. However, this box has been unchecked all the time. In fact, I am almost ready to believe now that this is a general performance issue, even though my system does meet the installation prerequisites.

I gave it some rest and closed the odd application and it does work a lot better now. Not 100% reliable—skipping keystrokes still occurs, but nowhere near as often as before. Still, I did some of the same project in 2014 and it's perfectly fine there.

So performance issue or my keyboard wigging out on me. I shall find that out tomorrow when I get to work with a different keyboard at the office.


Edit: Whatever it is I really have to find a way to fix it or go back to 2014 for the time being. While turning "location" into "lotion" may be funny, it is overall a real pain...

[Edited at 2015-06-30 13:41 GMT]


 

_stephan  Identity Verified
Germany
Local time: 20:25
English to German
TOPIC STARTER
Jun 30, 2015



[Edited at 2015-06-30 12:40 GMT]


 

Wojciech_
Poland
Local time: 20:25
English to Polish
+ ...
Another problem with AS Jul 1, 2015

I could also add this problematic situation, where AS suggestions (especially the one with yellow background) cover the translation...

Look here:
https://www.dropbox.com/s/j98204gppovfr2i/wp_20150701_17_53_57_pro.jpg?dl=0

Another problem is that with automatic concordance search (when there are no matches) and MT engines on the same tab in the results view (default setting), the tab automatically changes from MT results to concordance results, which is a bit annoying.
The only solution in this case is to detach the concordance window from the results view.

Also, is it possible for the active segment to be always set in the middle of the window? This would partly solve the problem with AS obstructing the view, which appears mostly when the translated segment is at the bottom of the window (in such a situation AS is displayed above the text and obstructs the view).

[Edited at 2015-07-01 21:37 GMT]


 

Norbert Wellmeyer  Identity Verified
Germany
Local time: 20:25
English to German
Studio 2015 AutoSuggest steals keystrokes Aug 17, 2015

I do have the same problem.
Turning AutoSuggest off solves the problem, but that is not acceptable.
AutoCorrect (replace at typing) has no impact on this issue.

I don't have the problem with Studio 2014 at all, and the computer is far above the system requirements.
I would greatly appreciate any hint, suggestion or fix.

Thanks,
Norbert

Edit: Now that I got the hint from this discussion what's the culprit, I set AutoSuggest to show suggestions from 3 characters or up. For now, this seems to fix it.
Perhaps someone can try also and confirm.

[Edited at 2015-08-17 12:29 GMT]


 

JoelD  Identity Verified
Local time: 03:25
Japanese to English
Same issue! Sep 8, 2015

I planned to use AS and Dragon with 2015 to up my productivity, but so far the annoying bug described here coupled with the annoying bug in this thread make me want to revert to 2014 or even 2011.

"Replace text as you type" is already disabled so in the meantime I will try changing the character length of suggestions. ( I swear I already did that. Do I have to change my settings for every project?)


 

Helen Matthews  Identity Verified
United Kingdom
Local time: 19:25
Member (2008)
Italian to English
+ ...
Same issue in a different thread Sep 8, 2015

Didn't find this forum when I posted (http://www.proz.com/forum/sdl_trados_support/291052-studio_2015_slow_in_using_termbases.html) - but I'm having the same issue.... we need a solution here!!

 

JoelD  Identity Verified
Local time: 03:25
Japanese to English
This bug is driving me mad! When can we expect and update? Sep 15, 2015

Argh! I cannot stand this bug any longer. I've set my AutoSuggest to not suggest anything under 4 keystrokes, but it still steals my keystrokes. I have a massive glossary and AS dictionary, so disabling the function completely defeats the purpose of using Trados in the first place.

I know SDL is looking into the issue, but please be aware that there are a lot of us out here whose productivity is being killed. I have to spend an inordinate amount of time going back and changing "te" to "the" etc.


 

JoelD  Identity Verified
Local time: 03:25
Japanese to English
Still waiting for an update Oct 5, 2015

I swear this bug is getting worse. My laptop is running slower for some reason, so now, the AS slows way down. If I type at normal speed, the first letter appears, then the AS "steals" the second and/or third letters, and by the time I'm done I get sentences that look like this :

"Forescore ad sven yars agao, our fthers brought fr th on ts cntientn a new nation."

Now, I realize some of this includes some of my own typing errors ("agao"), but this is ridiculous.

The AS in 2015 is worthless!

I'm just gonna keep posting here over and over until SDL updates because there is nothing else I can do.


 

SDL Community  Identity Verified
United Kingdom
Local time: 20:25
English
AS conflicts Oct 5, 2015

JoelD wrote:

I'm just gonna keep posting here over and over until SDL updates because there is nothing else I can do.


I imagine you have seen the posts in here explaining this will be fixed in the next update? If not I can confirm the fix is coming. The update release will be made available to our Beta testers later this week with any luck and then into production later this month. This is the plan, and all being well this is what will happen.

Regards

Paul
SDL Community Support


 

Spiros Doikas  Identity Verified
Local time: 21:25
Member (2002)
English to Greek
+ ...
Similar Oct 6, 2015

I have experienced something similar
http://www.proz.com/forum/sdl_trados_support/292535-studio_2015_and_conflict_with_text_expanders.html

Also, sometimes, when I start typing in a segment, the order of the second letter is reversed. I type "Th" and I get hT.

[Edited at 2015-10-07 11:00 GMT]


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio 2015 - AS conflicts with actual keystrokes

Advanced search







memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search