Why does the TMs exported from memoQ get disabled and can't be activated in Studio 2014?
Thread poster: Fredrik Pettersson

Fredrik Pettersson  Identity Verified
Hong Kong
Member (2009)
English to Swedish
+ ...
Jul 31, 2015

Why does the TMs exported from memoQ get disabled and can't be activated in Studio 2014?

The customer created a Studio package for me with many TMs and 23 source files for use in my SDL Trados Studio 2014. The source files worked fine to open and begin translating, but not the TMs. This is the error message I receive:

The translation provider 'XXX_XXX_XXX' could not be opened and has been disabled

Each time I tick the box to enable it I receive this error message that the TM can't be activated.

It is ticked for Update, Look up and Concordance (ticked in shaded grey). Two main TMs (same error message for both) and many sub-TMs. Both in All language pairs.

I then tried to create a new empty Studio TM myself, and imported from the TMX my customer had given me. But it turned out this TMX was empty (according to SDL Support).


Direct link Reply with quote
 

John Fossey  Identity Verified
Canada
Local time: 01:31
Member (2008)
French to English
memoQ Jul 31, 2015

At what point in your workflow was memoQ involved? Aside from the initial question you did not mention memoQ.

Direct link Reply with quote
 

Fredrik Pettersson  Identity Verified
Hong Kong
Member (2009)
English to Swedish
+ ...
TOPIC STARTER
MemoQ is the source CAT tool that I was supposed to use Aug 1, 2015

The customer normally have all their translators to connect to their memoQ server by installing the translator version of memoQ 2015. But in this case, my customer agreed that they create a package for me to be used with SDL Trados Studio 2014 instead.

The files (SDLXLIFF) worked without problems: I could open them in SDL Trados Studio 2014 and translate.
But the TMs, as SDL Support found out for me yesterday, are set in the project package settings to require connection to their memoQ server (from SDL Trados Studio), so that was the reason they didn't work for me.

I asked the customer yesterday to create a project package for Studio which included TMs that works in Studio, but now this morning when I woke up I received e-mail with pre-translated files from my customer, files to be used in Studio. I guess I can align these and create a TM out of them (because I didn't receive any TM for use in Studio), but the customer implied perhaps she hadn't enclosed all the pre-translated files yet. I think she wants me to try these first and see if they work. If they do, I hope she sends the files that remains.

So I think next step is to try these files and see if I can align them to create a TM of them.


Direct link Reply with quote
 

John Fossey  Identity Verified
Canada
Local time: 01:31
Member (2008)
French to English
Differences in segmentation Aug 1, 2015

MemoQ and SDL Studio perform segmentation slightly differently. A SDLXLIFF file created entirely with memoQ will not fully match the way SDL Studio uses it.

You cannot connect to a memoQ server with SDL Studio, and vice versa. They use a different protocol.

Can your client send a TMX file? This can be easily imported into SDL Studio.


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 07:31
English
This is only possible... Aug 1, 2015

Fredrik Pettersson wrote:

But the TMs, as SDL Support found out for me yesterday, are set in the project package settings to require connection to their memoQ server (from SDL Trados Studio), so that was the reason they didn't work for me.


... if your customer has some plugin that allows them to add a memoQ server to a Studio project. This is not beyond the realms of possibility, but if you don't have the plugin you won't be able to use it! If they don't have such a plugin then what you have described is impossible to achieve through Studio because it will only allow you to add a Studio Server TM.

Fredrik Pettersson wrote:

I asked the customer yesterday to create a project package for Studio which included TMs that works in Studio, but now this morning when I woke up I received e-mail with pre-translated files from my customer, files to be used in Studio. I guess I can align these and create a TM out of them (because I didn't receive any TM for use in Studio), but the customer implied perhaps she hadn't enclosed all the pre-translated files yet. I think she wants me to try these first and see if they work. If they do, I hope she sends the files that remains.

So I think next step is to try these files and see if I can align them to create a TM of them.


I'm confused by this. If she gave you pre-translated files then they are most likely XLIFF and you won't need to align them at all. Or did she give the target files partially translated? If the latter you'd need to pick out the translated segments, and probably penalise them too in case they are not 100% because aligning would give you the same 99% (automaticaly penalised 1%) for every segment in the TM.

This all sounds a little confused I think.

Regards

Paul
SDL Community Support


Direct link Reply with quote
 

Stepan Konev  Identity Verified
Russian Federation
Local time: 08:31
English to Russian
Override for Fredrik Pettersson Aug 1, 2015

TMs exported from memoQ get disabled and can't be activated in Studio
As far as I understand, you exported your memoQ TM into tmx and than imported it into Trados TM, right? If so, read next...

I have both memoQ and SDL Trados Studio 2015, and my clients who give me Trados packages do not even guess that I rarely use Trados for translation.
However, once I decided to try the brand new SDL Trados 2015 and tried to import my memoQ TMs into Studio. I got the same problem. The solution is in settings:

Normally you use this path to open TMs in STudio: Project settings => Language pairs => All language pairs => Translation Memory and Automated Translation => Add...
DO NOT use this path, use this one:
Project settings => Language pairs => Source language->Target language => Translation Memory and Automated Translation => Check 'Use different translation providers for this language pair' => Add...
Then you choose your TM converted from memoQ and use it.

[Edited at 2015-08-01 16:13 GMT]


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 07:31
English
That's interesting... Aug 1, 2015

Stepan Konev wrote:

Normally you use this path to open TMs in STudio: Project settings => Language pairs => All language pairs => Translation Memory and Automated Translation => Add...
DO NOT use this path, use this one:
Project settings => Language pairs => Source language->Target language => Translation Memory and Automated Translation => Check 'Use different translation providers for this language pair' => Add...
Then you choose your TM converted from memoQ and use it.


... so memoQ creates the project from the package using the specific language pair and not the All Language Pairs. I never noticed that before.

Good tip.

Regards

Paul
SDL Community Support


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Why does the TMs exported from memoQ get disabled and can't be activated in Studio 2014?

Advanced search







TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search