Trados 2015: how to filter for empty target fields
Thread poster: Samuel Murray

Samuel Murray  Identity Verified
Netherlands
Local time: 07:15
Member (2006)
English to Afrikaans
+ ...
Sep 15, 2015

Hello everyone

Is there a way to filter segments so that only segments that are empty are displayed? I'm not talking about "untranslated". These segments in my SDLXLIFF file are marked as "translated" but their target text fields are empty. Or, what is the regular expression for "nothing at all"?

Thanks
Samuel


Direct link Reply with quote
 

NeoAtlas
Spain
Local time: 07:15
English to Spanish
+ ...
A 6-step way… Sep 16, 2015

… unless another colleague gives you a more straight way:

1.- Filter using this regex: ^.{1,}$

This will filter all segments with at least one character in target.

2.- Mark them as Translation aproved, for example.

3.- Reset filter.

4.- Filter by Translated.

5.- Mark them as Not translated.

6.- Optional: Restore the Translation approved segments as Translated.

Regards,

... Jesús Prieto ...


Direct link Reply with quote
 
valerius  Identity Verified
Latvia
Local time: 08:15
English to Latvian
+ ...
Segments with messages? Sep 16, 2015

Haven't used Studio 2015 yet, but in 2011 empty confirmed segments have error messages added to them and there is an option to filter segments with messages.

Regards,
V.


Direct link Reply with quote
 

Roy Oestensen  Identity Verified
Norway
Local time: 07:15
Member (2010)
English to Norwegian (Bokmal)
+ ...
... but only after Verify is run? Sep 16, 2015

For Studio to flag empty segments I cannot see any other way than to run the Verify function.

Direct link Reply with quote
 
Manuel Arcedillo
Spain
Local time: 07:15
English to Spanish
RegEx for nothing at all Sep 16, 2015

Hi,

RegEx for nothing at all in target is ^$, but I'm afraid Studio needs something in the target side to perform the match, so matching empty segments apparently is not an option here. If you want to filter them, what Jesús said should work (searching ^ or . would be even simpler), or you can disable all QA checks except the empty translations and then filter by segments with messages.


Direct link Reply with quote
 
Mariusz Listewnik  Identity Verified
Poland
Local time: 07:15
Polish to English
+ ...
Works! May 6, 2016

The solution proposed by Jesús worked wonderfully. I only had trouble with selecting empty segments. My usual method when selecting all segments is to press Ctr Shift End, but it won't work with empty target fields. Instead, I pressed the first segment (on its number in the left), kept shift pressed and selected the last segment number. Then it was possible to change the status to "Not translated" again.

Direct link Reply with quote
 

Artyom Timeyev  Identity Verified
Russian Federation
Local time: 10:15
Russian to English
+ ...
Thank you May 14

Thank you, NeoAtlas.
Your solution worked like a charm in Trados 2011.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados 2015: how to filter for empty target fields

Advanced search







TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search