Pages in topic:   [1 2] >
Studio 2015: curved apostrophes make problem
Thread poster: LuxTranslations

LuxTranslations  Identity Verified
Luxembourg
Local time: 17:18
Member (2011)
German to French
+ ...
Sep 18, 2015

Hello,

When using Studio 2015 with French quotation marks (« and »), Studio automatically uses curved apostrophes, which basically is O.K., but I've got the following issue: any time I write a character chain like: "l'entrée" Studio automatically goes back to the apostrophe after the first character I type, i.e. if I start typing "l'e", than Studio goes back to the apostrophe, making me stop typing to place the cursor after the "e" and go on with "ntrée".

Studio seem to need time to adjust this apostrophe (to make it curved), which is a problem when typing fast.

Does anybody else have this issue? And any solution?


Regards,
Caroline

[Modifié le 2015-09-18 09:36 GMT]


Direct link Reply with quote
 

Łukasz Gos-Furmankiewicz  Identity Verified
Poland
Local time: 17:18
English to Polish
+ ...
Similar Sep 18, 2015

I have a similar problem with curly apostrophes but not with question marks. Two are okay, but one is a problem. The cursor goes back one character, with me typing in the wrong place as a result. This does not occur when I type very slowly.

Direct link Reply with quote
 

Roy Oestensen  Identity Verified
Norway
Local time: 17:18
Member (2010)
English to Norwegian (Bokmal)
+ ...
You could try AutoHotkey Sep 18, 2015

Someone suggested the free utility AutoHotkey (http://ahkscript.org/download/) for entering for instance quotation marks in Studio (and other programs) if the normal keys on the key board didn't work. Norwegian uses French quotes, but without space, so the shortcut in Studio doesn't work well (« ») for Norwegian.

I've tried using an AutoHotkey script which enters the characters « and » when I hit ", and it seems to work well.

By the way I have not experienced the problems you have, but hope the above solution may be of some help for you.


Direct link Reply with quote
 

Samuel Murray  Identity Verified
Netherlands
Local time: 17:18
Member (2006)
English to Afrikaans
+ ...
I've experienced it too Sep 18, 2015

charlier_c wrote:
If I start typing "l'e", than Studio goes back to the apostrophe, making me stop typing to place the cursor after the "e" and go on with "ntrée".


I experienced this yesterday, and started writing a post about it, but then when I tried to duplicate the issue later, Trados decided to behave correctly. Trados will probably misbehave again at some point. I'm not sure what causes this behaviour.

In my case, I typed the apostrophe and the letter "n" and a space, but Trados would move the cursor back to between the apostrophe and the letter "n" before I could press space, which means that although I meant to type ['n ] I ended up typing [' n], and i could not fix it without extensive left/right arrow key usage.

Studio seem to need time to adjust this apostrophe (to make it curved), which is a problem when typing fast.


In my case, it was a straight apostrophe and it remained straight. Have you tried disabling all of the autocorrect check boxes -- does that have an effect?


Direct link Reply with quote
 

LuxTranslations  Identity Verified
Luxembourg
Local time: 17:18
Member (2011)
German to French
+ ...
TOPIC STARTER
disabling all of the autocorrect check boxes Sep 18, 2015

Hi,
Well, I actually need these characters: «, », ’.
Caroline


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 17:18
English
Autohotkey... Sep 18, 2015

... is a good alternative until these issues are fixed in Studio (next update). There is also a script to handle the guillemets in the comments:

http://multifarious.filkin.com/2013/10/10/those-dumb-smart-quotes/

Regards

Paul
SDL Community Support


Direct link Reply with quote
 

Samuel Murray  Identity Verified
Netherlands
Local time: 17:18
Member (2006)
English to Afrikaans
+ ...
Oh, I have to type like I'm using Linux Sep 18, 2015

Hello

I've tested it again (with autocorrect enabled again).

1. For me, in my language, it's not a speed issue, but it's the fact that Trados does not return the cursor to its original position after applying the autocorrection. You can see this more clearly if you use dead keys, like I do in my language.

Since I'm using the United States International keyboard layout, the apostrophe does not appear until I type another character. In other words, if I press the apostrophe key, nothing happens (this is normal), and if I then press an unmodifiable character's key, then an apostrophe appears plus that other key. However, when I do that, Trados moves the cursor to the apostrophe (to do the autocorrection, I presume) and then neglects to return the cursor to where it was. This has nothing to do with speed -- I can do this as slow as I want, but Trados always moves the cursor back to the apostrophe and does not return it to where it was before the autocorrection was initiated.

I can solve this problem by typing in Trados as I would have to type in many Linux programs, by always pressing the spacebar after typing any key that is normally a dead key. In other words, instead of typing apostrophe + "n" + space, I would have to type apostrophe + space + "n" + space, which would result in ['n ].

(See, in most Linux programs (using the United States International keyboard), typing apostrophe + "hello" + space results in [hello'], whereas in most Windows programs typing apostrophe + "hello" + space would result in ['hello ]. In both Windows and Linux, typing apostrophe + "ello" plus space would generally result in [éllo ].)

2. However, I can see that slowing down your typing would be beneficial in cases that do not involve dead keys.

Is this a bug? You betcha.

Samuel


Direct link Reply with quote
 

LuxTranslations  Identity Verified
Luxembourg
Local time: 17:18
Member (2011)
German to French
+ ...
TOPIC STARTER
AutoHotkey Sep 18, 2015

Hello,

I'm afraid I don't understand how this works... I don't even understand what I'm to download there.
What is more, on http://multifarious.filkin.com/2013/10/10/those-dumb-smart-quotes/, only the first guillemets get changed... I would need: «alt0160 and alt0160».

Caroline

[Modifié le 2015-09-18 10:32 GMT]


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 17:18
English
So why not... Sep 18, 2015

charlier_c wrote:

Hello,

I'm afraid I don't understand how this works... I don't even understand what I'm to download there.
What is more, on http://multifarious.filkin.com/2013/10/10/those-dumb-smart-quotes/, only the first guillemets get changed... I would need: «alt0160 and alt0160».

Caroline


... use the standard Quick insert for these and add them to the toolbar? This is also covered in the article. You can copy paste the guillemets from Word and add them as a tag pair.

Wouldn't that work?

Or even use the new insert symbol feature in Studio which can also give them a shortcut?

Or perhaps using AutoCorrect would work by having some simple keyboard combination replaced by the guillemet like this:


Regards

Paul
SDL Community Support


Direct link Reply with quote
 

LuxTranslations  Identity Verified
Luxembourg
Local time: 17:18
Member (2011)
German to French
+ ...
TOPIC STARTER
copying from Word, etc. Sep 18, 2015

Hello,

I don't want to stop typing, use the mouse (use a shortcut) and get some quotation marks or that will come double, I'll then have to go between them to type the text, etc. ... Too fastidious.
To copy from Word... too fastidious
I can still change everything at the end, as I used to do in Studio 2014, but since there is this option in Studio 2015, I expected it to wok...

I've tried your AutoCorrect idea, but this doesn't work either.

Thanks anyway for all your answers. I think I will come back to Studio 2014 procedure.


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 17:18
English
The AutoCorrect idea... Sep 18, 2015

charlier_c wrote:

I've tried your AutoCorrect idea, but this doesn't work either.

Thanks anyway for all your answers. I think I will come back to Studio 2014 procedure.


... worked for me, perhaps you didn't check the replace text as you type? Anyway, this is a bug and it's been discussed in other posts in ProZ already. It will be resolved in the next update (next month), so for now we're all throwing workarounds at you... sorry about that!

Regards

Paul
SDL Community Support


Direct link Reply with quote
 

NeoAtlas
Spain
Local time: 17:18
English to Spanish
+ ...
Replace "straight quotes" with “smart quotes” box Sep 19, 2015

charlier_c wrote:

I would need: «alt0160 and alt0160».



Caroline: I checked this works for the target French (Luxemburg) as long as you have checked Replace "straight quotes" with “smart quotes”, in File > Options > Editor > AutoCorrect.

I mean, Studio 2015 inserts the hard spaces you mention.

Regards,

... Jesús Prieto ...


Direct link Reply with quote
 

Samuel Murray  Identity Verified
Netherlands
Local time: 17:18
Member (2006)
English to Afrikaans
+ ...
Another aspect of this bug, perhaps Sep 21, 2015

SDL Community wrote:
Anyway, this is a bug and it's been discussed in other posts in ProZ already. It will be resolved in the next update (next month), so for now we're all throwing workarounds at you... sorry about that!


1. Well, while they're at it, do you think it's an option to get Trados to replace straight quotes with smart quotes only when the quotes are actually typed? I've noticed that if I copy source to target a segment with straight quotes, the quotes remain straight only for as long as I don't move the cursor around in the segment. As soon as I move the cursor, all quotes in the target text change to smart quotes. That is very, very bad. Now I understand how texts that I translated with the right kind of quotes come back from the client with all the wrong types of quotes in them.

2. There's another problem that might be related to this bug, namely when I press Ctrl+PgDn in a segment with straight quotes, Trados not only changes the quotes to smart quotes but also duplicates some of the text.

Here's what the segment looks like directly after I pressed Alt+Insert:



And after I press Ctrl+PgDn, I get this:



Note how only some of the quotes were smartified, and a chunk of text got duplicated. This is not a screen error... refreshing the screen doesn't change this.

Samuel


Direct link Reply with quote
 

Richard Hill  Identity Verified
Mexico
Local time: 11:18
Member (2011)
Spanish to English
In word a simple ctrl+z undoes curly quotes but not in Studio Sep 22, 2015

Replace quotes works so smoothly in Word, and who knows why Studio can't emulate this behavior. I was translating a text the other day with lots of straight quote inch symbols and I would expect, as with Word, that after being automatically replaced with curly quotes, a simple ctrl+z would undo the change, but no, you need to fiddle with the mouse and do a couple of clicks to undo the curly quotes. One more detail that needs ironing out.

Direct link Reply with quote
 

LuxTranslations  Identity Verified
Luxembourg
Local time: 17:18
Member (2011)
German to French
+ ...
TOPIC STARTER
good idea for the next update... Sep 22, 2015

Well, thank you for your confirmation.
Maybe we might ask here the SDL programmers to think about this issue (and implement a well-working solution) for the next update? Let's hope this call will be heard.

Caroline


Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio 2015: curved apostrophes make problem

Advanced search







Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »
SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search