SDL 2011 - TM results without tags
Thread poster: Dvir Cafri

Dvir Cafri  Identity Verified
Israel
Local time: 03:19
English to Hebrew
Oct 28, 2015

Hello.
I have a weird situation with SDL 2011. I am working on a large project with many UI items surrounded by tags. I have a TM and Termbase, but the results I get are without the tags (I guess they didn't exist in a previous version of the document). For such segments, Trados usually returns the 99% match result with 1% penalty for different formatting, but it somehow also adds the missing tags and places them in their proper place to create a perfect full match.

Problem is, for some reason I can't get Trados to copy the tags, only the original TM result without them. I can select everything (including the tags), but only the text is copied. I tried with ALT-1 (it always is the first result) and also by manually copying the whole segment in the TM result window using the mouse, but the tags aren't copied. Other matches (partial, CM, 100%) can be copied without a problem.

Any idea how I could copy the result with the tags? I'm desperate.


Here is an example. I replaced the regular tag brackets with round brackets since Proz's editor interprets tags:

Source segment:
(b)OK(/b): Confirm the action.

TM orignal match (in target language, of course):
OK: Confirm the action.

TM top result looks like this (in the target langauge):
(b)OK(/b): Confirm the action.


But I can't copy the tags in this result to the target segment, no matter how I tried.

Thanks in advance.
Dvir


[Edited at 2015-10-28 15:00 GMT]


 

Sandra& Kenneth  Identity Verified
Israel
Local time: 03:19
Member (2009)
French to English
+ ...
Why can't you add the tags to the source? Oct 29, 2015

I'm not sure what your problem is.
What are UI items surrounded by tags?

If you want the tags to be added to the TM, add them in the target segment, and confirm the segment. That will do it.

Here is how to insert tags in target:
Simple guide to working with Tags in Studio | multifarious - http://is.gd/z2hMet

HTH,
Sandra


 

Dvir Cafri  Identity Verified
Israel
Local time: 03:19
English to Hebrew
TOPIC STARTER
Thanks, but that's not it. Oct 29, 2015

Thank you for your help. However, this is not what I meant.

Please check the following screenshot:
https://www.dropbox.com/s/1hscsb9zucbjw19/Screenshot%202015-10-29%2010.47.02.png?dl=0


.1 The source segment contains tags.
.2 The TM result shows the tags, and they perfectly match the layout of the source tags. I'd like to simply and quickly copy the complete TM result to the target segment with the tags to save time and effort.
.3 The target segment (in the translated document) contains only the text of the segment without the tags. No matter what I do, I cannot copy the tags to the target segment. I need to manually insert them using ALT-CTRL-Down or one of the other similar combination, one by one. I tried:
- ALT-1
- Highlighting the TM result using the mouse.
.4 If the TM result doesn't contain formatting penalty, then I can copy the TM result with the tags using ALT-1...9 without a problem.


Interestingly, I just found that the tags that cannot be copied are "group" tags (). If they appear in a TM result with "formatting penalty", then they cannot be copied. If they appear in regular non-penalized TM result, I can copy them just fine.

Any idea?


 

Sandra& Kenneth  Identity Verified
Israel
Local time: 03:19
Member (2009)
French to English
+ ...
Remove the formatting penalty... Oct 29, 2015

Hi Dvir,

To change the penalty settings:

File -> Options -> Translation Memory and Automated Translation ->Penalties

HTH,

Sandra


 

Dvir Cafri  Identity Verified
Israel
Local time: 03:19
English to Hebrew
TOPIC STARTER
When I change the penalty settings Oct 29, 2015

I don't see a penalty for the result, but I still cannot copy the tags in the result to the target segment. I have to place them manually from the ALT-CTRL-Down menu.

Its as if those are kind of "ghost" tags. I can highlight them, but I can't copy them from the TM result.


 

Sandra& Kenneth  Identity Verified
Israel
Local time: 03:19
Member (2009)
French to English
+ ...
You can use Ctrl-Click to copy tags. Oct 29, 2015

Hovering with the mouse in the source will highlight the correct tag. Then Ctrl-Click on it to copy it at the cursor.

It's easier.
icon_smile.gif


 

Dvir Cafri  Identity Verified
Israel
Local time: 03:19
English to Hebrew
TOPIC STARTER
I know that Oct 29, 2015

But:

.1 I don't want to use the mouse while working. Its extremely cumbersome, especially when I have so many segments I need to handle. Many of the segments contain more than one tag, so it would take forever to handle all of this using the mouse.
.2 In the TM result, I see the segment exactly as it should be (it looks like a 100% match, ready to be used as is). If I could simply copy it using ALT-1..9, it could have saved me a huge amount of time instead of inserting the each tag manually with ALT-CTRL-Down.

To put it in simple words: I see a 100% match in the TM result, and I'd like to copy and use it as is, even let SDL automatically "translate to fuzzy" without me having to manually rebuild the segment. For some unknown reason, this is not possible with penalized segments containing group tags.


But thanks anyway for trying to help. I appreciate it. Looks like I'm coming out of the "ghost tag zone", I now encounter less segments with this issue.


 

writec
Italy
Local time: 02:19
English to Italian
+ ...
Same problem, how did you solve it? Oct 20, 2016

HI, I'm having the same problem... have you found a way to solve it?
Thank you very much


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

SDL 2011 - TM results without tags

Advanced search







CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search