Pages in topic:   [1 2] >
Unable to add new files to a created project in Trados 2014
Thread poster: Egmont Schröder

Egmont Schröder  Identity Verified
Germany
Local time: 11:35
Member (2013)
Chinese to German
+ ...
Nov 16, 2015

Hello,

I have a very special problem with Trados, which is very annoying.

Eyertime I create a project and want to add new files to this project, the files are listed in the view "file", but the button "Open for translation" is greyed out for ALL of the files. I can't do anything with them.

Even when I delete them and open them again, the button is still greyed out. The only way to work with them again is to create a new project from the scratch.

Does anybody know what is going wrong?

Thanks!


 

Roy Oestensen  Identity Verified
Norway
Local time: 11:35
Member (2010)
English to Norwegian (Bokmal)
+ ...
Perhaps try to change the language selection? Nov 16, 2015

I also had this problem, until someone made me aware that I had to switch the language selection from the source to target language. You see the language selection above the file list.

Roy


 

Maria Simmen
Germany
Local time: 11:35
Member (2009)
English to German
+ ...
Just a guess, Nov 16, 2015

but did you check what it says in the "usage" column in the files view? I think it has to say either "translatable" or "localizable". If it's a "reference" file, it won't let you open it I don't think. You can change the usage when creating a project.

 

Walter Blaser  Identity Verified
Switzerland
Local time: 11:35
French to German
+ ...
Did you "prepare" the added files Nov 17, 2015

Egmont

When you add new files to one existing project, there are a few things that you need to address.

First, you need to switch to the source language before you add the files. Then, once you have added these source files, you need to convert them to SDLXLIFF by right-clicking on them and selecting "Batch Task - Prepare without Project TM". You will see that they now get the extension .SDLXLIFF, which they did not have just after you added them.

Finally, once you have done this you need to switch to the target language folder again in order to open the new files (in the SDXLIFF format). If you try to open a file for translation in the source language folder, nothing will happen.

Walter


 

Egmont Schröder  Identity Verified
Germany
Local time: 11:35
Member (2013)
Chinese to German
+ ...
TOPIC STARTER
It is the language selection:) Nov 18, 2015

But somehow I don't understand this feature.

When I open it, the language is "German", but when I add a file it automatically turns into "English", and I can't open the files for translation.

When I set the language to "German" again, I can open the original file for translation, but the new added files disappear.

Why does Trados automatically switch the language?


 

Roy Oestensen  Identity Verified
Norway
Local time: 11:35
Member (2010)
English to Norwegian (Bokmal)
+ ...
Guess you have to ask SDL that Nov 18, 2015

The language behaviour doesn't make sense to me either.

 

Ben Senior  Identity Verified
Germany
Local time: 11:35
German to English
Follow Walter's advice Nov 18, 2015

Egmont,

Walter explained very simply and very precisely what you have to do. Just follow his advice and you will be able to open the files for translation.

This is a problem that a lot of people have encounted when adding files to an existing project, but it is easily resolved.

It is in German when you are working in the translation because the target files are in German, but when you add a file it changes to English because the source files are in English. As Walter pointed out all added files have to be prepared, which is converting them into sdlxliff format, you CANNOT work directly in a Word file in Studio. To open a file for translation it must be in sdlxliff format and in the files view the language must be your target language.

Ben


 

Roy Oestensen  Identity Verified
Norway
Local time: 11:35
Member (2010)
English to Norwegian (Bokmal)
+ ...
Not sure if it still makes sense Nov 18, 2015

True, a file that is added, is in the source language, and has to be prepared. But after it is prepared for translation and opened in the Editor, I would have expected it to change to the target language by default so that I (the translator) don't have to remember.

[Edited at 2015-11-18 12:25 GMT]


 

Ben Senior  Identity Verified
Germany
Local time: 11:35
German to English
You are right Roy Nov 18, 2015

I agree with you Roy, but unfortunately it isn't so. This topic keeps regularly raising its head and is a problem for most newcomers to Studio and will continue to do so in the future, or until SDL come up with a solution.

Ben


 

Egmont Schröder  Identity Verified
Germany
Local time: 11:35
Member (2013)
Chinese to German
+ ...
TOPIC STARTER
Still not working Nov 18, 2015

I didn't read Walter's advice very carefully because it describes how to handle sdlxliff.
I get sdlxliff from the agency, so I don't need to convert them any more.

However, when I try to process the files with "Batch Tasks", the list of options is empty.

Even if I put the files directly in the target language folder, they do not show up in the view "file".



but did you check what it says in the "usage" column in the files view? I think it has to say either "translatable" or "localizable". If it's a "reference" file, it won't let you open it I don't think. You can change the usage when creating a project.



The usage is set to "translatable".


 

Ben Senior  Identity Verified
Germany
Local time: 11:35
German to English
Try this ... Nov 18, 2015

Egmont,

Try this:
In the Files view change to source language
Add your sdlxliff file
Right click on the added file go to Batch Tasks and select Copy to Target Languages
Then from Batch Tasks you should be able to Prepare without project TM
Switch to target language and open the file for translation

I have just tried it on two separate projects and it worked each time.

Ben


 

SDL Community  Identity Verified
United Kingdom
Local time: 11:35
English
The reason... Nov 18, 2015

Roy Oestensen wrote:

True, a file that is added, is in the source language, and has to be prepared. But after it is prepared for translation and opened in the Editor, I would have expected it to change to the target language by default so that I (the translator) don't have to remember.

[Edited at 2015-11-18 12:25 GMT]


... for this is that if you have a multilingual project how do we know which language to move to, or that you have finished processing the file? If you have the Freelance version you can't create custom batch tasks so you may wish to run more than one set.

That's the reason for the current logic anyway, so you have to do this:

1. drop the file(s) into the files list
2. process the files as required
3. switch to the language you wish to work with next

Having said this I do wonder why we didn't add some logic for bilingual projects where there is no choice... you only have one target language so it might make a lot of sense in this case to switch back to the target after the files have been prepared. Just assume that no more tasks are required on the source language files... in fact it's a rare usecase where more than one set of batch tasks would be run anyway.

But that's the logic anyway.

Regards

Paul
SDL Community Support


 

Roy Oestensen  Identity Verified
Norway
Local time: 11:35
Member (2010)
English to Norwegian (Bokmal)
+ ...
Exactly Nov 18, 2015

SDL Community wrote:
... for this is that if you have a multilingual project how do we know which language to move to, or that you have finished processing the file? If you have the Freelance version you can't create custom batch tasks so you may wish to run more than one set.

Having said this I do wonder why we didn't add some logic for bilingual projects where there is no choice... you only have one target language so it might make a lot of sense in this case to switch back to the target after the files have been prepared.


Of course, if it's a mutlilingual project, Studio would not automatically know which target language to switch to. But don't most freelance translators translate into just one language at a time?

I hope you will change that, as surely it would only be a case of checking how many target laguages there are in the project.

Roy


 

Egmont Schröder  Identity Verified
Germany
Local time: 11:35
Member (2013)
Chinese to German
+ ...
TOPIC STARTER
The list of batch tasks is empty Nov 18, 2015

Ben Senior wrote:

Right click on the added file go to Batch Tasks and select Copy to Target Languages

Ben


When I klick on "Batch Tasks", there is no list with tasks, only the information "No task available"


 

Walter Blaser  Identity Verified
Switzerland
Local time: 11:35
French to German
+ ...
Just to make sure ... Nov 18, 2015

Egmont Schröder wrote:
When I klick on "Batch Tasks", there is no list with tasks, only the information "No task available"


... check that you did not mark the project as "completed" because you cannot run any batch task on a completed project. You need to reactivate it first.

Walter


 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Unable to add new files to a created project in Trados 2014

Advanced search







Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search