Studio 2011 doesn't import symbols ¿¡ from .html
Thread poster: Kenny Barclay

Kenny Barclay  Identity Verified
Spain
Local time: 05:31
Member (2016)
Spanish to English
Jun 23, 2016

Hi everyone,

I m having a problem because Studio 2011 doesn't always import some symbols from an html file (specifically some upside down Spanish punctuation ¿ and ¡)

The problem means I can´t edit them out in Studio and they are still there when I generate the target version in English. Therefore, I have to then open, edit and then save the html file. This is a nuisance because I have a large number (over 300) files to translate.

Does anyone know why they don´t appear in the Studio editor or a way around this issue?

Thanks in advance!
Kenny


 

esperantisto  Identity Verified
Local time: 06:31
Member (2006)
English to Russian
+ ...
Show the file! Jun 23, 2016

Show the file, otherwise it all be just wild guessing. One wild guess: those characters are encoded as HTML entities rather than plain symbols. This is a very obsolete technique from the pre-Unicode era, unfortunately still used by some bad web designers. A possible solution: save them in UTF-8 without entities. This is possible, for example, with UniRed. However, I don’t know if there is any batch processing solution.

 

Kenny Barclay  Identity Verified
Spain
Local time: 05:31
Member (2016)
Spanish to English
TOPIC STARTER
The code is Jun 23, 2016

Hi,
Thanks for your reply.
I´m not too happy about putting up a link. I can tell you the code I need to go in and delete is:

¿ for the ¿
and
¡ for the ¡

So far I´ve been using Find&Replace to change them all at the same time in each document. It is a bit of a pain though!

Thanks
Kenny


 

Samuel Murray  Identity Verified
Netherlands
Local time: 05:31
Member (2006)
English to Afrikaans
+ ...
@Kenny Jun 23, 2016

Kenny Barclay wrote:
I can tell you the code I need to go in and delete is:
¿ for the ¿
and
¡ for the ¡


Unfortunately you pasted the exact same characters in both cases (xUUBF for the upside down question mark, and x00A1 for the upside down exclamation mark).


 

Kenny Barclay  Identity Verified
Spain
Local time: 05:31
Member (2016)
Spanish to English
TOPIC STARTER
Code was taken to mean the character Jun 23, 2016

[quote]Samuel Murray wrote:

Kenny Barclay wrote:
I can tell you the code I need to go in and delete is:
¿ for the ¿
and
¡ for the ¡



Oops. I didn't preview the post. By posting the code, it was taken to mean the symbol

the code (with period between characters) should be:

&.i.e.x.c.l.;

&.i.q.u.e.s.t.;


 

Samuel Murray  Identity Verified
Netherlands
Local time: 05:31
Member (2006)
English to Afrikaans
+ ...
@Kenny Jun 23, 2016

Kenny Barclay wrote:
I'm having a problem because Studio 2011 doesn't always import some symbols from an html file (specifically some upside down Spanish punctuation ¿ and ¡). ... The problem means I can´t edit them out in Studio and they are still there when I generate the target version in English. Therefore, I have to then open, edit and then save the html file. This is a nuisance because I have a large number (over 300) files to translate.


Kenny sent me the files and I confirm that it is a problem with the fact that the HTML files contain entities such as ¿ and ¡, which is just regular street HTML (despite the fact that some purists are opposed to their presence). Instead of displaying the correct characters, Trados acts lazy and simply turns them into tags. So if they are present in the target text, it means that the entities will be present in the target file.

[Kenny's files aren't fully formed HTML files (no heads, etc), but the code is HTML. So his files contain HTML (and only HTML), but they are not HTML files. Trados 2015 does identify them as HTML5, however.]

I don't have Trados 2011 (only 2015).

It is possible to disable entities in Trados' "HTML5" filter, but I have tried that with Kenny's files, and Trados still turns ¿ and ¡ into tags. So it would appear that there is no solution.

What you can do, is to ensure that you can see the entity, by telling Trados to display more of the tag, instead of just a tiny placeholder. In Trados 2015, you'd go to the View tab and then look on the far right for some purple icons. Hover your mouse over them and make sure the one that is called "Partial tag" is shown. I'm not sure how to do this in Trados 2011.



[Edited at 2016-06-23 14:58 GMT]


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio 2011 doesn't import symbols ¿¡ from .html

Advanced search







Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search