Studio 2017 does not export my file correctly [Workaround found]
Thread poster: MikeTrans
MikeTrans
Germany
Local time: 17:10
Italian to German
+ ...
Dec 2, 2016

Hello,
I'm sorry if this problem has been reported before, in this case thanks to point me, I haven't found anything related yet.
As a last testing with the new Trados version, I decided to see how Trados will handle Word or rtf files with hidden content. I have done the steps below after which I run the batch task 'Export Files' , but most (not all) of the segments in the output were in the original source language instead of the target language.

What I did:
-I have changed an original rtf file by selecting some content and then chose Fonts > Hidden (to hide specific content).
Trados will correctly import the file without the hidden content.

-I created a project without Project TM and with a TM to be read only (unchecked 'Update' box.)
-After opening the single file in the Editor, I filtered on certain segments and changed them to 'Translation Approved' and 'Locked' Segments.
-I then have worked on Unlocked segments; after editing/translating changed their status to 'Translated'.
-I have run the batch task 'Export for External Review', made some Search/Replaces.
-I then have re-imported the External Review via batch task.
-Then, I checked my file in the Editor and chose the batch task 'Export Files'.

When opening the exported file, most of the segments are in English (source language) instead of the translated German (target language) like shown in the Editor.

A bug, or do I miss something?


Thank you very much,
Mike

[Edited at 2016-12-03 13:27 GMT]


Direct link Reply with quote
 

Walter Blaser  Identity Verified
Switzerland
Local time: 17:10
French to German
+ ...
This seems like a quite convoluted workflow Dec 2, 2016

Hi Mike

I am trying to understand what you have been trying to achieve and one thing I don't understand is why you do an "Export for external review" if you make the changes yourself (and you have Studio). This feature is meant to send translated content to be reviewed by someone who does not have Studio (needing only MS Word). Why are you going through this unnecessary step?

I guess that the problem appeared during the export for external review and the subsequent reimport. Be aware that this feature has quite a few restrictions, one of them being that segments that don't have any translation (target segment empty) will not be reimported into Studio, meaning you will be left with the source segment, even if the reviewer has entered a translation into the target segment. A workaround for this is to run a pretranslate with the option "Copy source to target if no match from TM" before generating the file for external review.

Try to use a simpler workflow without the "Export for external review" and see whether you get better results. I guess, this will be the case.

Walter


Direct link Reply with quote
 
MikeTrans
Germany
Local time: 17:10
Italian to German
+ ...
TOPIC STARTER
Yes, exporting to Review was superfluous, Dec 2, 2016

Hi Walter,
I highly appreciate your response. Yes, I wanted to get rid of non-digits and non-letter characters, so I did the Export to Bilingual Review, but you are totally right: Trados has RegEx and I can just copy/paste special charachters in the Replace window, I realized this only afterwards, a tribute to my un-expertise with Trados yet...:)

I think I have found the error (but not checked it yet): In the bilingual file my stupid search/replace also has involved source segments.

But what's strange: I have created a new TM and chosen 'Update Main TM', then I deleted all target contents, I did a pre-translation with all CM 100% segments afterwards, and still the same problem: only a source language export.

I will now delete the project file, re-import it and prepare it again.

I thank you very much for your advices!
Mike


Direct link Reply with quote
 
MikeTrans
Germany
Local time: 17:10
Italian to German
+ ...
TOPIC STARTER
No changes after re-import Dec 3, 2016

Unfortunately, not doing the export to bilingual review or simply re-importing the project file doesn't change anything: still all the exported text is in source language. My understanding of Studio is that unaware of the segment status (translated, draft, approved etc.) it will not have any influence on the export with the condition that there is something in the target segment (otherwise, yes, the source segment will be exported).
I have checked my file in the editor: there are no empty contents and all segments are translated and in German, the export however is in English. Also there are no options to set in the export process. A mystery.

[EDIT]
It seems that Studio 2015, and also Studio 2017 (as in my case) has problems with rtf files. I found this posting:
http://www.proz.com/forum/sdl_trados_support/302228-only_half_of_the_translated_file_was_exported_in_trados_2015.html

I will try the solution there and report. But this has to be fixed !

[ADD]
The solution is: save your original rtf file as docx, import, prepare it in Studio (which will also pre-translate it), check in the Editor that all segments are complete (you should see all 100% CM and no draft segments), then you can export the docx correctly and save it back to rtf (or deliver it as docx).

Mike

[Edited at 2016-12-03 13:24 GMT]

[Edited at 2016-12-03 13:26 GMT]


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio 2017 does not export my file correctly [Workaround found]

Advanced search







Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search