How to shift focus from Termbase Viewer to Editor window?
Thread poster: FinlandFinnish
FinlandFinnish  Identity Verified
Finland
Local time: 16:55
Member (2014)
English to Finnish
+ ...
May 24

When I add new terms to termbase by highlighting target and source terms in SDL Trados Studio 2017 Editor window and pressing Ctrl+F2, the window focus is shifted to Termbase Viewer window. In order to continue translation, I must use mouse to click on the segment in Editor window in order to get back into Editor window and continue translation.

This extra step feels unnecessary and kills productivity and ergonomics.

Is there any non-mouse way to get back to Editor window, or (preferably) not shifting the window focus at all to Termbase Viewer window when adding terms?


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 15:55
Member (2010)
Spanish to English
Quick Add May 24

Use Ctrl+Shift+F2 to "Quick Add New Term" and you won't lose the focus in the Editor.
This only works, of course, if you don't want edit the new term or add more content in termbase fields.


Direct link Reply with quote
 

Stepan Konev  Identity Verified
Russian Federation
Local time: 16:55
English to Russian
No difference May 24

The Term Viewer window opens even with Quick Add New Term.
Furthermore, you need to check the Autohide option to make it close ‘automatically’.
But even with Autohide, it won’t autohide if the mouse cursor is within this window. You need to move the cursor away from the Term Viewer window to hide it.
There is no actual difference between these two shortcuts: with Autohide enabled, Ctrl+F2 shortcut works exactly the same as Ctrl+Shift+F2; with Autohide disabled Ctrl+Shift+F2 works exactly the same as Ctrl+F2; both involve Term Viewer window; both need mouse manipulations.


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 15:55
Member (2010)
Spanish to English
Quick Add Term works for me May 25

Stepan Konev wrote:

with Autohide enabled, Ctrl+F2 shortcut works exactly the same as Ctrl+Shift+F2; with Autohide disabled Ctrl+Shift+F2 works exactly the same as Ctrl+F2; both involve Term Viewer window; both need mouse manipulations.


It doesn't work like that on my machine.
This is what happens, regardless of whether autohide is enabled or disabled:
I highlight the source and target term, click Ctrl+Shift+F2, the term is added to my termbase (and there are a couple of seconds when I can see this happening) and then I continue typing in the target segment. No mouse clicks involved. The focus remains in the active segment.


Direct link Reply with quote
 

Ben Senior  Identity Verified
Germany
Local time: 15:55
German to English
There is a difference May 25

Stepan Konev wrote:
There is no actual difference between these two shortcuts: with Autohide enabled, Ctrl+F2 shortcut works exactly the same as Ctrl+Shift+F2; with Autohide disabled Ctrl+Shift+F2 works exactly the same as Ctrl+F2; both involve Term Viewer window; both need mouse manipulations.


Actually there is a very big difference between Ctrl+F2 and Ctrl+Shift+F2. If you use Ctrl+F2 you need to save the term (click on the little disc at the top of the pane), if you don't the term will not be added to the termbase. Or at least that is my experience. Otherwise I can only concur with Emma, that is exactly how it works for me.

Ben


Direct link Reply with quote
 

Stepan Konev  Identity Verified
Russian Federation
Local time: 16:55
English to Russian
Don't know what to say May 25

Well... when I highlight terms in both parts and use Ctrl+F2 with Autohide enabled, it does not ask me to save anything at all. Once mouse cursor moves behind the Term Viewer limits, it just disappears after 1.5 to 2 seconds and the term becomes highlighted with red line over it.
I did it several times trying to detect any difference between quick and non-quick, but I failed.
I double checked the shortcuts assigned to these commands, but they are definitely different. Besides, Trados would not let me assign same shortcut to different commands.
So, I just don't know what to say. They sold me a defective copy (I am not serious.)
I wonder what the original poster ended up with.

Update: Finally I can see the difference. With Autohide enabled and mouse cursor behind the Term Viewer pane, after pressing Ctrl+F2 one time, the Term Viewer pane disappears without saving. But if you press Ctrl+F2 again, it marks (but still doesn't save) the term with red line as if it was added to termbase.

[Edited at 2017-05-25 16:49 GMT]


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

How to shift focus from Termbase Viewer to Editor window?

Advanced search







Across v6.3
Translation Toolkit and Sales Potential under One Roof

Apart from features that enable you to translate more efficiently, the new Across Translator Edition v6.3 comprises your crossMarket membership. The new online network for Across users assists you in exploring new sales potential and generating revenue.

More info »
BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search