Translation Memory is not updating
Thread poster: Louise TAYLOR

Louise TAYLOR  Identity Verified
France
Local time: 14:45
Member (2015)
French to English
Jun 15, 2017

I am translating a project for a client who I have translated for each year for a number of years. Initially I created a TM with the extension _French to English UK_fr.FR_en-GB.sdltm. This file has worked fine for several years.

This year, for each file, I receive the warning 'No translation memories found to update for the language pair French (France)-English (United Kingdom). This happens if I try to update the main TM or the project TM.

I have tried creating a new TM with the same specifications as the project but this does not update either, the message is the same.

Looking back over my last few projects I can see that none of them have updated the main TM, I must have overlooked the warning. I think this has been happening since the last update.

Can anyone help me with this?


 

Stepan Konev  Identity Verified
Russian Federation
Local time: 16:45
English to Russian
Is the Update option checked? Jun 16, 2017

Hi Louise,
This is quite obvious guess, but I try it anyway: did you make sure that the TM you expect to be updated (or your newly created TM) is checked in the "Update" column in the list of TM's?
With "Update" option unchecked, you can confirm segments without any notification on the go. You may only get to know about it when you try to update your TM from Batch Tasks (ending up with the message you mentioned).


 

Louise TAYLOR  Identity Verified
France
Local time: 14:45
Member (2015)
French to English
TOPIC STARTER
Thank you Jun 17, 2017

Thank you for answering Stepan.
Unfortunately that is one of the things I have already checked.
I have resolved the problem for the short term by creating an AnyTM file and updating that with the previous year's files. Maybe this will have to be my permanent solution.


 

Henry Schroeder  Identity Verified
United States
Local time: 08:45
Member (2002)
German to English
+ ...
This problem has frustrated me for years Mar 22

I even asked about it at the Trados Roadshow in New York last fall.

Then I was still using Studio 2014.

The speaker pretended not to know anything about it, said she came in at 2015, but that, yes, of course, this was no longer an issue with Studio 2017.

Well I'm there now. Studio 2017. Same problem.

It occurs, as far as I can tell, when the subgroup appears under the main TM.

It looks roughly like this:

Master-Finance DE-GB...sdltm
-> Master-Finance DE-GB...sdltm (but this appears in a box with dotted lines)

p6jjsckatwyarqr3jw80.png

Whenever this sub-group appears, your TM is no longer updating. As far as I can tell, this subgroup appears any time a new file is loaded to a set-up project. Effectively making it pointless to set up projects where you can just drag new files into them.

Very disappointing from trados.

Your workaround with AnyTM is interesting.


 

SDL Community  Identity Verified
United Kingdom
Local time: 14:45
English
Looks to me... Mar 22

... as though you are just using Project Tms and are probably looking in the wrong place for your updates.

 

Angela Rimmer  Identity Verified
United Kingdom
Local time: 13:45
Member (2014)
German to English
+ ...
Project TMs... or another bug Mar 22

SDL Community wrote:

... as though you are just using Project Tms and are probably looking in the wrong place for your updates.


Agreed. Those "sub-groups" as you call them are project TMs.

Another problem might be a bug that I discovered a few years ago which is still an issue in Studio 2017: For certain TMs, if they have fields, these fields need to be completed in order to update the TM. Go to Project Settings > Translation Memory > Update and check if there are any fields. If yes, add values to those fields. Then try updating the TM and see if that works.


 

Henry Schroeder  Identity Verified
United States
Local time: 08:45
Member (2002)
German to English
+ ...
There is a flaw in the project feature of Trados Studio Apr 20

My solution above does not work.

I have also given up. In addition to this problem, it is now no longer possible to see the term base entries when working in Studio 2017 (you only see a line indicating that, yes, the word is in the term base, but you have to manually enter it in the field).

It is possible that Angela's solution works for the TM, but there is a much, much, much easier solution - switch to memoQ.

As I am sure you know, realize or wish, the way these projects (in Trados, memoQ, memsource, etc.) are supposed to work is that you set them up, associate a TM and and term base with them and keep loading in one file after another. Not only do you not have to create a new project each time, but you automatically generate a massive TM over the course of time.

Whatever the problem is with Trados Studio 2014 and 2017, this simply does not happen by itself or without the unnecessary alignment of various secondary settings. Somehow or other it must be possible, but it is not simple.

In memoQ it works flawlessly. Even the set-up takes less time, and you can load xliff-files in and update the memory by just pressing "confirm" (in trados you have to change the segment status of each and then click confirm individually on each line). So all those xliff files loaded into a Studio project (see target folder in project) with all those segments that have never been included in your TM can be dragged into your memoQ folder and the TM thus updated very quickly. When you load new files into the project, the settings do not suddenly change (as with Trados Studio) so that you have a subgroup in the TM and no TM updating. It is all as it should be for translators: simply and easy. We are not IT experts, after all.

It has been a good 16 years with Trados.

Good luck!


 

SDL Community  Identity Verified
United Kingdom
Local time: 14:45
English
Just a few things... Apr 20

Henry Schroeder wrote:

I have also given up. In addition to this problem, it is now no longer possible to see the term base entries when working in Studio 2017 (you only see a line indicating that, yes, the word is in the term base, but you have to manually enter it in the field).



Sounds as though you have closed the term recognition window. Click on View -> Reset Window Layout and it's back.

Henry Schroeder wrote:

As I am sure you know, realize or wish, the way these projects (in Trados, memoQ, memsource, etc.) are supposed to work is that you set them up, associate a TM and and term base with them and keep loading in one file after another. Not only do you not have to create a new project each time, but you automatically generate a massive TM over the course of time.



That's the way you choose to work. It's not the way these projects are supposed to work. Many users, probably most I think, create new projects for each job. Simple enough if you use project templates as it only takes a few clicks.

Henry Schroeder wrote:

In memoQ ... you can load xliff-files in and update the memory by just pressing "confirm" (in trados you have to change the segment status of each and then click confirm individually on each line).



No you don't. In Trados you just press confirm exactly the same as you do in memoQ.

Henry Schroeder wrote:

So all those xliff files loaded into a Studio project (see target folder in project) with all those segments that have never been included in your TM can be dragged into your memoQ folder and the TM thus updated very quickly. When you load new files into the project, the settings do not suddenly change (as with Trados Studio) so that you have a subgroup in the TM and no TM updating.



In fact you can run a batch task in Trados and update all the files in your project into your TM in one go... very quickly.

Henry Schroeder wrote:

When you load new files into the project, the settings do not suddenly change (as with Trados Studio) so that you have a subgroup in the TM and no TM updating.



The problem here is not that the settings have changed... they don't just change.. you have created a project with Project Translation Memories and as you don't know how to use them you have become a bit confused. I'm glad you're happier with another tool, but probably not good to try and explain to other users something you don't understand.


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Translation Memory is not updating

Advanced search







Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
SDL Trados Studio 2019 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2019 has evolved to bring translators a brand new experience. Designed with user experience at its core, Studio 2019 transforms how new users get up and running and helps experienced users make the most of the powerful features.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search