Studio 2015 changes fonts and does not display dashes, slashes, quotation marks and the like
Thread poster: Pablo Mones

Pablo Mones  Identity Verified
Uruguay
Local time: 10:53
Member (2008)
English to Spanish
Aug 10

Hi, I have a problem with Studio 2015: it doesn't display neither the original nor the predetermined font, changing it to Courier New and not showung dashes, slashes, quotation marks and the like (see images below with original text and how it appears in Trados).

Original

Trados

I attach images of the problem.

Does anyone know how to solve it? I have already done the following:

Options/Editor/Fonts and changed the default font type to Arial. No changes.

Also tried to do what Lianne van de Ven suggested me when I had the same problem in Studio 2017 (http://www.proz.com/forum/sdl_trados_support/317078-studio_2017_does_not_display_dashes_slashes_quotation_marks_and_the_like.html ), but here this option is not possible.

Thank you in advance for any suggestion

Pablo Mones

[Editado a las 2017-08-11 00:58 GMT]


Direct link Reply with quote
 

Lianne van de Ven  Identity Verified
United States
Local time: 08:53
Member (2008)
English to Dutch
+ ...
Try a different font? Aug 10

Hi Pablo,

The correct link to the previous post is: http://www.proz.com/forum/sdl_trados_support/317078-studio_2017_does_not_display_dashes_slashes_quotation_marks_and_the_like.html
The parenthesis that you had around the link, made it default to the general support forum for trados.

I agree with the suggestion of Epameinondes. I think this function does not work perfect.
When I change the font to courier under alt+F > t > > editor > Font Adaptation for the first language in the dropdown, nothing happens. When I select my target language (for the project that I have open) and change it to courier new (I don't have plain courier, I guess), only the target language in the translation results window changes to courier new. The same applies to other fonts I select, they only show in the TR pane - regardless of the "formatting display style" under editor.

I have customized the fonts in the Translation Results Window (that display differences) to Segoe UI and even then, changing the font as above overrides this while it doesn't do anything for the editor itself. However, I have set the font to Segoe UI semibold for the editor, and that does work. I don't know the details, I have tinkered around with it because I am rather picky about the display, but I never figured out what makes it tick. However, I have never seen missing or odd characters like in your screen shot.

Maybe you have an issue with font mapping: http://producthelp.sdl.com/sdl%20trados%20studio/client_en/Ref/U-Z/Options/File_Types/FM/FM_FM.htm
It could also be a keyboard setting, maybe? A Spanish keyboard?

This is what I can find in the Studio Manual by Matt Dannewitz Linder:
"You can customize the font, including digits, used in the Editor pane (and compared to TagEditor, with its once-and-for-all type size, I find this a real boon).
The quick method for changing both the source and font size simultaneously “one size” at a time is to go to View > the Font Adaptation group. Activate the function by clicking the top symbol (inactive by default; activated it looks like in this pic-ture). Then use the Increase or Decrease button. By clicking the dialog box launcher at the bottom (or by going to File > Options (Alt/F10, F, T) and select Font Adaptation under Editor), you open the following pane:
see image:
https://www.dropbox.com/s/8hhkysjzkh20fso/font-adaptation.png?dl=0

Don’t forget that the text color contrast function may be of great ser-vice when you have text in very light color against a light back-ground. Emma Goldsmith has written a couple of good posts on vari-ous customization topics: Zoom, font and display issues in SDL Tra-dos Studio 2011, and The intricacies of display in SDL Trados Studio 2011.
E.g. https://signsandsymptomsoftranslation.com/2012/09/13/zoom-font-display/
And a good summary of what you can do in the way of adapting the Editor view is provided by Paul Filkin in his blog post Adjusting the view..."

You could also go to the SDL support forums. https://community.sdl.com/

Let us know what you find out!


Direct link Reply with quote
 

Pablo Mones  Identity Verified
Uruguay
Local time: 10:53
Member (2008)
English to Spanish
TOPIC STARTER
It didn't work Aug 11

Hi, Lianne.

Thank you for your answer and all the time you took to write it. I have already corrected the mistake you mention about the hyperlink.

I regret to tell you that I tried everything you told me but the problem is still there. What I noticed is that both now and in my other post, the files were from the same client.

Best regards and, once again, thank you.

Pablo


[Editado a las 2017-08-11 01:00 GMT]


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio 2015 changes fonts and does not display dashes, slashes, quotation marks and the like

Advanced search







BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search