Studio 2017 not inserting best match
Thread poster: Ine Ramaekers

Ine Ramaekers  Identity Verified
Belgium
Local time: 12:01
English to Dutch
+ ...
Aug 15, 2017

Hi all,

I've done a lot of research on this topic, but I still haven't found a solution. The problem is, essentially, that Studio does not overwrite pre-translated segments with best matches while translating. I don't remember ever having this problem before, in the 6-7 years I've been working with Trados, but it's been going on for a while now, I'm guessing probably since I've had my new computer.

I've looked through all the settings, but everything seems in order. Perform lookup/apply best match after lookup are both activated, and yet it will never replace a previous translated segment by a better one, and I just can't figure out why. I have already read that it might not always take the most recent 100% match (why, Trados, why???), but even after removing all other units in the TM that could cause confusion, it still won't replace anything, I always have to manually insert the translation from the TM.

Anyone else have this problem or better yet, a solution?


 

Andrey Vinokurov
Russian Federation
Local time: 13:01
English to Russian
I think Studio never overwrite pre-translated or somehow 'touched' strings Aug 15, 2017

Probably the workaround is to pre-translate the file (again), but I did not test it.

 

Stepan Konev  Identity Verified
Russian Federation
Local time: 13:01
English to Russian
When pretranslating a file,... Aug 16, 2017

...Trados inserts matches that are already the best available as of that moment.

Most probably, you mean that Trados does not overwrite the same pre-translated segemnets that you once amended in the course of your work.

I assume that you amend a pre-translated segment, then you see exactly the same instance of a segment you already amended, but it looks as before your amendments. Right?
If this assumption is right (and I cannot imagine a situation when a better translation appears otherwise than that), then you need to tick these boxes:
File - Options - Editor - Auto-propagation - Auto-propagate exact matches to confirmed segments AND
Confirm segment after auto-propogating an exact match.

They are not checked by default.

Another observation that came to my mind is that previous upgrades of Trados did not reset your current settings (by overwriting the Default profile). I mean that you could check those boxes in 2009 and then Trados just kept previous settings after each next upgrade to 2011, then to 2014, then to 2015. On the other hand, 2017 upgrade resets you settings to default (overwrites the Default profile). That is why you experience it in a new way in comparison with last 6 to 7 years.
But this is just my wild guess...

[Edited at 2017-08-16 01:45 GMT]


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio 2017 not inserting best match

Advanced search







SDL Trados Studio 2019 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2019 has evolved to bring translators a brand new experience. Designed with user experience at its core, Studio 2019 transforms how new users get up and running, helps experienced users make the most of the powerful features, ensures new

More info »
CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search