How do I stop Trados Studio from inserting a space before a %?
Thread poster: asr2
asr2

Local time: 22:08
Sep 25

Trados Studio always changes, for example, 5% to 5 %. How can I stop Studio from doing this?

Direct link Reply with quote
 

Heinrich Pesch  Identity Verified
Finland
Local time: 23:08
Member (2003)
Finnish to German
+ ...
That is right Sep 25

There must always be a space before a unit symbol. 15% is a unity in itself and cannot be dealt with as a placeable. But 15 % is a number with a unit. So if the next time the same translation unit comes up but with 28 % the software will understand it and fill in the new number but not change the unit.

Direct link Reply with quote
 

Silke Walter  Identity Verified
Germany
Local time: 22:08
Member (2014)
English to German
Change Settings Sep 25

In German there has to be a space before ‚%‘. But if you want to change it in Studio, you could go to the project settings, click on ‚check wordlist‘ (or something like that, I use a German interface) in the ‚QA checker 3.0‘ under the quality check. Then add the % sign with the space as wrong expression, without as correct expression. Then it is changed when you run the quality check in Studio at the latest.

Settings


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 22:08
English
Use the project settings... Sep 25

asr2 wrote:

Trados Studio always changes, for example, 5% to 5 %. How can I stop Studio from doing this?


... to tell Studio to handle the numbers as you wish.

Project Settings -> Language Pairs -> EN - DE -> Translation Memory & Automated Translation -> Auto-Substitution -> Measurements -> Choose the option you need.

These dictate how the space is handled. The QA settings will tell you when it's wrong so you can correct it, but changing it in the project settings means you shouldn't have to correct anything.

Regards

Paul
Why not try the new SDL Community


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 22:08
English
Incorrect Sep 25

Heinrich Pesch wrote:

There must always be a space before a unit symbol. 15% is a unity in itself and cannot be dealt with as a placeable. But 15 % is a number with a unit. So if the next time the same translation unit comes up but with 28 % the software will understand it and fill in the new number but not change the unit.


15% can be handled as a placeable exactly as 15 % can be. How the placeable is formed depends on your project settings.

Regards

Paul
Why not try the new SDL Community


Direct link Reply with quote
 

Erik Freitag  Identity Verified
Germany
Local time: 22:08
Member (2006)
Dutch to German
+ ...
Except... Sep 25

SDL Community wrote:

The QA settings will tell you when it's wrong so you can correct it, but changing it in the project settings means you shouldn't have to correct anything.


Except in the cases where Studio gets it wrong (at least for my target language, German) no matter what the settings, for example currency symbols, calendar dates, or units of measurement other than the most basic ones.

Yes, I know, it's probably all Windows' fault somehow...


Direct link Reply with quote
 
asr2

Local time: 22:08
TOPIC STARTER
Only % should be handled separately Sep 26

But I want still want "true" numbers to be converted, for example, 1.23 (EN) -> 1,23 (DE). I just want Studio 2017 from automatically adding a space. Is this a new "functionality" with 2017, previously this was no problem.

Direct link Reply with quote
 

Roy Oestensen  Identity Verified
Norway
Local time: 22:08
Member (2010)
English to Norwegian (Bokmal)
+ ...
Changing project settings: Must this be done for each and every project? Sep 26

SDL Community wrote:
asr2 wrote:

Trados Studio always changes, for example, 5% to 5 %. How can I stop Studio from doing this?


... to tell Studio to handle the numbers as you wish.
Project Settings -> Language Pairs -> EN - DE -> Translation Memory & Automated Translation -> Auto-Substitution -> Measurements -> Choose the option you need.


I have the same problem, except the other way around: 5 % is changed to 5% in propagated segments. I would have a global change for EN -> NO rather than having to do this change on a project basis, which seems a nuiscance.

Roy


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 22:08
English
Set up your general options Sep 26

Roy Oestensen wrote:

I have the same problem, except the other way around: 5 % is changed to 5% in propagated segments. I would have a global change for EN -> NO rather than having to do this change on a project basis, which seems a nuiscance.

Roy


If you set up your Project Templates or your File -> Options then you won't have to do this on a project by project basis.

Regards

Paul
Why not try the new SDL Community


Direct link Reply with quote
 

Angela Rimmer  Identity Verified
United Kingdom
Local time: 21:08
Member (2014)
German to English
+ ...
Changing per project vs global settings Sep 26

Roy Oestensen wrote:

SDL Community wrote:
asr2 wrote:

Trados Studio always changes, for example, 5% to 5 %. How can I stop Studio from doing this?


... to tell Studio to handle the numbers as you wish.
Project Settings -> Language Pairs -> EN - DE -> Translation Memory & Automated Translation -> Auto-Substitution -> Measurements -> Choose the option you need.


I have the same problem, except the other way around: 5 % is changed to 5% in propagated segments. I would have a global change for EN -> NO rather than having to do this change on a project basis, which seems a nuiscance.

Roy


You will have to change the settings every time if you are receiving packages from your clients -- the project settings will be configured as the creator has them defined. But for your own projects, changing your general settings will fix this.


Direct link Reply with quote
 

Silke Walter  Identity Verified
Germany
Local time: 22:08
Member (2014)
English to German
Thank you, Angela. Sep 26

This had been the reason for my suggestion. I am using it this way as a reliable workaround.

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

How do I stop Trados Studio from inserting a space before a %?

Advanced search







TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search