TM units don't seem to be updated instantly
Thread poster: Ignacio Costa

Ignacio Costa  Identity Verified
Brazil
Local time: 00:21
Member (2016)
English to Portuguese
+ ...
Mar 12

Hi folks!

First of all, sorry if this's been already discussed somewhere else. I've tried to google it and didn't find a direct answer for my issue.

I'm using Trados Studio 2017 and it’s been some months since I noticed that TM units aren’t being updated instantly.
E.g.: Let’s say I'm translating a string, and the next one would be a 90% match with that string. As I confirm the first one and go to the next, my “Translation result” window doesn't return that very previous string as a fuzzy match.
On the other hand, I can still find that on the concordance search!
Also, I've noticed that, after just a couple of minutes, that string is finally added to the TM and can be shown in further fuzzy match results.
It's puzzling me, as I don't know if this 'delay' is a real bug or something I may have set up in error.
Does anybody have a similar problem and (hopefully) know what is happening?
This apparently silly bug may be very time-consuming when we have a long list of similar strings, as we can't benefit from the best fuzzy match that we should have in our TM (i.e., the one we've just added!).

Thank you!

Ignacio


 

MikeTrans
Germany
Local time: 05:21
Italian to German
+ ...
It depends on your Fuzzy Match settings... Mar 15

First, check wether all necessary checkboxes are enabled in your Project Options for the TM: Enabled_Lookup_Concordance_Update; if the second and/or the last one is deactivated you will never see any matches proposed from new translations, but you get results when hitting Concordance searches.
Then, you have to check the Options or Project Options and look in the 'Search' settings for your language pair. Here the fuzzy match settings must be small enough in order to return a fuzzy match; if it's set to 70 (default) or higher you will hardly ever see any fuzzy match, especially with longer sentences.
You can also set the Concordance settings as low as 30% for a lot of returns, also automatic ones, and finally, be sure you have the Fragment Search and upLIFT function enabled which really helps (but for that you need to have 1000 TUs or more in your TM).

Cheers,

[Edited at 2018-03-15 04:36 GMT]


 

Ignacio Costa  Identity Verified
Brazil
Local time: 00:21
Member (2016)
English to Portuguese
+ ...
TOPIC STARTER
Thanks, but my problem remains. Mar 17

Hey Mike.

Thanks a lot for your answer.

These all make sense, but my problem seems to be a bit different:
The translation units are, eventually, added to the TM and recognized as fuzzy matches by Studio. The point is this is not instantaneous.
An example: let's say I translate "I have three eggs", and the very next line would be "I have four eggs" or "You have three eggs". I'd expect that Studio would suggest me as a fuzzy match that line I just translated, with 90% of similarity or so. However, it simply doesn't appear, and sth way less similar is suggested from my TM (illustrating again, sth like “I have done that”, with 60 or 50% of similarity).
However, following that same example, if the line "I have four eggs" shows up like 5 minutes later, then the TM will successfully find its fuzzy match and suggest it.
Do you see the point? All settings do seem to be enabled and working. It's just a matter of time. So, I was wondering if this is a “known delay” or if there's anything else I could still set to solve that.
My feeling is that it hasn’t always been like that with previous versions. I don’t know if this is a general problem with Studio 2017 or sth related to any new feature (like Fragment Matching, which I do use).

Thank you!


 

MikeTrans
Germany
Local time: 05:21
Italian to German
+ ...
Very strange... Mar 18

Ignacio,
yes I see your problem now, i.e. the time delay until your matches are considered. That's very strange: In the latest version of Trados 2017 (SR1) there is what is called a 'Look ahead' function that should even *speed up* searches and match displays. From your description it seems that there is a problem with this new feature because I never heard a similar problem before in past versions (I have a decent knowledge about past Studio versions, but I'm not too familiar with the newest version yet).

I've been working recently with Trados 2017 SR1, but I don't use Project TMs, I create a working TM from scratch and load it to update, plus I load my main TM in second position in read-only and update it when my work is finished. Doing so I'm not experiencing this problem, I get all fuzzy matches immediately (set to 60%), and your given examples would appear immediately on my system, I'm sure. No idea why it happens to you. I hope you'll get other feedbacks!

Not using a project TM could be a workaround for you in the meantime, until someone comes with a better help suggestion or solution.
It would be helpful if SDL could feedback here if there is a known problem with the software.

[Edited at 2018-03-18 01:39 GMT]


 

Ignacio Costa  Identity Verified
Brazil
Local time: 00:21
Member (2016)
English to Portuguese
+ ...
TOPIC STARTER
Nice tip. Tks! Mar 18

Hi Mike.

I've just confirmed and I'm also using Studio 2017 SR1 (I wasn't quite sure if it had been updated to SR1 these last days, but it had).

To be honest, I think it's been some months since this is happening here. I'm recalling now that I even thought this could be a performance issue from my PC (wondering if it wasn't processing data fast enough). Then, in December, I replaced my HDD for a SSD and was hoping this could solve that.

Well, the PC is now 10x faster (including Trados, overall), but this problem is still there.
All this to say that the problem is here, at least, since late last year.

Your approach creating new TMs and post-upgrading them to a general TM seems very good! I'll surely try that.

Thanks again and I hope someone from SDL could try to figure out that problem after all.

Best regards and enjoy your Sunday,

Ignacio


 

LegalTransform  Identity Verified
United States
Local time: 23:21
Member (2002)
Spanish to English
+ ...
Trados Mar 19

Have you tried, FILE (at the top), then OPTIONS, then EDITOR, then AUTO PROPAGATION, then Enable Auto Propagation (don't forget to set the Prompt User options accordingly).

[Edited at 2018-03-19 17:59 GMT]


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

TM units don't seem to be updated instantly

Advanced search







Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »
CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search