How to use Auto Text in Trados 2014
Thread poster: MollyRose

MollyRose  Identity Verified
United States
Local time: 20:10
Member (2010)
English to Spanish
+ ...
Aug 31, 2018

I have the professional version, so it isn't due to a licensing problem.

I created a couple Auto Texts under Auto Suggestion. They are under Options/Editor/Auto Suggest/Auto Text. I have the same target language selected as used in my projects (Spanish Mexico) and termbase. There isn't a "plain" Spanish on the dropdown list.

I created them because they will never show up in the source, and I was excited because I thought I would never have to type all those words aga
... See more
I have the professional version, so it isn't due to a licensing problem.

I created a couple Auto Texts under Auto Suggestion. They are under Options/Editor/Auto Suggest/Auto Text. I have the same target language selected as used in my projects (Spanish Mexico) and termbase. There isn't a "plain" Spanish on the dropdown list.

I created them because they will never show up in the source, and I was excited because I thought I would never have to type all those words again. (What a disappointment--I still have to do it.) One of the auto texts is: (por sus iniciales en inglés), except I didn't include the parentheses, in case that wouldn't work--they don't with the term base.

Why doesn't the auto suggest come up after I type the first 4 letters? I end up having to type the whole thing every time.

Thank you in advance, whoever helps!


[Edited at 2018-08-31 22:19 GMT]
Collapse


 

Stepan Konev  Identity Verified
Russian Federation
Local time: 05:10
English to Russian
'por' is only 3 letters Sep 1, 2018

In your example, the first word is por. It is not long enough for Trados Auto Text.
Space char resets letter counting to 0: por sus iniciales en inglés = 123_123_123456789... So, if you try with 'iniciales en inglés', you will succeed.

An optimum procedure would be as follows:
1. Select a word longer than 4 letters (adding 4-letter words is possible but totally meaningless) or a phrase starting with a word equal to or longer than 4 letters in target.
2. P
... See more
In your example, the first word is por. It is not long enough for Trados Auto Text.
Space char resets letter counting to 0: por sus iniciales en inglés = 123_123_123456789... So, if you try with 'iniciales en inglés', you will succeed.

An optimum procedure would be as follows:
1. Select a word longer than 4 letters (adding 4-letter words is possible but totally meaningless) or a phrase starting with a word equal to or longer than 4 letters in target.
2. Press Alt+F7 => Enter => Enter

If this word or phrase is not available from other autosuggest sources, you will see a suggestion with keyboard icon after typing 4 letters.

[Edited at 2018-09-01 09:23 GMT]
Collapse


 

MollyRose  Identity Verified
United States
Local time: 20:10
Member (2010)
English to Spanish
+ ...
TOPIC STARTER
Thanks, Stepan Sep 4, 2018

With a term from termbase, a space works, but I see it doesn't with autotext. I changed "por" to "pori" and it works. I just have to remove the "i" every time. But at least I don't have to type the whole phrase each time! Thank you.

If it gets too annoying to remove the "i," then I will just type the "por sus" every time and start the autotext with "iniciales" as you suggested.

[Edited at 2018-09-04 15:15 GMT]


 

Stepan Konev  Identity Verified
Russian Federation
Local time: 05:10
English to Russian
Minor addition Sep 5, 2018

MollyRose wrote:
If it gets too annoying to remove the "i,"


Actually, there is another autosuggestion mechanism called AutoCorrect. It's a bit awkward because of complicated access to the feature – you have to go to File-Options-Editor-AutoCorrect each time you want to add an entry. SDL programmers believe this feature is so useless and vain that you don't even need a shortcut for that.
Besides, you have to keep all your autocorrect entries in mind, which limits the use of this feature (but this time it depends on you, not SDL).

So...
In AutoCorrect window, you can add a pair like this:
Replace: abbr (pori in your case)
With: expanded abbreviation (por sus iniciales en inglés in your case)
Don't forget to press 'Add'. Otherwise your pair won't be saved.
Now each time you type 'abbr' (pori) and space, it will convert to 'expanded abbreviation' (por sus iniciales en inglés) regardless of the number of letters.

In your case, you may use 'pors' or 'pori' or anything else that you can remember and that slightly differs from the regular word 'por'. This is needed because if you select 'por' as a short form for your longer phrase, all regular 'por's will be processed this way.


[Edited at 2018-09-05 05:58 GMT]


 

Ekaterina Kroumova  Identity Verified
French to Bulgarian
+ ...
There is even a simpler solution Sep 5, 2018

There's even a simpler solution, al least for me. I just add the pair expression to my default termbase. Very useful for longer and recurring phrases, even if they are not really terminology.

Stepan Konev
 

NeoAtlas
Spain
Local time: 03:10
English to Spanish
+ ...
Check Autotext in AutoSuggest options Sep 5, 2018

Check that Autotext checkbox is ticked in Options > AutoSuggest.
Also, although you already mentioned it, double check that the AutoText entries are entered in the TARGET language of your project.
Otherwise AutoText entries will never come up after typing the 4 first letters.
Good luck!
… Jesús Prieto …


 

MollyRose  Identity Verified
United States
Local time: 20:10
Member (2010)
English to Spanish
+ ...
TOPIC STARTER
Autocorrect! Sep 5, 2018

Thanks again, Stepan. I'm not sure I was aware that this existed in Trados, but I do use it a little in MS Word. For instance, when I type mnx, it automatically replaces it with my translation of the whole, long name of the school district where I work! It's great!

At your suggestion, I was going to put the whole parenthetical phrases in auto correct, with pori and pors. But before clicking "Post reply," I went to Trados to see if I could do it. Unfortunately there is no Autoco
... See more
Thanks again, Stepan. I'm not sure I was aware that this existed in Trados, but I do use it a little in MS Word. For instance, when I type mnx, it automatically replaces it with my translation of the whole, long name of the school district where I work! It's great!

At your suggestion, I was going to put the whole parenthetical phrases in auto correct, with pori and pors. But before clicking "Post reply," I went to Trados to see if I could do it. Unfortunately there is no Autocorrect under Flie/Options/Editor in my 2014 version. Is it available in a later version?
Collapse


 

Ekaterina Kroumova  Identity Verified
French to Bulgarian
+ ...
Unfortunately not Sep 5, 2018

MollyRose wrote:

Unfortunately there is no Autocorrect under Flie/Options/Editor in my 2014 version. Is it available in a later version?


It was rolled out in Studio 2015.


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

How to use Auto Text in Trados 2014

Advanced search







Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »
Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search