Trados 7 has bugs and the knowledge base is useless!
Thread poster: Marinus Vesseur

Marinus Vesseur  Identity Verified
Canada
Local time: 10:25
English to Dutch
+ ...
Jun 23, 2005

Yes, it's me again, I seem to have a curious gift of stumbling upon program bugs. It happens especially when working with Microsoft Office or with Trados. The epitomy of bugbothering is reached when both run simultaneously.

Anyway, I thought I'd try two 'new' things (new to me anyway) this morning:
'non-translatable paragraphs' in the 'settings' menu of workbench. It should allow you to determine what paragraphs Trados should skip. Supposedly you can import certain styles to be skipped by clicking op 'Open Document'. Only that Workbench crashes if you do. So I tried to find something about it in the online knowledge base, typed in 'open document' and got this reply:
UNFORTUNATELY NO ARTICLE FOUND

Okay, I thought, typically me to stumble on a Trados 7 bug on day 1 after installation.

A little later I thought I'd try using MutiTerm, so much improved now, they say.
I arranged for a new termbase, marked a word in the original text in my Word document, clicked on 'add entry' in the MultiTerm menu entered the translation and clicked on 'add entry'. Presto: error message. It says something about the INSERT INTO command containing the wrong field name called 'topterm'. I had not typed in 'topterm', I know it!
You know what I did next? Yep, the online knowledge base. I searched for 'insert into' and 'add entry'. You know what the 'knowledge base' told me?
Right:
UNFORTUNATELY NO ARTICLE FOUND

Obviously Trados 7 was released prematurely for reasons I can only speculate about. Something to do with the takeover by SDLX? Other marketing strategies. This thing is half baked. Mind you, I'll find my workarounds again, as I've done before or I'll just write off some functions as they do more harm than good. The knowledge base should be renamed in IGNORANCE BASE.

From a frustrated Trados user.

Kind regards, Marinus


Direct link Reply with quote
 

Ralf Lemster  Identity Verified
Germany
Local time: 19:25
English to German
+ ...
More detailed info...? Jun 23, 2005

Hi Marinus,
Hope you don't mind if I just focus on the facts...

Anyway, I thought I'd try two 'new' things (new to me anyway) this morning:
'non-translatable paragraphs' in the 'settings' menu of workbench.

Not a new function - this has been part of Workbench at least since T5.x, most likely even earlier.

It should allow you to determine what paragraphs Trados should skip. Supposedly you can import certain styles to be skipped by clicking op 'Open Document'. Only that Workbench crashes if you do.

Works without problems on my system.
What exactly happens (error message, other notable behaviour, etc.)? Is there anything specific about the document you're trying to open? (Extracting the styles (not paragraphs) from the target document requires a conversion to RTF - could you try to save the chosen document to RTF in Word (if that gets you an error message, you've found the source of the problem).
Does this behaviour occur with other Word documents?

So I tried to find something about it in the online knowledge base, typed in 'open document' and got this reply:
UNFORTUNATELY NO ARTICLE FOUND

No surprise - try searching the ProZ.com FAQ for Post Reply (that's also a button label...). The process is described in KB article 456 (which you can find by searching for "non-translatable"); to be more specific about the problem, I would need to know more.

A little later I thought I'd try using MutiTerm, so much improved now, they say.
I arranged for a new termbase,

What does that mean? Did you establish a link to an existing termbase in Word? (Note that the Word/MultiTerm interface is independent from the MT application - IOW MT doesn't need to run for the interface to work; OTOH the fact that MT is running doesn't mean the interface has been established.)

marked a word in the original text in my Word document, clicked on 'add entry' in the MultiTerm menu entered the translation and clicked on 'add entry'. Presto: error message. It says something about the INSERT INTO command containing the wrong field name called 'topterm'.

What exactly does it say? Can you please quote the full and precise error message given?

You know what I did next? Yep, the online knowledge base. I searched for 'insert into' and 'add entry'. You know what the 'knowledge base' told me?
Right:
UNFORTUNATELY NO ARTICLE FOUND

How about searching for the error number and/or key words in the error message?

Best regards,
Ralf


Direct link Reply with quote
 

Nicole Maina  Identity Verified
Italy
Local time: 19:25
Member (2005)
German to Italian
+ ...
how to mark non translatable paragraphs Jun 23, 2005

[quote]Ralf Lemster wrote:

Hi Marinus,
Hope you don't mind if I just focus on the facts...

Anyway, I thought I'd try two 'new' things (new to me anyway) this morning:
'non-translatable paragraphs' in the 'settings' menu of workbench.

Not a new function - this has been part of Workbench at least since T5.x, most likely even earlier.

hi ralf,

I know this thread is about something else, but I have been trying to find out how this feature works for ages!! could you please give me some more details?

settings>non-translatable paragraphs>open document
then the style names appear. I choose the one I do not want to be processed by trados, and click on add. then I save, but when I try to open the document and translate it, trados opens all paragraphs, without caring about the style at all!

how does this works? sorry...
nicole


Direct link Reply with quote
 

Ralf Lemster  Identity Verified
Germany
Local time: 19:25
English to German
+ ...
Known issue Jun 24, 2005

Hi again, Marinus,
Unfortunately, you didn't respond to my questions - some info might have helped.

Anyway, I got some feedback from Trados Support:
- The problem opening .doc files to select non-translatable paragraphs is confirmed as such; opening RTF files should work, though.

- Regarding the MultiTerm error message, did you convert your termbases to version 7 (this is necessary given different terminology handling in T7)?

...and regading Nicole:
settings>non-translatable paragraphs>open document
then the style names appear. I choose the one I do not want to be processed by trados, and click on add.

The Add button is used to enter a style manually - to choose one from the list, you need to use Copy instead.

HTH, Ralf


Direct link Reply with quote
 

Marinus Vesseur  Identity Verified
Canada
Local time: 10:25
English to Dutch
+ ...
TOPIC STARTER
Finding the workarounds Jun 24, 2005

Ralf Lemster wrote:
Extracting the styles (not paragraphs) from the target document requires a conversion to RTF - could you try to save the chosen document to RTF in Word (if that gets you an error message, you've found the source of the problem).

Thank you Ralf, for your patience. I'm actually quite glad I can unload my frustration here sometimes and still get a decent answer.
I haven't tried conversion to RTF, I could do that, though I've burnt my fingers on the RTF-filter in Word before, too.

A little later I thought I'd try using MutiTerm, so much improved now, they say.
I arranged for a new termbase,

What does that mean? Did you establish a link to an existing termbase in Word?
Well, the funny thing is that it worked once or twice, so obviously there was a link. But then the error message (don't know exact wording, since I use the German interface) 'the INSERT INTO command (Anweisung) contains the following unknown field name: 'topterm'. Make sure you have entered the name correctly, etc...' [/quote]

You know what I did next? Yep, the online knowledge base. I searched for 'insert into' and 'add entry'. You know what the 'knowledge base' told me?
Right: UNFORTUNATELY NO ARTICLE FOUND

How about searching for the error number and/or key words in the error message?
I installed the German Trados user interface; I don't expect the Knowledge base to contain German error messages and I'm not sure what the English wording would be. Still, I'll try to do it, next time.

I had forgotten another error message that appears when I try to open projects I had started in MultiTermX:

The Microsoft Jet database module cannot find the entry table 'mtIndexes'.... While we're at it, maybe that rings a bell to you.

Your help is much appreciated.


Direct link Reply with quote
 

Marinus Vesseur  Identity Verified
Canada
Local time: 10:25
English to Dutch
+ ...
TOPIC STARTER
Termbase conversion Jun 24, 2005

Ralf Lemster wrote:

- Regarding the MultiTerm error message, did you convert your termbases to version 7 (this is necessary given different terminology handling in T7)?


Ah, I see now that you had already responded again. Sorry, missed that. I was so busy hacking my computer to pieces yesterday I couldn't immediately reply to your first response

So I have to convert my termbases to version 7. That worries me. What if something goes wrong THERE? Gotta make backups before I do that. I could check how to do the conversion but perhaps you don't mind telling me here and someone else may be benefitted, too.

Thanks a million!

-Marinus


Direct link Reply with quote
 

Nicole Maina  Identity Verified
Italy
Local time: 19:25
Member (2005)
German to Italian
+ ...
it is not working.. Jun 24, 2005

Ralf Lemster wrote:

...and regading Nicole:
settings>non-translatable paragraphs>open document
then the style names appear. I choose the one I do not want to be processed by trados, and click on add.

The Add button is used to enter a style manually - to choose one from the list, you need to use Copy instead.

HTH, Ralf


sorry ralf, my question was not very clear and there was a mistake. of course I meant clicking copy, but then I don't know how to go on after clicking "save". is trados now supposed to skip all "headers" he finds in any document I open? right now this is not happening. when I open the document I have used to copy the styles, trados opens all paragraphs, as usual, without skipping anything. what should I do?
thank you for your help
nicole


Direct link Reply with quote
 

Ralf Lemster  Identity Verified
Germany
Local time: 19:25
English to German
+ ...
Frustration buffer... *g* Jun 24, 2005

Marinus Vesseur wrote:
I'm actually quite glad I can unload my frustration here sometimes and still get a decent answer.



So I have to convert my termbases to version 7. That worries me. What if something goes wrong THERE? Gotta make backups before I do that. I could check how to do the conversion but perhaps you don't mind telling me here and someone else may be benefitted, too.

I would strongly recommend taking backup copies (plus database exports) whenever you convert databases (TMs or termbases).

I'm afraid I cannot give you hands-on experience on conversion to T7, as I currently have no time for that...
AFAIK Trados are in the process of writing a KB article on the conversion routine - you may want to check a readme file (if any) in the installation pack, and/or the Help function.

Best regards,
Ralf


Direct link Reply with quote
 

Ralf Lemster  Identity Verified
Germany
Local time: 19:25
English to German
+ ...
Sorry... Jun 24, 2005

Hi Nicole,
sorry ralf, my question was not very clear and there was a mistake. of course I meant clicking copy, but then I don't know how to go on after clicking "save". is trados now supposed to skip all "headers" he finds in any document I open? right now this is not happening. when I open the document I have used to copy the styles, trados opens all paragraphs, as usual, without skipping anything. what should I do?

This is one of those cases where one would need to check the files (and templates) involved; there could be manifold reasons for this behaviour. Just tested the function myself last night (6.5.5.441) - no problem at all.

Sorry!
Best regards,
Ralf


Direct link Reply with quote
 

Ralf Lemster  Identity Verified
Germany
Local time: 19:25
English to German
+ ...
KB Article Jun 24, 2005

Hi again,
The conversion process to MT7 Desktop is described in KB Article 1535. Hope this helps.

Best, Ralf


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados 7 has bugs and the knowledge base is useless!

Advanced search







TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search