XML internal tag problem + PCDATA?
Thread poster: JarnoHakulinen

JarnoHakulinen
Local time: 19:22
English
Aug 16, 2005

I'm using Trados 5.0.1.217.

I'm trying to create a functioning .ini file for our firm's xml translation needs. I have the dtd file.

I tried to create the .ini file with the dtd settings wizard. It did not recognise most of the tags, so I added them manually.

All external tags come out nice in TagEditor, but I have a problem with the internal tags. Our firm's dtd has a set of internal elements, which all are labeled under (emphasize). The following could be a piece of the code:

(para)This is (emphasize)(bold)the best(/bold)(/emphasize) firm in the world.

Now, TagEditor does not show the (emphasize) and (bold) as tags, but as translatable text. I need to get all the (emphasize) tags (there are several others, as well) to show as internal tags. Can you help me?


Another problem. I do not know much about xml, but our firm's xml chief says that, for example, all (para) tags should be PCDATA. The dtd settings wizard only states as options None, CDATA, RCDATA, and EMPTY. Is this relevant?

(The angled brackets of the xml code are replaced with rounded ones)


[Edited at 2005-08-16 11:04]

[Edited at 2005-08-16 11:06]

[Edited at 2005-08-16 11:11]

[Edited at 2005-08-16 11:13]


 

Ralf Lemster  Identity Verified
Germany
Local time: 18:22
English to German
+ ...
Code is not visible as plain text in the forum Aug 16, 2005

Hi Jarno,
You will notice that the code you quoted is not shown; the forum software interprets this code as a command (albeit an invalid one).

You may want to try using the "Code" tags as explained in the Forum FAQ.

Best regards,
Ralf


 

JarnoHakulinen
Local time: 19:22
English
TOPIC STARTER
Code tags not working Aug 16, 2005

I tried to add the CODE tags, but they do not seem to help.

Is there a way to include tag markers in the post so that they will show?


 

Ralf Lemster  Identity Verified
Germany
Local time: 18:22
English to German
+ ...
Replace pointed brackets... Aug 16, 2005

JarnoHakulinen wrote:

I tried to add the CODE tags, but they do not seem to help.

Is there a way to include tag markers in the post so that they will show?


...with round ones.

HTH, Ralf


 

JarnoHakulinen
Local time: 19:22
English
TOPIC STARTER
Now it works Aug 16, 2005

Thanks Ralf!

Now I have fixed the post so that the xml code is in rounded brackets. ()

I hope that someone can help me.


 

JarnoHakulinen
Local time: 19:22
English
TOPIC STARTER
Problem is in internal tags Aug 22, 2005

I have now experimented a bit more with the ini file and the xml.

I removed the (emphasize) tags from the xml file and the ini. Now, as far as I understand, it should work. But TagEditor still does not show the internal tags (bold), (italics), etc. correctly. If I mark them as "group", everything inside these tags shows as non-translatable, so Trados surely understands them as tags.

But it does not show them as internal tags if I mark them as internal tags. Where could the problem be?


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

XML internal tag problem + PCDATA?

Advanced search







SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »
SDL Trados Studio 2017 only €435 / $519
Get the cheapest prices for SDL Trados Studio 2017 on ProZ.com

Join this translator’s group buy brought to you by ProZ.com and buy SDL Trados Studio 2017 Freelance for only €435 / $519 / £345 / ¥63000 You will also receive FREE access to Studio 2019 when released.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search