Trados 7 changing formatting
Thread poster: Burrell

Burrell  Identity Verified
United Kingdom
Local time: 03:09
Member (2004)
English to Latvian
+ ...
Oct 15, 2005

I do not even know how to describe what is going on. It might be a longish explanation.
I have a big bilingual Word document. There is a text in English formatted as DoNotTranslate part and then the same text follows in the same English but that is formatted as DoTtanslate. The file is translated and now I have to proofread it. Except that somewhere along the line odd segments, after they are closed, suddenly become DoNotTranslate segments and loose all the Latvian special characters that were there turning into gibberish. The only way to fix them is to open the same segment again, change the formatting to DoTranslate, change manually all the gibberish letters to normal letters. In the meantime I cannot see the segments in Workbench as it shows that all the text (target and source) is external text (I have not figured out the implications of that yet but they cannot be good). Then I close the segment, open again and the segment text appears again in WB.
Now, the document is very big. If I keep opening every segment three times and rewrite separate letters, I might work on it till the second coming. So I am starting to pull my hair out in exasperation. Any ideas, suggestions, swear words for Trados? SOS

Cheers,
Burrell


Direct link Reply with quote
 

Heike Behl, Ph.D.  Identity Verified
United States
Local time: 19:09
Member (2003)
English to German
+ ...
TagEditor Oct 15, 2005

Did you use the TagEditor for the translation?

The changed format problem when using Trados to translate in Word is well known.
In Trados 7, you can use TE to translate Word files. All formatting is shown as mostly external tags you can ignore or as internal tags, which you have to copy in the correct place in your target sentence. But you should not have to worry about formatting issues any more.


-- Well, having said that, we all know Trados. Something or other is bound to come up...

[Edited at 2005-10-15 17:04]


Direct link Reply with quote
 

Burrell  Identity Verified
United Kingdom
Local time: 03:09
Member (2004)
English to Latvian
+ ...
TOPIC STARTER
Problems with TE as well Oct 15, 2005

When I realised I am having problems with formatting, the first thing I tried is switching to Tag Editor. However it said it cannot open the file as it is saved as a bilingual file (Exact wording: This file cannot be processed as TTX because it was saved as a bilingual document in Word). As I have no idea what that means and what I should be doing, I did not pursue this method.

Maybe somebody can advice me on this bilingual issue.


Direct link Reply with quote
 

Heike Behl, Ph.D.  Identity Verified
United States
Local time: 19:09
Member (2003)
English to German
+ ...
Which file did you try to open? Oct 15, 2005

Burrell wrote:

When I realised I am having problems with formatting, the first thing I tried is switching to Tag Editor. However it said it cannot open the file as it is saved as a bilingual file (Exact wording: This file cannot be processed as TTX because it was saved as a bilingual document in Word). As I have no idea what that means and what I should be doing, I did not pursue this method.

Maybe somebody can advice me on this bilingual issue.


Did you try to open the original untranslated English file in TE and re-translated it with Translate to Fuzzy when you got the error message?

If you tried to open the uncleaned already translated file, I would expect some error message. "Bilingual" in Trados usually refers to a text that contains both source and target units.


Direct link Reply with quote
 

Burrell  Identity Verified
United Kingdom
Local time: 03:09
Member (2004)
English to Latvian
+ ...
TOPIC STARTER
Just tried Oct 15, 2005

And did no succeed. TE opened the file succesfully but appart from Open, Open/Get and Open next no 100%/get there are no options. I cannot translate it to fuzzy, the option is not activated.

Direct link Reply with quote
 

Heike Behl, Ph.D.  Identity Verified
United States
Local time: 19:09
Member (2003)
English to German
+ ...
Does the tm work at all? Oct 15, 2005

Burrell wrote:

And did no succeed. TE opened the file succesfully but appart from Open, Open/Get and Open next no 100%/get there are no options. I cannot translate it to fuzzy, the option is not activated.


Do at least the previously translated sentences show up? They might not be 100% matches since there might be internal tags that were hidden in Word.

What happens if you open the first segment? The Translate to fuzzy option is only available when you've opened a segment. At this point, the options Open, Open/Get and Open next no 100%/get are grayed out.


Direct link Reply with quote
 

Burrell  Identity Verified
United Kingdom
Local time: 03:09
Member (2004)
English to Latvian
+ ...
TOPIC STARTER
Fuzzy only till the next segment Oct 15, 2005

IF I open/get every segment separately, the translation comes up. So the TM is ok. Then I choose translate to fuzzy and it does - the next segment only. And the document consists of several hundreds small and big segments. So manual method is out of question.
In the meantime I am going on with my snail speed editing in the WB.

What I found interesting is that the segment that is going to loose the formatting after I close it, shows up as no match. So in effect I can see when it is going to have problems, I copy the same text from WB window, paste it, give it the right formatting and I can close it normally and it does not loose the formatting. But it is just so slow...

Thankfully my client is a very understanding person and the end client has driven us up the bend already, so I will get a deadline extension without loosing the face. However it is still frustrating, plus I loose time and subsequently money.


Direct link Reply with quote
 

Heike Behl, Ph.D.  Identity Verified
United States
Local time: 19:09
Member (2003)
English to German
+ ...
fuzzy only until next segment Oct 15, 2005

I had that problem fairly frequently in TE with Trados 6.5. (I haven't used version 7 that much yet). Usually, restarting all Trados related files corrects this problem, sometime rebooting the system is necessary.

Direct link Reply with quote
 

Ralf Lemster  Identity Verified
Germany
Local time: 04:09
English to German
+ ...
Side issues Oct 16, 2005

Hi,
I cannot comment on the formatting issue, but...

This file cannot be processed as TTX because it was saved as a bilingual document in Word).

If a file was segmented in Word, TagEditor cannot 're-segment' it. To use TE on a Word file, you would need to start with the original Word file.

...and regarding fuzzy match that's only running until the next segment:


I had that problem fairly frequently in TE with Trados 6.5. (I haven't used version 7 that much yet). Usually, restarting all Trados related files corrects this problem, sometime rebooting the system is necessary.

Try clicking into the Workbench window once - that was a known bug in T6.5.

Best regards,
Ralf


Direct link Reply with quote
 

Heike Behl, Ph.D.  Identity Verified
United States
Local time: 19:09
Member (2003)
English to German
+ ...
:-) Oct 16, 2005

Ralf Lemster wrote:


I had that problem fairly frequently in TE with Trados 6.5. (I haven't used version 7 that much yet). Usually, restarting all Trados related files corrects this problem, sometime rebooting the system is necessary.


Try clicking into the Workbench window once - that was a known bug in T6.5.

Best regards,
Ralf


Ha, warum einfach, wenn's auch kompliziert geht? (Why do it the easy way if there's also a more complicated way?)

Thanks, Ralf!


Direct link Reply with quote
 

Hynek Palatin  Identity Verified
Czech Republic
Local time: 04:09
English to Czech
+ ...
Paragraph breaks Oct 16, 2005

There was a discussion on the same topic recently. Make sure that paragraph breaks are not marked with the non-translatable style. Search for all paragraph breaks in the original (not pretranslated) document and replace them with paragraph breaks with the DoTranslate style. I am not sure if it will solve your problem completely, but you should give it a try.

Direct link Reply with quote
 

Burrell  Identity Verified
United Kingdom
Local time: 03:09
Member (2004)
English to Latvian
+ ...
TOPIC STARTER
I have learned to live with it Oct 16, 2005

I just have to change formatting before closing the segment, if it is anything else appart from DoTranslate. It took me several hours of error and trial but I have finished at least this file. Mind you, I am not sure how the client will deal with it. Now I just have to hope that the other files do not have the same glitch.
Re paragraph marks. The doc has several hundred paragraph marks. It is not really possible or effective in this case. But thanks for advice, might have to use it in the future (hope not, but who knows!).
I think the way file has been created prevents me to pretranslate it all in one go. There are translatable and non translatable bits all mixed together and I guess it cannot jump over the non-translatable ones. At least that is what happens. So could not use this advice either.

Thank you for the help!
Burrell


Direct link Reply with quote
 

Hynek Palatin  Identity Verified
Czech Republic
Local time: 04:09
English to Czech
+ ...
Paragraph marks Oct 17, 2005

The doc has several hundred paragraph marks. It is not really possible or effective in this case.


You can replace them with a single Search and Replace operation in Word. Search for: ^p Replace with: ^p + formatting


Direct link Reply with quote
 

Burrell  Identity Verified
United Kingdom
Local time: 03:09
Member (2004)
English to Latvian
+ ...
TOPIC STARTER
Never thought of it Oct 17, 2005

Hynek Palatin wrote:

You can replace them with a single Search and Replace operation in Word. Search for: ^p Replace with: ^p + formatting



Of course!! It never crossed my mind. Thanks, I will give it a try.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados 7 changing formatting

Advanced search







Across v6.3
Translation Toolkit and Sales Potential under One Roof

Apart from features that enable you to translate more efficiently, the new Across Translator Edition v6.3 comprises your crossMarket membership. The new online network for Across users assists you in exploring new sales potential and generating revenue.

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search