Pages in topic:   [1 2 3] >
TAG Editor 7 - "Error while writing breaks"
Thread poster: Jerzy Czopik

Jerzy Czopik  Identity Verified
Germany
Local time: 23:09
Member (2003)
Polish to German
+ ...
Jan 11, 2006

Trados: 7.1.0.719 (Build 719)
Windows XP SP II
Office XP SP III
Completly new clean install, performed last Sunday...
Now when I open a Word file to translate it with TAG Editor and attempt to save it then (without starting to translate) inn target format (as Word file) I get "Error while writing breaks". No changes to TAGs are made, but still the file cannot be written.
TAG Editor produces an output file, which is empty, but seems to contain more, as the size is almost exactly the same as the size of the source file.

This does not happen with all files, but only with some...
I send a support ticket to Trados/SDLX, but as I have no support agreement it may take weeks, until they answer. Did someone encounter similar problems and do know a solution?

MTIA
Kind regards
Jerzy


Direct link Reply with quote
 

Piotr Bienkowski  Identity Verified
Poland
Local time: 23:09
Member (2005)
English to Polish
+ ...
Word file from which version? Jan 11, 2006

Jerzy Czopik wrote:

Trados: 7.1.0.719 (Build 719)
Windows XP SP II
Office XP SP III
Completly new clean install, performed last Sunday...
Now when I open a Word file to translate it with TAG Editor and attempt to save it then (without starting to translate) inn target format (as Word file) I get "Error while writing breaks". No changes to TAGs are made, but still the file cannot be written.
TAG Editor produces an output file, which is empty, but seems to contain more, as the size is almost exactly the same as the size of the source file.

This does not happen with all files, but only with some...
I send a support ticket to Trados/SDLX, but as I have no support agreement it may take weeks, until they answer. Did someone encounter similar problems and do know a solution?

MTIA
Kind regards
Jerzy


First, it will not take weeks before SDL support responds.

Second, the DOC file may come from an old version of Word. I've seen such problems already with some DOC files. Open the DOC type a space and save again (use Save as to make sure you have control of the file type as which you are saving the file).

Third, maybe it is an RTF file masquerading as DOC. To check if it is so, drag and drop the file onto a Notepad window. If you see the letters RTF near its beginning and a lot of curly brackets, then its RTF. Otherwise, it isn't. If you tried this trick with Notepad, close Notepad without saving.

Fourth, maybe it is a genuine TE bug...

HTH

Piotr


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 23:09
Member (2003)
Polish to German
+ ...
TOPIC STARTER
It IS Word, 97 to be precise Jan 11, 2006

And not RTF pretending to be Word...
I have no problems with opening the files, I can work with them and save as ttx. But for some of them I canot save the files as Word back.

Before the merge between SDL and Trados I got support responses within two business days, now it takes longer
One could buy a support agreement for a single case (AFAIR) or for limited period of time, now this option vanished. And I was told it will not come back. Bad for me, as I usually had no problems. Now I will probably have to pay the support for the whole year to get ONE single problem solved. Not very efficient IMO.

Nevertheless, thank you for your input.

Regards
Jerzy


Direct link Reply with quote
 

Piotr Bienkowski  Identity Verified
Poland
Local time: 23:09
Member (2005)
English to Polish
+ ...
Some Word 97 files cause problems Jan 12, 2006

Some Word 97 files cause problems in TagEditor 7.1 They simply need to be opened and saved again in a more recent version of Word.

Similarly, Word 97 (which, AFAIR, is not supported by TagEditor) has problems with DOC files from more recent versions of Word, e.g. it might skip part of the text, not display a table, etc. I'm writing from my own experience here.

Regards,

Piotr


Direct link Reply with quote
 

Milan Sochor  Identity Verified
Czech Republic
Local time: 23:09
German to Czech
+ ...
Nichts geholfen Jan 24, 2006

Hallo Jerzy,
es würde mich interessieren, wie Du das Problem gelöst hast. Ich habe nämlich die gleiche Quälerei und bei mir haben bis jetzt alle Ratschläge versagt.
Mit freundlichem Gruß
Milan


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 23:09
Member (2003)
Polish to German
+ ...
TOPIC STARTER
The problems seem to be gone now Jan 24, 2006

But not for sure.

To keep this thread open for all I allow me to summarize Milans post above:
He encounters the same error and wonders, if any solution has been found.

Trados support asked me, which JRE (Java Runtime Environment) I would have. I checked that and found out, that my JRE was outdated. So I went to www.java.com and installed the latest one.
Together with the advice to open the files and save them with a higher version of Word (ie 2000, XP or 2003) and then try again this seems to have done the trick. But I have only tested one of the files I had problems last time, and it was processed smoothly.
Now to be absolutely sure the problem is not more existent, I would need to work on more files, but I cannot do that at the moment, because I have other work to do. As for the previous job, where I wanted to use TAG Editor, I stopped to do so after the second "Error while writing breaks" and processed the files with Word (after all they were not that bad).

Regards
Jerzy

[Edited at 2006-04-17 19:26]


Direct link Reply with quote
 

Milan Sochor  Identity Verified
Czech Republic
Local time: 23:09
German to Czech
+ ...
"Ausweg" Jan 25, 2006

Hallo Jerzy,
Deine Anweisungen haben nicht geholfen.
Ich habe zum Schluß Trados 7.1.0.719 uninstalliert und bin zur Version 7.0.0.615 zurückgekehrt – das funktionierte. Ich weiß, daß es keine befriedigende Lösung ist, aber der Kunde wartet nicht.
Vielen Dank für Deine Bemühungen.
Ich würde von dir gerne hören, ob Deine Lösung bei Dir „endgültig“ funktioniert.
Mit freundlichem Gruß
Milan


Direct link Reply with quote
 

Patrick Boller  Identity Verified
Canada
Local time: 17:09
English to Spanish
+ ...
Source File issue Apr 17, 2006

Hello everyone,

I just encountered this issue, and the way I was able to fix it, at least with the file I had problems with, was to fix the original document.

I have noticed that whenever "breaks" (section, page, etc.) are used in Word, Trados tends to have problems handling them, specifically when the break comes right after the text.

All I had to do was add a carrier return (press "Enter" key) just before the break(s) in the original file (the one Trados looks for to "reimport" the target text into - which has to be in the same folder as the ttx) and the "cleanup" was done perfectly.

No changes were needed on the TTX file.

I was fortunate to have only 1 section break to deal with...

Hope this helps.

Patrick


Direct link Reply with quote
 

Wouter van den Berg  Identity Verified
Netherlands
Local time: 23:09
English to Dutch
+ ...
Temporarily replace section and page breaks with some marker Feb 4, 2007

I just read this *very* helpful thread and feel it my duty to add my two cents', even though it's more than a year after the first post.

This is what DID NOT work for me:

* Saving as a later Word version (Piotr Bienkowski). Problem persisted, even after making very sure I saved it as a later version by pasting all content in a fresh Word 2003 document.
* Updating JRE (Jerzy Czopik). This might have worked, but I didn't manage to do install it, perhaps because of my IE7 settings.
* Using the updated TM to translate the original document - this actually worked, but of course there were many non-matching segments due to the tagging TagEditor adds. In this case, there were just TOO many tagging differences. But it might work for others.
* Adding returns before all section and page breaks (Patrick Boller). Excellent idea in fact - but in my case, the problem wasn't resolved as now I got the "cannot convert Word doc" error. So I tried...
* Saving doc as an rtf, opening rtf with TagEditor and using the updated TM to. Well, I found out that the latest TagEditor version still has trouble opening 98 MB documents. So I had to abandon this effort.

Then I tried a method inspired by Patrick Boller: replacing all page breaks and section breaks with unique markers that would be picked up by Trados - in my case simply with [page break] and [section break] in tw4winExternal style.

This worked... But not without re-translating the source. Because, as it turned out, SOME OF THE BREAKS WERE INSIDE SEGMENTS and that may have been the root of my problem. In my case, it wasn't too much trouble to solve this, as there were just three or four cases (out of 58 replaced break).

After adapting the tagging of these segments I could save the ttx as a Word doc. Of course, I still had to replace the "break markers" with actual breaks, but that was a piece of cake: just used the opposite Search and Replace operation ([page break] -> ^m, [section break] -> ^b).

This solution took me just ten minutes in the end...


Wouter van den Berg

http://www.vertaalbureau.nl
http://www.vertaalbureau.nl/weblog


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 23:09
Member (2003)
Polish to German
+ ...
TOPIC STARTER
Replacing is a great idea Feb 4, 2007

I don't know excatly why it did not work for you, but the "official" solution to this problem is really inserting a paragraph mark before section/page or column break. Trados has problems with section/page or column breaks inserted immediately after the last text character, without a preceeding paragraph mark. In fact they are not intended to be placed directly after the text, but after a paragraph mark - so at least my knowledge.

What happened to me recently was, that there was a page break within a table (in an empty cell on top)! So even with all non-printable characters shown I could not see it. I only found it using the "search" function. Something similar might have been the reason in your case, as you state the breaks were in the middle of some segments.

In the end it is always (almost, to be very honest) the user who creates all the trouble. When used properly, Word makes far less problems, but when do we get properly formatted documents?

Did you install the latest patch by Trados? There are a lot of issues resolved there. I have installed it and it seems, that everything is working allright.

Anyway, I think we can consider this case as "solved" - using your method

Best regards
Jerzy


Direct link Reply with quote
 
Carlos Hernández
Spain
Local time: 23:09
English to Spanish
+ ...
TOC Mar 18, 2007

I had the same problem recently and the cause was not section breaks, but a table of content at the beginning of the document. The TOC was not updated and that seems to cause problems when trying to create the target MS-Word file from TagEditor.

What I did was open the source file with MS-Word, update the TOC and problem solved.

Hope this helps


Direct link Reply with quote
 
Carlos Hernández
Spain
Local time: 23:09
English to Spanish
+ ...
Insert 1 line after images May 4, 2007

I experienced the same problem and I solved it by inserting a line break after each image/graphic.

To do this, open the original word file and replace "^g" with "^&^p", without the quotes. In other words, replace all graphics with the searched text plus 1 line break. Then save the document and open it with TagEditor. Translate and then save the translation back into word format.

The problem seems to be that TagEditor doesn't get along very well with breaks after images, graphics or text boxes. By inserting a line break, the problem seems to be solved.


[Editado a las 2007-05-04 00:04]


Direct link Reply with quote
 

Mikhail Kropotov  Identity Verified
Russian Federation
Local time: 00:09
Member (2005)
English to Russian
+ ...
Thank you, Wouter van den Berg! Sep 5, 2007

I had the same problem and was able to fix it using the steps you described. I am so grateful to you!

Just to make it clear for anyone who might wonder into this thread (it's #1 in Google for the exact phrase "Error while writing breaks", so I would expect quite a lot of visitors), here's what I did:

- replaced page breaks and section breaks with External Trados style placeholders
- re-translated the modified DOC in TagEditor using the TM (Translate to Fuzzy took just a little while)
- successfully converted the TTX to DOC
- back-replaced the placeholders into page/section breaks.

Also, my DOC had lots of line breaks that seemed to present problems when I had tried to translate the file directly in Word. Suprisingly enough, they had no effect on TagEditor at all - they had nothing to do with the "error while writing breaks." I never touched them while troubleshooting this error.

Again, thanks to all you guys for this thread and for ProZ forums in general!

[Edited at 2007-09-05 04:17]


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 23:09
Member (2003)
Polish to German
+ ...
TOPIC STARTER
You do not need to retranslate the document... Sep 5, 2007

Now, after having encountered this problems some few times and better understanding what is the cause, I have a better way to deal with it.
First and of course best is to open the DOC in Tageditor, translate few sentences from the beginning, middle and the end of the file and then trying to save to avoid later problems. At this stage you can easily find those breaks, which are not preceeded by a paragraph mark and insert a pargraph mark there.

However, if your file is ready translated and does not save, you need to open the source file in Word and the translated file in TE parallel. In Word search for breaks, check which are not preceeded by a paragraph mark. Insert a paragraph mark there, where needed. Then search the same place in Tagedior, copy a paragraph mark TAG and insert it just at the same place as in Word. Then you have to save Word, close it, save ttx and try again to save as target. If you did everything right, it will save.

Jerzy


Direct link Reply with quote
 
Paul Godfrey
United Kingdom
Local time: 22:09
French to English
Remove comment boxes as well May 19, 2008

I have found yet another reason why this happens - the presence of comment boxes. Simply erasing all comments from the document worked in my case. Other than this, my favouritre solution is just adding the paragraph marker before a section break as stated above. Why should Trados still have such annoying elementary problems at this relatively late stage in its development?

Direct link Reply with quote
 
Pages in topic:   [1 2 3] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

TAG Editor 7 - "Error while writing breaks"

Advanced search







SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »
LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search