Editing number only segments
Thread poster: Lagom
Lagom  Identity Verified
United Kingdom
Local time: 02:29
Swedish to English
Jul 8, 2006

In a project I am working on there are a number of segments that contain only numbers with source decimal symbol displayed as a comma. As I am translating into English I need to change this to a decimal point but Trados is ignoring these number only segments. How can I change this?

I am using the Workbench/Word combination with Trados 2006 and Word 2003.

Many thanks,

Ben


Direct link Reply with quote
 

Christine Andersen  Identity Verified
Denmark
Local time: 03:29
Member (2003)
Danish to English
+ ...
Expand the previous segment Jul 8, 2006

This irritates me too, but a workaround that sometimes helps is to 'Expand the previous segment'.

(Short cut: Ctrl + Alt + Page Down).

This is useful when Trados divides a sentence after abbreviations like etc. and other abbreviation full stops, before telephone numbers, and when you want to run two Source Text sentences together as one in the translation.

Otherwise the only way I know is to do the job the old way in the cleaned file, but it is admittedly tedious if the numbers are scattered through the text.



Direct link Reply with quote
 
Lagom  Identity Verified
United Kingdom
Local time: 02:29
Swedish to English
TOPIC STARTER
Thanks! Jul 8, 2006

Hi Christine,

Thanks for the input but as you said, I think this is a 'back to basics' editing job in Word!

Ben


Direct link Reply with quote
 

Vito Smolej
Germany
Local time: 03:29
Member (2004)
English to Slovenian
+ ...
Localizing things like numbers Jul 8, 2006

is done in TWB in Translation memory options / Substitution Localisation. It's quite possible your current setup leaves them unchanged.

Regards

Vito


Direct link Reply with quote
 

Peter Linton  Identity Verified
Local time: 02:29
Member (2002)
Swedish to English
+ ...
Search and Replace Jul 9, 2006

I suspect there is a better way, but FWIW I use this primitive Search and Replace:

Search for ([0-9]),([0-9])([0-9]) e.g. 1,23
Replace with \1.\2\3 (+ Use Wildcards) gives 1.23

This is of course only for figures with 2 decimal places. This formula can be adjusted by varying the number of ([0-9]) and \1\2\3 etc and the location of the punctuation character.


Direct link Reply with quote
 

Vito Smolej
Germany
Local time: 03:29
Member (2004)
English to Slovenian
+ ...
"I suspect there is a better way" Jul 9, 2006

Search for ([0-9]@),([0-9]@)
Replace with \1.\2

and dont forget to check the "Use wildcards" checkbox


[Edited at 2006-07-09 13:05]


Direct link Reply with quote
 
Lagom  Identity Verified
United Kingdom
Local time: 02:29
Swedish to English
TOPIC STARTER
Many thanks! Jul 12, 2006

I apologise for the delay in responding, but many thanks for all the very helpful suggestions. Ben

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Editing number only segments

Advanced search







Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search