Workbench 7.5.0.756 closes with error with term recognition enabled
Thread poster: Michael Weise

Michael Weise
Local time: 10:13
German to Russian
+ ...
Jan 3, 2007

Current config: XP SP2, IE 7.0.5700x, Java 1.4.2_08, Java 5.0, all updates.

Just bought SDL Trados 2006 incl. MultiTerm 7.1. Uninstalled the previous version (incl. MultiTerm 6.5 which was useable). Installed the newer 2006 version, attached my old termbase... The just-purchased Trados 2006 Freelance simply refuses to work If terminology recognition is enabled in Workbench, Workbench stops working upon opening of any segment in WinWord. You get a Microsoft error message saying that Workbench (TW4Win) generated an error and needs to close, and that's it.
You can edit segments with term recognition disabled, though. Version 6.5 used to work fine on the same machine. Please help!


Direct link Reply with quote
 

Giles Watson  Identity Verified
Italy
Local time: 08:13
Italian to English
You need to recreate the termbase in MT7. Jan 3, 2007

Hi Michael,

If you have installed MultiTerm 7, you need to recreate your termbases.

This is what the manual says:
>

Once you have installed MultiTerm Desktop you can load MultiTerm 6.x MDB files as follows:

1 In MultiTerm Desktop,select Load External Termbase from the Termbase menu. The Attach Termbase dialog box opens.

2 Enter the location of your MultiTerm version 6.x *.mdb file or click Browse to select the file.

3 Enter a termbase name and click OK .

4 A message appears stating that the termbase has been successfully loaded and you are asked if you want to remove the old version. You may want to keep the old version of the termbase until you are sure that the termbase migration has been successful. You can then remove the old version.

5 From the Termbase menu select Open/Close Termbases . The termbase you loaded is available from the list of available termbases.

6 Select the termbase to open it. Your MultiTerm 6.x termbase should appear in your browse pane.You can now work with your termbase in MultiTerm 7.

>

When you select MultiTerm 7 in Workbench's Terminology Recognition Options, make sure you have browsed to the correct termbase location and that the source and target languages are the right way round.

The above procedure worked for me.

Did you do anything different?

HTH

Giles


Direct link Reply with quote
 

Michael Weise
Local time: 10:13
German to Russian
+ ...
TOPIC STARTER
I guess that I actually did the same Jan 3, 2007

Giles Watson wrote:

If you have installed MultiTerm 7, you need to recreate your termbases.
...
The above procedure worked for me.

Did you do anything different?
Giles


I mentioned attaching my old termbase, but when you try to attach your old termbase to MT7 what you actually do is letting MultiTerm convert your old termbase to the new format just as you described. I guess there is no other way to attach an old termbase to MT7, so I did not do anything different.


Direct link Reply with quote
 

Giles Watson  Identity Verified
Italy
Local time: 08:13
Italian to English
You're also supposed to detach the termbases from MultiTerm 6 first Jan 3, 2007

Hi again Michael,

Did you detach the termbases from MultiTerm 6 before importing into MT7?

MT 7 will read termbases in MT 6 but needs to convert them if you want the benefit of new Unicode-related features (see Article ID: 1537 in the Trados Knowledge Base).

The release notes say:
>
You must attach MultiTerm 6.x termbases as MDB files in MultiTerm 7 and the termbase objects will be reorganised and recreated. SDL recommends the following procedure when upgrading to SDL MultiTerm 7:

1. 1) Detach existing termbases
* For each termbase that is available within your MultiTerm iX Workstation environment, select Termbase > Detach and keep a copy of the termbase MDB file on your hard disk.

2. 2) Install MultiTerm 7
* Uninstall TRADOS MultiTerm iX Workstation and MultiTerm Extract (if available). To do this, use the Remove feature in Add or Remove Programs
* Now install SDL MultiTerm 7 Desktop.
(NB the rest of the instructions are identical to my previous message)
>

Also, what do you see in the Terminology Recognition Options of Workbench? If something is wrong there, these Knowledge Base articles may be of some use:

http://www.sdl.com/trados-support-view.htm?cntID=1440
http://www.sdl.com/trados-support-view.htm?cntID=1378

Cheers,

Giles


Direct link Reply with quote
 

Michael Weise
Local time: 10:13
German to Russian
+ ...
TOPIC STARTER
No, I did not detach anything, but now it works! Jan 5, 2007

Giles Watson wrote:
Did you detach the termbases from MultiTerm 6 before importing into MT7?

No, I just fully uninstalled MT6,5 and installed MT7 afterwards.

BUT detaching shouldn’t actually be that important, 'cause I believe that I managed to fix my problem. I did it on my own, 'cause SDL support didn't even reply to my desperate E-mails. Unexpected Workbench shutdown was a consequence of a MT7 problem and not a Workbench problem. MT7 proved to have some non-obvious limitations regarding spelling of the path to/of the temp folder. To be more specific, I used to have a dot in the path name. All progs worked with that Windows temp folder setting for years, including MT 6.5. There's actually nothing criminal in having a dot in a path name - this fully conforms to the Microsoft file system naming conventions or whatever this spec may be called. Only the wonderful piece of programming called MT7 failed to live with that. As soon as I changed the name of the temp folder(s) to a name without a dot in it MT7 started working (editing and adding entries) and in the same time stopped killing Workbench. Believe me, it wasn't an easy guess to find out what specifically MT7 did not like on my PC, but anyway I made it, I can continue working and I'm proud of myself now.


Direct link Reply with quote
 

Michael Weise
Local time: 10:13
German to Russian
+ ...
TOPIC STARTER
Similar behavior can also be caused by other reasons Jan 7, 2007

Workbench 7.5.0.756 can also close with error with term recognition enabled in case you are attempting to use term recognition when using translation memories created in previous versions of Workbench. Please see my respective posting.

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Workbench 7.5.0.756 closes with error with term recognition enabled

Advanced search







Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »
LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search