Runtime problem with Word
Thread poster: Sherefedin MUSTAFA

Sherefedin MUSTAFA
Netherlands
Local time: 14:22
Member
English to Macedonian
+ ...
Sep 27, 2007

Hi,
Can you pls help me find a solution for the following problem:
I use Word 2003 in Windows XP. Since today the Word application while
starting shows an error (I use the Dutch version an wil try to translate the
error message) saying:
============
Microsoft Visual Basic

Error 5 during execution.
Invalid procedure - call or argument.
============

I have found on the web a thread with the advise to download and install
this file:
http://www.microsoft.com/downloads/thankyou.aspx?familyId=bf9a24f9-b5c5-48f4-8edd-cdf2d29a79d5&displayLang=en

Have done but the problem still exists.
BTW have also deleted the normal.dot file in the hope the new one will fix
the problem, but it didn't change at all.

TIA


Direct link Reply with quote
 

Clelia Tarasco  Identity Verified
Local time: 14:22
English to Italian
similar problem Sep 27, 2007

Hi
I had a similar problem may be caused by a hidden character in a file I was translating
I fixed the problem re-installing Word
Try it and let me know
Have a nice evening!


Direct link Reply with quote
 

Sherefedin MUSTAFA
Netherlands
Local time: 14:22
Member
English to Macedonian
+ ...
TOPIC STARTER
Doesn't help Sep 27, 2007

Cara Clelia,
Thank you for sharing your experience with me.

I’ve tried your suggestion by uninstalling en reinstalling not only Word but the whole Office 2003 from my pc but the problem is still there.

Regards,
Sherefedin


Direct link Reply with quote
 

Fathy Shehatto  Identity Verified
Local time: 15:22
English to Arabic
+ ...
<font color=green>Follow these steps</b></color> Sep 28, 2007

Dear Sherefedin,

I could find the same problem but with starting word 2000 I'm sure it is the same problem.


Question:
When I open Word 2000, this message appears on the screen:

"Microsoft Visual Basic
Run-time error 5
Invalid procedure call or argument".

I click on the "Exit" in this message, and Word 2000 starts working.
Any help?

Answer:
This message is the one, which appears when a template with faulty macros is attached to Word. You must have installed an application using word templates lately, haven't you?

If under Windows XP (or Windows 2000), have a look at this folder:

C:\Documents and Settings\YOURUSERNAMEHERE\Application Data\Microsoft\Word\STARTUP

You should find a few .dot files in here. Close Word and move those .DOT files somewhere else (do not delete them!).

Open Word again. Your error message should not appear again. To find out which template is faulty, just move your template files again in this directory one by one and launch Word each time. When the error message appears again, you'll have your guilty template at hand!

Question:
I followed your advice. The only .dot file I found in ...\STARTUP, is the Trados5 .dot. I moved it elsewhere, I opened Word and the Visual Basic message has gone, but also the Trados set-up in Word has gone too. I need to have Trados5 .dot template in Word!!! What should I do??

Answer:
If the error message has gone, that's because your Trados5.dot template must have gotten corrupted in some way.

You should be able to find a copy of this template in the following folder:

C:\Program Files\TRADOS\T5_FL\TT\Templates

(Well... unless you installed Trados 5 in another directory).

Just copy the one you find here in your Word startup directory, and you should be ok.

If you still have the error message with this new template, I suggest you go to:

http://www.officeupdate.com/ProductUpdates/default.aspx

Click on "Go" in the Check for Office Updates section. It may take a while if you don't have a broadband connection. This script will check your Office installation and tell you if any update/patch is available. It may help.

Best Regards



[Edited at 2007-09-28 06:35]


Direct link Reply with quote
 

Sherefedin MUSTAFA
Netherlands
Local time: 14:22
Member
English to Macedonian
+ ...
TOPIC STARTER
It works again! Sep 28, 2007

Dear Fathy,

Indeed, my Word startup directory contained only the TRADOS8 template.
After removing this template to another place Word started normally.
The next step was to find an old Normal.dot file which I renamed in Old.dot, first copied it the Word Startup directory and after that I returned the template TRADOS8 to the same Word startup directory. Pls don't ask me what the logic of this can be cause I can't follow it anymore.

Thank you very much for this solution.

Best Regards,
Sherefedin


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Runtime problem with Word

Advanced search







Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search